editorinterop.dll or one of its dependencies is missing

  • 2
  • Problem
  • Updated 2 months ago
I get the "Editorinterop.dll" or one of its dependencies is missing error when trying to run Camtasia 2019. I tried every fix I could find or was told to do, but no progress. I ran
-  DISM.exe /Online /Cleanup-image /Restorehealth (no issues)
- sfc /scannow (no issues)
- Re-installed Camtasia 2019
- Downloaded and installed the FREE Camtasia 9 (same error)
- Tried to download the Editorinterop.dll file (64 bit) and put it in C:\Windows\System32 (error unpacking it)
- Automatic Editorinterop.dll fix (virus in program - so aborted)

I run Windows 10 Enterprise on a 2019 Lenovo ThinkPad.

Any ideas? 
Photo of andre.dewaal

andre.dewaal

  • 5 Posts
  • 1 Reply Like

Posted 2 months ago

  • 2
Photo of kayakman

kayakman, Champion

  • 8023 Posts
  • 2775 Reply Likes
recommend you contact free tech support
Photo of andre.dewaal

andre.dewaal

  • 5 Posts
  • 1 Reply Like
I am working with tech support as well, but thought I would post this on the Community forum as well to see if I could resolve this quickly. Thanks.
Photo of Joe Morgan

Joe Morgan

  • 9093 Posts
  • 4795 Reply Likes
Theres an old support article regarding this.
I was looking at it last night and thought it probably isn't much help with windows 10.
There might be a breadcrumb of a clue in there?
https://support.techsmith.com/hc/en-us/articles/115002532187-Camtasia-Windows-Unable-to-Start-Camtas...

Photo of andre.dewaal

andre.dewaal

  • 5 Posts
  • 1 Reply Like
Thanks for the comment. That was the first things I tried (and also suggested by tech support), but it is applicable mainly to Windows 8.1 and older. So no joy there. Downloading Camtasia 9.1.5 also did not solve the issue. Thanks.
Photo of kayakman

kayakman, Champion

  • 8022 Posts
  • 2775 Reply Likes
long shot ... perhaps download/install Camtasia 2020 free trial; any help?
Photo of andre.dewaal

andre.dewaal

  • 5 Posts
  • 1 Reply Like
Same error. Thanks for the suggestion.
Photo of Dubie

Dubie

  • 1685 Posts
  • 1411 Reply Likes
Try downloading and running the Microsoft Visual C++ redistributable package.

That was a fix that worked for Camtasia version 2018

You can get it here.

https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads

Make sure to get the one for your system which most likely will be the x64 download




Dubie:)


Photo of andre.dewaal

andre.dewaal

  • 5 Posts
  • 1 Reply Like
Success. Thank you. Installing Microsoft Visual C++ 2015-2019 Redistributable (x64) solved the problem. I had Microsoft Visual C++ 2008 redistributable installed.

It is a fix now for Camtasia 2019 as well.

Thanks again. Great feedback. Much appreciated.
Photo of Dubie

Dubie

  • 1683 Posts
  • 1411 Reply Likes
Glad you got it working.

Now go have some fun !!


Dubie:)