ERROR: The Project file cannot be opened. Make sure the selected file is a valid .camproj file.

  • 15
  • Problem
  • Updated 5 years ago
Please help!

I have recreated my Camtasia video three times, and it's driving me nuts. When I try to save my project, it goes smoothly. I even exported to zip files just to make sure.

But when I open up the saved camproj files, and even when I use the "import zipped project..." I get this same error. It looks like a valid camproj file, so I feel like this error message is catching some other error instead.

Also, when I was completed with my video and tried to publish, an error popped up then as well. My project includes a few of the built-in effects (transitions, audio edits, zoom n pan, callouts), mp3 files, jpegs, and screencapture vids. I am using the Trial version of V8.0.1 on Windows 7 Enterprise.

Thanks,

Sami
Photo of Sami

Sami

  • 3 Posts
  • 1 Reply Like
  • frustrated!

Posted 8 years ago

  • 15
Photo of Sami

Sami

  • 3 Posts
  • 1 Reply Like
Has anyone else had this problem?
Photo of Cyril Chiquet

Cyril Chiquet

  • 3 Posts
  • 1 Reply Like
Yes I had.
Photo of Gaz Davis DeWolfe

Gaz Davis DeWolfe

  • 4 Posts
  • 0 Reply Likes
Me too
Photo of Jose Luis Ansó Gonzalez

Jose Luis Ansó Gonzalez

  • 1 Post
  • 0 Reply Likes
Me too
Photo of Frank Schubert

Frank Schubert

  • 1 Post
  • 0 Reply Likes
we too
Photo of Mike Curtis

Mike Curtis, Employee

  • 2204 Posts
  • 220 Reply Likes
Hello Sami,

I think in this case it would be best if you could open a case with our support team and attach the zipped project. Sorry for the trouble and inconvenience.

You can open the case here and they should reply within one business day: http://techsmith.custhelp.com/app/uti...

Sincerely,
Mike Curtis
Photo of Sami

Sami

  • 3 Posts
  • 1 Reply Like
Hi Mike,

Thanks for the quick response. I just figured out the problem- I named one of my screen capture files with an "&" sign. I finally realized that whenever I added this particular file to the clip bin the project would no longer save and reopen properly! I would recommend creating a catch for illegal characters for the next update, cuz I lost a lot of hours of work today!

Thanks again for getting back to me.

Sami
Photo of Randy Schott

Randy Schott

  • 396 Posts
  • 47 Reply Likes
Just a shot in the dark: We saw a user in Tech Support last week with the same problem. Turned out they had an ampersand (&) character in their project name (and one of the camrecs) that caused our XML parsing to not work correctly after saving. Do any of your media have an ampersand in the file name, or did you save the project to a file name that includes that character?

It's a confirmed bug that we're addressing for a maintenance release.

If that's not it, then Support will be your best route.

Randy
Photo of julink

julink

  • 2 Posts
  • 3 Reply Likes
Hi Randy, First of all , Congrats , the 8 Verse is really Great ! (excuse my english i'm frensh).
Regarding my Issue ..., Since i included in my project a camrec. file named with an ampersand , it's impossible to open the project ... then i tryed to rename the bad file but it's still impossible to open it ... honestly it's 2 days of work and i'm in a very big RUSH ... do you think that i could imagine to restore the project ? and how ? ...
Please save me : )
Photo of Cyril Chiquet

Cyril Chiquet

  • 3 Posts
  • 1 Reply Like
I had the same problem, I had (&) character in the file name. I had no idea that was the problem!

I changed it in the file name and also open the the file as XML with Notepad ++ and search for the (&) character and changed it to (and). I saved it and tried to open the project file and it worked!

I was getting very frustrated as it was the second time I re did the editing and it happened again and I had no idea why. So I am happy that I could make it work and did not have to do everything again.

Though I think it is dumb that the program does not support the (&) character.

Hope you manage to fix it like I did.
Photo of Beth Miller

Beth Miller

  • 1 Post
  • 0 Reply Likes
I had this problem as well, but there is no "&" anywhere in my file name. I have spent hours working on this project and it won't open no matter what I do. Help!
Photo of Cyril Chiquet

Cyril Chiquet

  • 3 Posts
  • 1 Reply Like
Do you have any other character beside letters?
Photo of kayakman

kayakman, Champion

  • 8068 Posts
  • 2785 Reply Likes
Does the project contain camrec files created with CS7?
Photo of CATERAF

CATERAF

  • 7 Posts
  • 0 Reply Likes
I have the same problem.
It MAY have a CS7 file in it.
I started off with no CS7 files and then i brought one in - not sure at what point though because CS8 was working fine and then a day or two later it crashed.
I would've noticed if it had happened immediately.

I also have no ampersand in my title.
Photo of Marisol Pardillo

Marisol Pardillo

  • 6 Posts
  • 0 Reply Likes
same here. This is frustrating.
Photo of Gaz Davis DeWolfe

Gaz Davis DeWolfe

  • 4 Posts
  • 0 Reply Likes
Same here.
No ampersand. Did have a # in a wma title name renamed the wma file and changed the xtml to stop searching for "fox3#.wma" but it still won't open the file.
Photo of Joseph E Trey

Joseph E Trey

  • 4 Posts
  • 0 Reply Likes
I am having this problem too. I am on a brand new PC - Pavilion m6 with GB of RAM - I completed a project - rendered it then came home and tried to work on it - when I receive the ERROR: The Project file cannot be opened. Make sure the selected file is a valid .camproj file.

I have poured over the XML file - and the only "&" is in the XML code - not in any file names - nor are there any other special characters.

My one theory is am storing my files in a DROPBOX folder and this may have caused a problem (similar to network drive issues?) - however - I have 2 previous edits of the same file (with different names) in the same folder and they open fine.

I am going to see if I can submit my XML file to Tech Support for review - if I hear anything I will be sure to submit it here.
Photo of Joseph E Trey

Joseph E Trey

  • 4 Posts
  • 0 Reply Likes
it appears to be connected to having an exteranal drive connected WHILE I was editing. While I did not save anything to this drive - nor did I reference any files - (or so I thought)

Upon closer inspection ONE file - which I thought had been copied locally - was in fact still being referenced on the external drive.

Being able to edit the XML PATH (which is really nice - since you cannot do this with many zorched files) allowed me to change the reference of the effected file. Then file then worked without issue.

EXAMPLE:

ADDITIONAL STEPS:To be extra sure, once it opened, I zipped the entire project to a new folder - disconnected the drive and tried to relaunch - all is now right with the world - not sure if this will help anyone else - but I wanted to post it here.

i was using the COPY TO LIBRARY OPTION - NOT the LINK TO CONTENT Option in Camtasia - so I did not think this could happen - I will be looking more into how that feature works -

Hopefully, this helps somebody - basically - look at your project file in a text editor and make sure there are no external references that you are not connected to. Simply solution - but a bit confusing.
Photo of Joseph E Trey

Joseph E Trey

  • 4 Posts
  • 0 Reply Likes
One last thing - I noticed something else - that I have reported to Tech Support as well -

SUGGESTION- rather than having the error say "ERROR: The Project file cannot be opened. Make sure the selected file is a valid .camproj file" - it would really help if the error was FILE NOT FOUND - and allowed the file to be located -

I noticed if the DRIVE is the same - but the path is incorrect this is the behavior - however - if the Drive cannot be found then the file throws the error above - perhaps chaning this would help, if it is possible.
Photo of CATERAF

CATERAF

  • 7 Posts
  • 0 Reply Likes
For mine, I have it on a server that I connect to, but no file locations have changed and it can open half my CS8 files but not all the different saves of it?
Photo of Gaz Davis DeWolfe

Gaz Davis DeWolfe

  • 4 Posts
  • 0 Reply Likes
I have also moved my assets out of the dropbox and I still can't open it.
Photo of AV Guru

AV Guru

  • 2 Posts
  • 1 Reply Like
I have wasted over a week trying to get a solution to this issue from Support. I have sent almost 2GB of camrec, library resources and audio collateral to Support and have received no clear indication on the issue, I have no strange characters in my file names and project names, no Camtasia 7 files in any of the projects and am using an HP dv7 with many MANY times the system recommendations.

I am moving to Premiere Pro CS6 to edit my screencasts. Thanks for the new codec on the screen records Tech Smith. Your video editor is a piece of crap. Fix it please or stop claiming to be a professional product, it sure isn't worth what you charge for it in it's current state.

Photo of Jose

Jose

  • 3 Posts
  • 0 Reply Likes
Same here.
Photo of AV Guru

AV Guru

  • 2 Posts
  • 1 Reply Like
After abandoning this issue, I looked into some other symptoms of this problem and discovered some interesting stuff.

I did a major system registry scrub and have not had any problems since. It will be fun to see if this is a solution or just a quick fix..... whee. I just want to say how UN-helpful Tech Smith's support has been, I am pretty sure they closed my ticket because they couldn't find a solution to my query.

For all those struggling to open .camproj files that they have created in Camtasia Studio 8 (I NEVER tried to open any CS7 files in version 8, so that was never an issue for me) and keep getting invalid errors, try a safe system registry clean up. I don't want to give Camtasia any excuse to take down my message so all I'll say is do some research and find a Microsoft approved ISV that can do the job. WARNING! doing this can mess with settings of drivers etc, so make sure you know what you are doing!

PS this also seemed to help the incessant crashing...

Be well!
Photo of Ed Soria

Ed Soria

  • 6 Posts
  • 1 Reply Like
Wow, it looks like I'll be moving my screencasts to Adobe Premiere Pro too. This problems has been ongoing for many years. WTH?!
Photo of Marisol Pardillo

Marisol Pardillo

  • 6 Posts
  • 0 Reply Likes
Downloaded the trial because other team members purchased the full version and it keeps crashing. Hopefully there will be a fix soon.
Photo of Marisol Pardillo

Marisol Pardillo

  • 6 Posts
  • 0 Reply Likes
I have the latest version, so I know that is not that issue. There are no ampersands in my file names or weird characters. I'm working on a project that needs to be completed asap but I'm skeptical to purchase the software if it doesn't work.
Photo of Jose

Jose

  • 3 Posts
  • 0 Reply Likes
I'm totally agree with you :((
Photo of kayakman

kayakman, Champion

  • 8068 Posts
  • 2785 Reply Likes
Are you using CS8 8.0.2?

Is the project from CS7?

If from CS7, suggest you load that project in CS7, export as zip, then import and convert in CS8. Does that work?

Some suggestions [not knowing what the project looks like] ...

markers?
captions?
hotspots for flash?

Run the project from your local HD.

In CS 7, first simplify the project as much as possible [convert audio tracks to single WAV files each]

Still in CS7, if not using markers or hotspots, make a full project AVI; export any captions. In new CS8 instance, create new project using the AVI and imported captions.

FYI, since 8.0.2, I have not had a conversion failures. However, because I only have a 2 GB RAM system, some converted projects will not load [too complex, out of memory]. I have been able to simplify these first in CS7, then either convert the simplified project in CS8, or rebuild in CS8 as a new project from things like full project WAVs, exported/imported captions, full project AVIs.
Photo of Marisol Pardillo

Marisol Pardillo

  • 6 Posts
  • 0 Reply Likes
Wow, that's one heck of a workaround but at this point I will try anything. I was created in 8.0.2 but I will try opening it in 7 just in case. No markers or no hotspots but definitely captions. Everything is running locally.

I will give it a try and see what happens.
Photo of Marisol Pardillo

Marisol Pardillo

  • 6 Posts
  • 0 Reply Likes
Nothing. It says the file was created in a newer version. I'm going to have someone else try to open it and see if maybe it is just my software that has an issue.
Photo of kayakman

kayakman, Champion

  • 8068 Posts
  • 2785 Reply Likes
OK; if the project was created in CS8, you cannot open it in CS7.

Can you describe the project? What is origin of the source files? Describe its complexity, how long in time, editing dimensions, recording dimensions, callouts, cursor effects, zoom pans, etc?

I assume after you created the project, you manually saved it before closing?

It is possible your camproj file is corrupted.
Photo of Marisol Pardillo

Marisol Pardillo

  • 6 Posts
  • 0 Reply Likes
Hi Kayakman,
I have tried everything. The project is about 5 minutes in length. It contains 1 mp4, 1 swf, captions, highlight boxes and 21 audio files. No zooms or pans. Just highlights around screen shots from the captivate animation. The project was saved manually before closing.

I have tried several different files and it happens with all of them. I can open it, create it and once I save it, then I cannot reopen it again.

I am going to keep googling. Someone has to have the answer. I really don't want to start from scratch.
Photo of kayakman

kayakman, Champion

  • 8068 Posts
  • 2785 Reply Likes
Marisol, where did the MP4 and SWF files come from?

As a test, perhaps try this ...

Play the MP4 and SWF in some pl;ayer while capturing with Camtasia Recorder.

Use those captures to rebuild the project video-wise.

21 audio files in 5 minutes is a lot; where did the audio files come from?

If the audio is narration, try re-narrating using Voice Narration or Audacity to get new audio content

Do some typical editing; does this new project work?
Photo of CATERAF

CATERAF

  • 7 Posts
  • 0 Reply Likes
Hi Marisol,

I don't think it's the volume of audio files that is causing the problem. I'd have about that in the space of about 3.5 minutes for my video.

I'm curious about the mp4.. has that been in there the whole time? Was it an mp4 created with a different version of camtasia?

I tried importing an mp4 file and I had the same problem come up shortly after.
In saying that though, mine was a case of it giving me the error and then any opens after that would fail. It wasn't a case of it saves fine and then just won't open.

Hmm.. has techsmith responded to your ticket?
Photo of Jeff Clampitt

Jeff Clampitt

  • 1 Post
  • 0 Reply Likes
Same problem. No special characters in file names. What gives?!?!?
Photo of ms

ms

  • 162 Posts
  • 22 Reply Likes
I have been getting this since v8 came out but never got it ever with v7.

I have narrowed down what could be causing it to occur with my projects.

I import a narration file that has been created and edited in Adobe Audition.

This is fine as long as I don't make ANY further edits to the audio file back in Audition. If I do, then v8 does not recognise the project.

I used to do this all the time with v7 - i.e. import a 'finished' narration file onto the timeline but then make minor edits as the project developed.

This now does not work in v8 and, yet again, caused me to scream 'Aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaagggggggggggggggggggggggggggggggggggggggggggghhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhh', yesterday.

I notice other audio issuses too with v8's recognition of Audition audio but I'll leave that for another thread.
Photo of Nina

Nina

  • 1 Post
  • 0 Reply Likes
Hi all,

I've got the same problem: A colleague created a camrec file with Camtasia 8.0 (test version) and uploaded it to our FTP server. I upgraded my 7.0 version to 8.0, downloaded the file from the server and tried to open it. Error message: the project file cannot be opened. Make sure the selected file is a valid .camproj file. It is, without any special characters.
That's really frustrating... Any ideas?
Thanks!
Nina
Photo of kayakman

kayakman, Champion

  • 8068 Posts
  • 2785 Reply Likes
some possible confusion here?

a camrec file is a video capture in a special Camtasia container; it will contain an AVI, and other stuff. You can extract the AVI if you want

a camproj is a Camtasia Studio project file; it is a XML like descriptor of what's on the timeline when you make a project.

you should be able to take a camrec and load it on the CS8 timeline.

but in order to open any camproj file, all the associated project files must be with it.

a camproj file, by itself, is of no value.

a camproj that has been exported as a zip can be imported in Camtasia and should open because all the associated project files will be in the zip archive; importing the zip extracts the archive and should give you a project folder, with a camproj and all the project's source files.
Photo of e learning

e learning

  • 2 Posts
  • 0 Reply Likes
I am having the same problem. There is also a terrible hum in the audio. It was a lot of work to develop the project and I can't believe I have to start all over again. Has anyone come up with a solution?
Photo of Abby Gail Alpert

Abby Gail Alpert

  • 1 Post
  • 0 Reply Likes
I'm having the same problem too but eff it, I'm starting over & turning all my cam files into AVI format. So hopefully this time it doesn't happen, and if it does I'll be able to open it in WMM at least. Sick of waiting.
Photo of CATERAF

CATERAF

  • 7 Posts
  • 0 Reply Likes
Not sure why they removed my reply before, but I just said contact Tech Support ASAP because they don't seem to check here (or if they do, they don't reply much!). Tech Support get back to you reasonably fast and may help. Also, make sure you have the latest version downloaded - that helped me.. though it didn't solve my problem completely.

All the best!
Photo of kayakman

kayakman, Champion

  • 8068 Posts
  • 2785 Reply Likes
are you planning on extracting the AVIs from the camrec files?
Photo of Colleen

Colleen

  • 8 Posts
  • 0 Reply Likes
same problem here... on camtasia for mac... I tried removing the & from the XML files and changed the name of the one recording with & but... no ... no luck... I too have lost tons of hours of work... any way to at least salvage my recordings?
Photo of Dave Butt

Dave Butt

  • 1 Post
  • 0 Reply Likes
I'm encountering the same issue for Mac. I have been working on this project for a week and have never had issues with saving or anything. Now when I try to open the .cmproj file I get the message "The document could not be opened" with no further explanation.

This has been a very negative first experience with this program.
Photo of Gaz Davis DeWolfe

Gaz Davis DeWolfe

  • 4 Posts
  • 0 Reply Likes
I don't have any ampersands in any of the files I used, but I had a # in one of the WMA files I was using, made the change and it still won't open.
Starting to think the projects a lost cause and the last week of my life have been for naught.
Photo of kayakman

kayakman, Champion

  • 8062 Posts
  • 2785 Reply Likes
suggest you log this as a case with tech support
Photo of Mark Nowowiejski

Mark Nowowiejski

  • 30 Posts
  • 0 Reply Likes
I am having this issue too - file opened fine all week and now friday morning with it 90% done it won't open
Photo of Grégory Makles

Grégory Makles

  • 6 Posts
  • 1 Reply Like
Same here. This is insane. One week of work is lost, it's unthinkable - it's several time the cost of the software that my company should charge to Techsmith.
Photo of Colleen

Colleen

  • 8 Posts
  • 0 Reply Likes
My conversations with tech support suggested that sometimes the XML file saves incorrectly and they suggested renaming it at project.XML where mine somehow saved as ~project.XML. Also... I had taken to saving my work onto dropbox where I can at least go back to an earlier version using dropbox's wonderful history options... I didn't get everything back but most of it at least. I'm now really careful in how I name my images etc and save frequently on dropbox... Hoping this will do the trick as I really do like the functionality of the program.
Photo of Grégory Makles

Grégory Makles

  • 6 Posts
  • 1 Reply Like
I don't get your comment. My project are .camproj and there are no ~ anywhere to see. It's true that on opening save file they're holding xml content but I don't get how your suggestion may apply.
Photo of Colleen

Colleen

  • 8 Posts
  • 0 Reply Likes
Yes, inside the package contents of the cmproj is a document called project.XML... I'm just sharing what I was told and it seemed to do the trick for me... But I'm no expert.

This conversation is no longer open for comments or replies.