Extend Frame Preview Glitch

  • 1
  • Problem
  • Updated 1 year ago
I recently upgraded to the latest version of Camtasia for Windows and I am experiencing a bug with Extend Frame. I have a long period of screen video with no movement, which ends when the mouse cursor moves. I wanted to extend the still period by a few seconds to sync up with my voice. However when I do so, the preview displays the extended frame to be the first frame of movement after the still period, and when the extended duration ends, it reverts to the correct (still) frame. This happens regardless of the duration I choose or even what frame in the still period I extend. When I batch production the mp4 displays the extended frame correctly, so it is only a bug in the preview. Is there anything can be done about this? It's making editing difficult.
Photo of tkehne

tkehne

  • 7 Posts
  • 0 Reply Likes
  • frustrated

Posted 1 year ago

  • 1
Photo of kayakman

kayakman, Champion

  • 7221 Posts
  • 2412 Reply Likes
I am not able to reproduce your issue

could you make a short screencast demonstrating what you do to make it happen; please host on screencast.com
Photo of tkehne

tkehne

  • 7 Posts
  • 0 Reply Likes
This is the frame right before the extended frame. The screencapped video was identical to this for several seconds leading up to this as well, and about a second after the extended frame. The extended frame should also look the same:
http://www.screencast.com/t/ysGS0llDJL7

This is what the extended frame actually looks like. It appears this way for the entire duration. Notice the altered position of the mouse cursor in the screencapped video relative to the previous image:
http://www.screencast.com/t/i2I3Aod1

This is the frame immediately after the duration of the extended frame. Notice how the mouse cursor has reverted back to its original position:
http://www.screencast.com/t/t7qaehg169wK

And finally, this is the first frame in the screencapped video after this where the mouse starts to move. Notice how it is identical to the appearance of the extended frame:
http://www.screencast.com/t/6LkhHGfug

Again, this issue is only in the preview. When I batch production, the extended frame appears as it should in the mp4. Also, this is the only time I have had this issue with extend frame. I extended many frames in this video both before and after this point, with no discrepancies. My guess is that it's an error with how the video is decompressed for preview playback.
Photo of kayakman

kayakman, Champion

  • 7221 Posts
  • 2412 Reply Likes
thanks for the screen shots

just to be sure, are you extending a frame off a trec clip? [can't tell from the images]
Photo of tkehne

tkehne

  • 7 Posts
  • 0 Reply Likes
Yes, it was a trec recorded with Camtasia.
Photo of kayakman

kayakman, Champion

  • 7221 Posts
  • 2412 Reply Likes
thanks for the confirmation

I took a new trec capture that had a pause in action, then mouse movement, and tried to duplicate your experience; but no luck; extended frames seemed to come out as expected

have you tried making another test trec, with a pause, then mouse movement to see if it happens again?
Photo of tkehne

tkehne

  • 7 Posts
  • 0 Reply Likes
Yeah, I've made about a dozen. This is the only time this has happened. There must be some other condition that causes it to happen. I'll be keeping an eye out to see if happens again. I don't like this though; it makes me feel like I can't trust the preview to make sure things sync up.
Photo of Robert R.

Robert R., Online Community Admin

  • 1614 Posts
  • 514 Reply Likes
Hi tkehne;

As a test can you please open Camtasia and go to Edit - Preferences - Advanced and set Hardware Acceleration to "Use Software-only mode" then restart Camtasia. Once restarted, can you try duplicating the issue?

-Robert
Photo of tkehne

tkehne

  • 7 Posts
  • 0 Reply Likes
Robert,

That does indeed fix the issue. Does that mean it's an issue with the graphics card? My PC has an AMD Radeon R7 M260. I imagine software-only has a significant performance penalty so I hope it can be resolved.
Photo of Joe Morgan

Joe Morgan

  • 7546 Posts
  • 4136 Reply Likes
It means TechSmith needs to resolve this problem.

So for now,odds are. You're better off using Camtasia 9. Which you can download and activate with your Camtasia 2018 key.

https://www.techsmith.com/download/oldversions

After 2 months without a patch for glitches related to GPU acceleration.

Camtasia 9 is currently the most reliable choice overall. "In my opinion"

Regards,Joe

Photo of tkehne

tkehne

  • 7 Posts
  • 0 Reply Likes
OK. Thank you kayakman, Robert and Joe for your help! Should I submit a tech support ticket to notify the devs or will they see it here?
Photo of tkehne

tkehne

  • 7 Posts
  • 0 Reply Likes
OK. Thank you kayakman, Robert and Joe for your help! Should I submit a tech support ticket to notify the devs or will they see it here?
Photo of kayakman

kayakman, Champion

  • 7221 Posts
  • 2412 Reply Likes
suggest you do a ticket, just to formally get it on the record; that way, the devs should get the input