External microphone doesn't show up in my Camtasia audio options?

  • 2
  • Question
  • Updated 6 months ago
My external microphone doesn't show up in the audio options when I want to record with Camtasia Mac. But it shows up in my IOS Settings. How can I use my external Mic to record audio with Camtasia?
Photo of Po Borrow

Po Borrow

  • 3 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 2
Photo of erik.groenhaug

erik.groenhaug

  • 84 Posts
  • 31 Reply Likes
I think TS should answer this. Setting a device as default input in the OS, should define that device as default also in CS9 - Should not matter whether this is OSx or windows.
Photo of Po Borrow

Po Borrow

  • 3 Posts
  • 0 Reply Likes
I tried to find for the option to define an input as default. but couldn't find the option. where is that?
Photo of erik.groenhaug

erik.groenhaug

  • 84 Posts
  • 31 Reply Likes
Sorry - I ment setting one device for input in system should be reflected in the applications as well
Photo of davemillman

davemillman

  • 461 Posts
  • 141 Reply Likes
Are you able to record in another app with the external mic in question? If so, are you able to switch between that mic and the internal mic in that app? 

The only thing that causes mics to be unavailable on my system is when I plug in the microphone after launching the app. Quit Camtasia, plug in the mic, test the mic, then launch Camtasia. 
(Edited)
Photo of Po Borrow

Po Borrow

  • 3 Posts
  • 0 Reply Likes
yes I tested it with 2 other applications and works with the external microphone.

only in camtasia I have onl this option: https://www.evernote.com/l/AKs2hgLZ829Brop-nTBHTuLEfhbKMEY_OVk

what should I do?
Photo of erik.groenhaug

erik.groenhaug

  • 84 Posts
  • 31 Reply Likes
Just checked on my Imac. No problems getting CS3 to recognize my scarlett external audio device.
Photo of Glenn Buck

Glenn Buck

  • 3 Posts
  • 0 Reply Likes
I'm dealing with the same issue.  I bought an expensive condenser USB microphone to make superior audio recordings.    It was working fine in Camtasia Mac until I did an update.   Since then, my USB microphone no longer displays as an option.   It works fine for all other recording software...just not on Camtasia.   Camtasia is the only reason I bought the mic.   Now I'm just frustrated.   I went into the system via utilities and audio midi setup and changed the 44.1 format to 2 channel 16-bit integer...with no success.
Photo of davemillman

davemillman

  • 461 Posts
  • 141 Reply Likes
Very odd. I've connected several microphones to Camtasia Mac 2 & 3 without problems. This should go to TechSmith support. We'd love to hear the answer when it comes!
Photo of erik.groenhaug

erik.groenhaug

  • 84 Posts
  • 31 Reply Likes
So the simple question to techsupport is: where do you see what devices that are ready for use in recording?
Photo of randolph.kahle

randolph.kahle

  • 1 Post
  • 0 Reply Likes
I had a similar thing happen. I am using a Rhode Podcaster - works fine all all Macs except my Mac Mini. In fact it did work on the Mac Mini until I did a software update on Chrome. Now I cannot use the microphone drop down selector as it is disabled.
Photo of Peter Figliozzi

Peter Figliozzi

  • 1 Post
  • 0 Reply Likes
Using Camtasia 3.0.4.  USB mic must be plugged in before running the program, else it will not be recognized.
Photo of mai-lan.rogoff

mai-lan.rogoff

  • 3 Posts
  • 0 Reply Likes
I have the same problem - Camtasia 3 not recognizing external mic (Blue snowball) which is plugged in BEFORE I start Camtasia. Restarting computer also did not help. Camtasia 2 works flawlessly.
Photo of davemillman

davemillman

  • 461 Posts
  • 141 Reply Likes
mai-lan.rogoff,

Do other applications on your mac recognize the Blue Snowball? 
Photo of mai-lan.rogoff

mai-lan.rogoff

  • 3 Posts
  • 0 Reply Likes
Camtasia 2 does, and records from it very nicely
Photo of mai-lan.rogoff

mai-lan.rogoff

  • 3 Posts
  • 0 Reply Likes
I also don’t get any sound from Camtasia 3 when I disconnect the Blue and try to record from the internal mike on the computer. I'm selecting the toggle for mic after hitting the record button, so that's not the problem.
Photo of Joe Morgan

Joe Morgan

  • 5054 Posts
  • 2630 Reply Likes
Perhaps contacting support will resolve your issue.

This is a Free Service............... Submit a ticket


       https://support.techsmith.com/hc/en-us/requests/new

Or call, >>>

 Toll Free: 800.517.3001 (U.S. & Canada Only)

8:00 AM to 7:00 PM EST Monday through Friday

Regards, Joe

Photo of sponderb

sponderb

  • 4 Posts
  • 0 Reply Likes
I have a sanheiser headset that plugs into the mic hole that ios recognizes but Camtasia doesn't recognize it. I've tried various combinations of starting Camtasia with the mic plugged in and the opposite. Using iMac with High Sierra. Help.
(Edited)
Photo of ph

ph

  • 4 Posts
  • 0 Reply Likes
Finally!

The sliders don't work as sliders - if you just CLICK in the grey area or the green area then the controls all work perfectly.
Photo of sponderb

sponderb

  • 4 Posts
  • 0 Reply Likes
Nope, mine just move to the on, if off--and reverse if I click on the green. However, it seems to be picking the external mic selection, but recording from recording audio from my headset, as I test it at a distance with whispers. An acceptable workaround but not quite as advertised.
Photo of ph

ph

  • 4 Posts
  • 0 Reply Likes
Sorry that didn't help - two other ideas:

1. Go to  Camtasia Preferences - Recording - System Audio - Uninstall - Say No - and try again.

2. Same as above but say yes and re-install.

And that empties my Ideas Bucket!
Photo of sponderb

sponderb

  • 4 Posts
  • 0 Reply Likes
SOLVED. When I change the preferences on the Mac, the external mic selection replaces the built-in Mic, so for all intents and purposes, it becomes the internal mic. Thanks for the help.
Photo of ph

ph

  • 4 Posts
  • 0 Reply Likes
Great to hear! I know from bitter experience how great it is to find a solution!

Let's hope our struggle helps someone else!

Best wishes.
Photo of ben

ben

  • 1 Post
  • 0 Reply Likes
I'm also having this problem on my 2012 Macbook Pro on High Sierra with a Focusrite Scarlett 18i8 interface. It is recognised and working successfully in other apps like Logic Pro X.

It also worked fine on my Mac Mini on Sierra with Camtasia 2 - since upgrading the computer and making the switch to Camtasia 3 it doesn't get picked up whether I plug it in first or second.

The interface is set in system settings as both input and output device and it doesn't take over the internal mic setting in Camtasia for me - I'd had that idea and a quick test showed that the internal option is still just using the internal mic from the way it's picking things up.

I would love a solution to this, it's incredibly frustrating.
Photo of James Malloch

James Malloch

  • 1 Post
  • 0 Reply Likes
I was struggling with this for a while but found a solution. When you first click "record" on Camtasia 3 it will bring up a dialogue box that includes choices of what you'd like to record. The box furthest right lets you activate System Audio, the one just to the left of that lets you activate "Built-in Input" After clicking that one green, you still have to click on the words "Built-in Input" and change it to "Built-in Microphone" if you want your designated mic to actually record. Hope this helps!