Failed to load main frame, again.

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
I have recently tried the trial of Snagit 13, and unfortunately (along with Snagit 12 also) does not fit my needs nearly as well as Snagit 11 or 10 did so well. Upon deciding that it I had tried 13 enough to give it a fair shot, I then was ready to go back to my previous install of Snagit 11(yes, I uninstalled Snagit 11 before running the Snagit 13 trial). Snagit 11 is the last version I have a paid license for.

After Snagit 13 trial was uninstalled ,and with Snagit 11.4.3.280 reinstalled, I began to go about my work on the computer as usual. As soon as I took my first screenshot (and every one thereafter) SnagitEditor would not launch and I would get the error “Failed to load main frame.”

This was the first time I had ever seen this error after years of using Snagit 11. I came here looking for others with this issue and did see in fact that there were others, and that a fix had been presented:
https://feedback.techsmith.com/techsmith/topics/why-am-i-getting-failed-to-load-main-frame-error-and...

Note: I have also uninstalled Snagit 11.4.3.280 and went back to my older Snagit 10.0.2 which is still excellent in my opinion. Unfortunately the exact same error persists through version 10!

So when I read:
https://www.techsmith.com/snagit-version-history.html

17 March, 2015: Snagit v12.3.1

  • Fixed issue with “Failed to load main frame” error
This doesn't help me if I am using v10 or v11!

I also have read:
https://support.techsmith.com/hc/en-us/articles/205317917

Which sounds promising. I have downloaded the MainFrame.zip from Nate, but have not been able to successfully merge the registry edits from the files "regfile" and "regfile2."

I have closed all Techsmith/Snagit running processes, and am using a user account with Admin privileges but get an error from the Registry Editor for both files which say:

"Cannot import D:\Desktop\regfile.reg: Not all data was successfully written to the registry. Some keys are open by the system or other processes, or you have insufficient privileges to perform this operation."

Any help with getting me back to a state where I can use my previously working Snagit 11 would be much appreciated.

Thank you.
Photo of Mark K

Mark K

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 2 years ago

  • 1
Photo of Joe Morgan

Joe Morgan

  • 5638 Posts
  • 2924 Reply Likes
I believe SnagIt 11 is no longer officially supported.

However, that might help you anyway.
I would contact a human being directly through the phone or chat and explain what went wrong.Odds are, "I'm guessing here" they will try to help you out.

This is a Free Service...............You can Contact CHAT or Submit a ticket

       https://support.techsmith.com/hc/en-us/requests/new

Or call, >>>

 Toll Free: 800.517.3001 (U.S. & Canada Only)

8:00 AM to 7:00 PM EST Monday through Friday

Regards, Joe

Chat Support Hours.

You can reach the “CHAT” Support Team for assistance from

 6:00 AM to 9:00 PM ET, Monday-Friday

 Saturday from 12:00 PM to 4:00 PM ET.



 
Photo of Mark K

Mark K

  • 3 Posts
  • 0 Reply Likes
Thanks Joe, I will give that a try.