failed video capture for Snagit on OSX

  • 1
  • Problem
  • Updated 3 weeks ago
My Snagit recorder (v. 3.3.7 build 78055) will about 20% of the time just hang indefinitely after I finish a recording. It seems to happen more often when the recordings are longer than 4min. It'll just have the beachball on OSX and appear as "Not responding" in Activity Monitor. When I force quit it it says "video capture failed."  What's particularly annoying is there's no way to know whether it worked until after i've finished the recording and the longer the recording, the more I have to lose. I see a number of others have posted this same issue without acknowledgement from Tech Smith of this being a bug. Can someone from TS please leave a meaningful response to this?  Is there any pattern or workround known to solve this. If not I need to move to a different screen recording software and request a refund as this is not only costing time but morale on all the failed recordings. thx
Photo of grid7

grid7

  • 3 Posts
  • 0 Reply Likes
  • hugely frustrated

Posted 2 years ago

  • 1
Photo of Jack Fruh

Jack Fruh, Champion

  • 539 Posts
  • 167 Reply Likes
This is a community (user to user) support forum.

You may want to take make this an official support request:
https://support.techsmith.com/hc/en-us/requests/new
Photo of grid7

grid7

  • 3 Posts
  • 0 Reply Likes
thx submitting a ticket now... 
Photo of eric.r.mckinney

eric.r.mckinney

  • 1 Post
  • 0 Reply Likes
Have had the same issue.  Any followup?
Photo of grid7

grid7

  • 3 Posts
  • 0 Reply Likes
Nope. Gave up long ago and switched to Monosnap app. Way more reliable.