FIXED: Camtasia 2019 lag and freezing while editing/voice narrating - and what helped it for me!

  • 2
  • Problem
  • Updated 3 months ago
  • (Edited)
So.. I am currently editing/cutting and voice narrating my tutorial and I ran into some seemingly unfix-able lag and freezing while doing it. I googled and found a bunch of other people with similar issues, tried all sorts of suggestions but with no result and growing frustration. Then I saw that in the preferences Autosave by default is set to every 1 minute(s). I changed it to 10 and... voila!

  

No more freezing/lag. (well only every 10th minute now but I can live with that). I also don't find that camtasia crashes on me a lot and I usually hit that CTRL + S button every once in a while so 1 minute autosave might truly be an overkill since it slows down everything for sometimes up to 15-20 seconds for me. I usually have 1 hour tutorial recordings and I suppose autosaving them takes its toll on it. I just wanted to share that with everyone here in case it might help you too. Cheers, Tim
Photo of Amino

Amino

  • 2 Posts
  • 0 Reply Likes

Posted 9 months ago

  • 2
Photo of Max Anderson

Max Anderson

  • 2 Posts
  • 1 Reply Like
This is not working for me. I have tried multiple versions of this, 1 min, 5 mins, 10 mins, but it doesn't matter. It just hangs. I hit play, and the icon looks to change to pause, but no dice. It's a really disruptive issue to workflow.
Photo of Joe Morgan

Joe Morgan

  • 8529 Posts
  • 4584 Reply Likes
Have you tried editing in Software Only mode.

Photo of Max Anderson

Max Anderson

  • 2 Posts
  • 1 Reply Like
I have not - I will give it a try.. Thanks!