Font in Camtasia suddenly substituted by Arial

  • 2
  • Problem
  • Updated 4 weeks ago
I have created a lower third design and saved it in the Library. I used two fonts from the Thesis fonf family, TheSans C5 Bold and TheSans C5 Plain. When I created a new project and loaded the lower third group from the library, the line with TheSans C5 Plain looks exactly like it should, and the line in Bold is now substituted by Arial, even if I manually select the font I want. Also when I add a new annotation and select TheSans C5 Bold, it displays as Arial. Highlighting the text element in the time line or selecting the words themselves makes no difference.

So the font displayed correctly a few minutes ago, it still works in other software, but inside of Camtasia it is broken.

I then restarted the program, I restarted the computer and I re-installed the whole font family, and it's still the exact same result: TheSans C5 Plain works just like before (as do all other fonts in the family), TheSans C5 Bold still doesn't. So it's pretty clearly a Camtasia problem.

Our client chose Camtasia for all their editing stations, we just provide the library for them. Their corporate design is not optional, we need to use this exact font.
Photo of ole

ole

  • 3 Posts
  • 0 Reply Likes

Posted 4 weeks ago

  • 2
Photo of Joe Morgan

Joe Morgan

  • 5878 Posts
  • 3065 Reply Likes
I've seen this occur with OTF fonts.

The solution is to convert the font to TTF format.Uninstall the OTF font and install the TTF font.

Regards,Joe 
Photo of ole

ole

  • 3 Posts
  • 0 Reply Likes
Thanks for the reply! That seems like a bad option, if not illegal. The actual solution would be for Camtasia to get a proper OTF implementation. It's 2018 after all...
Photo of Joe Morgan

Joe Morgan

  • 5864 Posts
  • 3058 Reply Likes
I'm not a lawyer,

but if you own rights to the font. I don't know why converting it to another format. Would land you in legal hot water.

Most professional fonts are not inexpensive. I'm thinking you can probably download it in TTF directly from the company it was purchased from.
Photo of Joe Morgan

Joe Morgan

  • 5864 Posts
  • 3058 Reply Likes
This issue has plagued Camtasia for years. So "IF" that is what is occurring.

Waiting for TechSmith to resolve this situation. Well, Ill let you draw your own conclusion.

You can contact support. I can't guarantee that's what's happening.But it's a typical example of when, the editor is defaulting to another  font.

This is a Free Service............... Submit a ticket

       https://support.techsmith.com/hc/en-us/requests/new

Or call, >>>

 Toll Free: 800.517.3001 (U.S. & Canada Only)

8:00 AM to 7:00 PM EST Monday through Friday

Regards, Joe

Photo of Daniela

Daniela

  • 19 Posts
  • 11 Reply Likes
I approached TS support with the same dilemma, but they simply said that I should request the TTF font from the creator then. Camtasia does not officially support OTF fonts and, according to the TS support, is not scheduled to do so anytime soon.
Photo of Joe Morgan

Joe Morgan

  • 5878 Posts
  • 3065 Reply Likes
Thanks for jumping in {:< )

Regards,Joe
Photo of ole

ole

  • 3 Posts
  • 0 Reply Likes
Wow, thanks for all the replies! Good to know that there is an active community here.

I have sent a request to tech support. Maybe they can help, after all the font did work at one point.

There is no official TTF version of the font, so I'm probably stuck with some kind of conversion.

Thanks again!