Glitch in your snagit application. On two different occasions I needed to reinstall because it says "Snagit...

  • 1
  • Question
  • Updated 2 years ago
Glitch in your snagit application. On two different occasions I needed to reinstall because it says "Snagit needs to be in your application folder to run". Has anyone else had this problem? Running Mac OS Sierra Snagit version 3.3.7.  
Photo of Scott Glover

Scott Glover

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Jack Fruh

Jack Fruh, Champion

  • 539 Posts
  • 167 Reply Likes
I've never had that happen. 
Seems odd.
Though I think I went from version 1 to version 4 of snagit.
(and for reference, it's always been in my application folder)

Do you use a tool like alfred to launch snagit? I keep a backup copy of my applications on a USB drive and I've noticed that when it's attached, Alfred will sometimes list apps I have there in addition to the ones I have in my applications folder.

It might be worth searching your system for snagit to see if you have an extra copy somewhere, and if so, just rename it snagit_backup or something like that so it doesn't get called up by accident.

- Jack
Photo of Ken Whitaker

Ken Whitaker

  • 40 Posts
  • 10 Reply Likes
I would stop Snagit. Make sure there are no Snag*** apps running at all. Then remove Snagit app completely and the preferences. (I can send you instructions that I received from their tech support on how to remove all preferences.) Then re-install Snagit with the LATEST version which today is V4.1.2. Don't have version 4? Upgrade to it! I'm running on Sierra and it works great (after they resolved some performance issues).
Ken "Software Maniac" Whitaker