Hi in Snagit 2018 my audio cannot be initialized when I try to record video and the session craps out.

  • 2
  • Question
  • Updated 3 months ago
Hi in Snagit 2018 my audio cannot be initialized when I try to record video and the session craps out. First off I am not recording audio but have unchecked record microphone, record audio system, and webcam. I am recording at low, and have the re-scale option clicked. I’ve followed their troubleshooting audio for windows tutorial and updated my audio drivers and still no dice. Any input would be helpful, thank you.
Photo of gmacarevich

gmacarevich

  • 1 Post
  • 0 Reply Likes

Posted 1 year ago

  • 2
Photo of belatronix

belatronix

  • 4 Posts
  • 0 Reply Likes
I have the same behaviour. And it is not solved by change to different recording devices. My sound-drivers are also the newest. 
This is a bug. 
Photo of dma2112

dma2112

  • 4 Posts
  • 0 Reply Likes
me as well, just left a ticket.  
Photo of Derek C

Derek C

  • 3 Posts
  • 0 Reply Likes
I've also run into this problem.  I am on an MSI GE72 6QF Apache Pro. What works for me may still not work for you.

What (so far) seems to work for me is to turn off the Nahimic audio driver (you can turn it back on again after your captures if you want).

Then  using regedit, go to feature control for Snagit under: Computer\HKEY_CURRENT_USER\Software\TechSmith\Features\snagit

The support posts say to set AllowMfAudioCapture value to 0.  
I tried that and it worked once, but then the problem came back.

But I then set AllowMfDeviceDiscovery also to 0. 
Device discovery appears to be the key, perhaps a typo in the support post that people are referencing. Setting this to 0 and it doesn't seem to matter whether AudioCapture is on or not.

Now capture is working fine every time (so far!).

Also the recording of system audio and microphone (I use a USB Blue Snoball) are working properly, so disabling device discovery doesn't seem to affect that (for me). No need to disable microphones, etc.


In Summary:
1) turn off Nahimic Driver
2) set value Computer\HKEY_CURRENT_USER\Software\TechSmith\Features\snagit\AllowMfDeviceDiscovery  to 0