Hotspot "pause at end of callout" not working

  • 2
  • Question
  • Updated 5 years ago
  • Answered
Since upgrading from Camtasia 8.0.4 to 8.4 the "pause at end of callout" hotspot feature no longer works.  I compile the same projects and play the production on the same Web Server but the new 8.4 version does not pause.  Any idea why this occurs?
Photo of stevet423

stevet423

  • 2 Posts
  • 0 Reply Likes
  • disappointed

Posted 6 years ago

  • 2
Photo of Ben Giovingo

Ben Giovingo

  • 8 Posts
  • 2 Reply Likes
I am also experiencing this same issue.  Projects produced yesterday with the same settings (MP4 Flash/HTML5 Player) no longer acknowledge the pause at end of callout hotspots.  They just play through.
(Edited)
Photo of kayakman

kayakman, Champion

  • 7462 Posts
  • 2572 Reply Likes
I too can confirm this issue; I've produced almost 500 projects involving several thousand stop-at-end, click-to continue hotspots

they don't work

if the hotspot is at the end of a project, the video stops and USUALLY the hotspot is dead, unless you manually seek back a few frames

also, when viewed in Chrome vs. IE 11, there is slight different behavior [in IE, the hotspots will occasional work]

if you make a multi files from markers production where the project contains stop-at-end, click to continue hotspots, they are all ignored

note: if you host on Screencast.com, the hotspots will work as expected

very reproducible behavior
Photo of Ben Giovingo

Ben Giovingo

  • 8 Posts
  • 2 Reply Likes
Thank you for your confirmation.  As a quick work-around, do you know of a way to roll back the update?
Photo of kayakman

kayakman, Champion

  • 7462 Posts
  • 2572 Reply Likes
you need to uninstall 8.4, then reinstall 8.3
Photo of kayakman

kayakman, Champion

  • 7462 Posts
  • 2572 Reply Likes
CS TechSupport has been alerted
Photo of Ben Giovingo

Ben Giovingo

  • 8 Posts
  • 2 Reply Likes
Rolling back to 8.3 corrected this issue.
Photo of Sihem

Sihem

  • 4 Posts
  • 1 Reply Like
How did you download the version 8.3 please?
Photo of Sihem

Sihem

  • 4 Posts
  • 1 Reply Like
And once 8.3 is installed, my camtasia project won't open as it was created in 8.4. This sucks :(
How did you guys fix the issue?
Photo of kayakman

kayakman, Champion

  • 7462 Posts
  • 2572 Reply Likes
older versions can be downloaded here ...

http://www.techsmith.com/download/oldversions.asp
Photo of kayakman

kayakman, Champion

  • 7462 Posts
  • 2572 Reply Likes
there are several workarounds that can be used

re 8.4 projects that will not open in 8.3 ....

you can produce the project in 8.4 to MP4 with player; this will give you all the files needed to reconstruct the project on 8.3

use the produced 8.4 MP4 to start a new project in 8.3; add back in your hotspots, markers, captions, etc

this tutorial shows how ...

http://cookbookplus.com/Temp/TechSmith/HowTo/HowToRebuildProjectFromProductionFileSet/HowToRebuildPr...


Photo of Sihem

Sihem

  • 4 Posts
  • 1 Reply Like
This video took me 3 weeks to cut, edit, add callouts, transitions and whatnot. There is no way I am repeating all of that :) Thank you all for the link and suggestions though and let's hope this isaue gets fixed ASAP!
Photo of kayakman

kayakman, Champion

  • 7435 Posts
  • 2557 Reply Likes
the approach I suggest will preserve all your editing since the objects are burned in to the MP4, and you only need to re-add hotspots, markers, captions, which are easy to pull from the config.xml

usually only about a 1 hour task for a decent sized project

I've done this with many complex projects where the original archived project has been lost

use transparent hotspots over the images of the original ones in the MP4
Photo of Sihem

Sihem

  • 4 Posts
  • 1 Reply Like
Oh right, I understand you now, will try that.Thanks, that's very helpful!
Photo of Logan S.

Logan S.

  • 2813 Posts
  • 153 Reply Likes
Hey Bob,

Did you open a ticket on this one?
Photo of kayakman

kayakman, Champion

  • 7435 Posts
  • 2557 Reply Likes
Hi Logan; yea, Alex and Mike [et al] know all about it
Photo of Kalle Romanov

Kalle Romanov

  • 21 Posts
  • 4 Reply Likes
Not only the hotspots at the end, also thru the whole video, the hotspots  function very randomly in Chrome, FF, IE. I just upgraded from ancient Cam5 just to find out this bug in Cam8.4!  
Why many hot-spots? I produce videos with portions really loaded with information, so is is essential to stop because users require different time to learn the contents.
Photo of kayakman

kayakman, Champion

  • 7462 Posts
  • 2572 Reply Likes
again, this is a known issue and is being addressed 
Photo of Rob Saffell

Rob Saffell

  • 1 Post
  • 0 Reply Likes
Thanks for getting this posted. I am rolling back now - really wish some these issues would get found out before it rolls out (I started seeing a lot of crashes after upgrading, also).
Photo of Krystyne_ADLC

Krystyne_ADLC

  • 2 Posts
  • 0 Reply Likes
I produced this in screencast.com and I am still experiencing problems with the pausing not working. I have followed all of this stream and done everything indicated. Still this video does not pause at the end of the questions I need it to. http://www.screencast.com/t/SYSmB8ibL
Photo of Kalle Romanov

Kalle Romanov

  • 21 Posts
  • 4 Reply Likes
What Camtasia version you use? I've updated to 8.4.1 where this problem was fixed several weeks ago, and all hot spots are 100% functional.
Photo of Krystyne_ADLC

Krystyne_ADLC

  • 2 Posts
  • 0 Reply Likes
I am using 8.4.1 as well.
Photo of Milissa Gould

Milissa Gould

  • 1 Post
  • 0 Reply Likes
This information is SUPER helpful! Thank you to everyone that posted!  Luckily I caught the issue when I wasn't too far into my training video.   
Photo of kayakman

kayakman, Champion

  • 7462 Posts
  • 2572 Reply Likes
latest version is 8.4.2
Photo of mkasper

mkasper

  • 1 Post
  • 0 Reply Likes

I have installed 8.4.3. Still dont work as far as I can see. Any plan for when a new Version when this work is skipped?


Photo of kayakman

kayakman, Champion

  • 7462 Posts
  • 2572 Reply Likes
are you producing to MP4 with player; are you launching the video using the xxx_player.html [or xxx.html] file?   are you viewing locally of off a hosting site [and which one]?

produce and share to screencas.com as a test?

what browser are you using?
Photo of john.miller

john.miller

  • 4 Posts
  • 1 Reply Like

What is the status of this?  I am also seeing this issue.  I have only used 8.4.3.  Strange thing is, some hotspot pauses work, some do not.  All in the same video.  In fact, I just copied and pasted the very first one.  I also produced just a selection of one hotspot that wasn't working and in that video it worked.  There seems to be no rhyme or reason.  I am using MP4 with SmartPlayer and I am running the html directly with Windows Explore; i.e. no web-server.

Photo of kayakman

kayakman, Champion

  • 7462 Posts
  • 2572 Reply Likes
what browser [and version] are you using
Photo of john.miller

john.miller

  • 4 Posts
  • 1 Reply Like
I am using Chrome Version 38.0.2125.104.
Photo of kayakman

kayakman, Champion

  • 7462 Posts
  • 2572 Reply Likes
I generally found the hotspot issue to be resolved with 8.4.3

but they do behave better in IE 11

for best hotspot behaviors, I do custom production, setting key frames every 1 sec; I also make sure the hotspots are at least 2 seconds in duration; it can also help if any hotspots placed at end of video a are offset from the actual end of project by 1/2 second

can you test in IE 11 and let us know?
Photo of john.miller

john.miller

  • 4 Posts
  • 1 Reply Like
I will give your suggestions a try.  It will take me some time to get back to this, but I will respond.
Photo of Ben Giovingo

Ben Giovingo

  • 8 Posts
  • 2 Reply Likes
I've found that v8.3.1 continues to not be broken. I don't see any clear advantage trying to navigate work arounds for the current builds.
Photo of stevet423

stevet423

  • 2 Posts
  • 0 Reply Likes
Mmmm - I went back to 8.3 shortly after the original post and never looked forward... 
Photo of john.miller

john.miller

  • 4 Posts
  • 1 Reply Like
Once I changed the key frames to 1 second and the durations to 2 seconds the pauses worked in Chrome.  I have other issues with IE 11 so I was not able to test it with that.  The duration of 2 seconds does seem excessive, but it did work.
Photo of kayakman

kayakman, Champion

  • 7462 Posts
  • 2572 Reply Likes
John, thanks for your feedback; hope you can work with the hotspots now

you might try experimenting with shortening the hotspot durations to 1sec; but I've found that 2 seconds works best in current versions of Chrome and IE11

I've found that achieving best hotspot behavior requires an empirical R&D approach [different tweaks for different scenarios]; they also seem subject to version state of browsers, and, of course, the version of the TechSmith SmartPlayer that is deployed with a specific production; as I recall, the player changed significantly between 8.1 and 8.3?
Photo of kelzipan

kelzipan

  • 7 Posts
  • 1 Reply Like
Just read waaaaay too much on callout hotspots on this forum.  I tried every solution and nothing worked locally or on screencast until I made the hotspot duration at least 2 seconds and changed the key frames to 1 second.  I wish this were better documented as a workaround/instruction step.  Thanks, kayakman and john.miller.  Just upgraded to 8.5.0 but still didn't work til I made those changes.  It works in Chrome as well.  It wasn't working anywhere before I made those changes, though (locally with Firefox, IE, Chrome, as well as Screencast on any of those browsers.)

This conversation is no longer open for comments or replies.