How do I copy to clipboard ONLY

  • 1
  • Question
  • Updated 2 years ago
  • Answered
I want to just copy a screen region to my clipboard and skip the editor but nothing I try works :(

Attaching a screenshot of my settings:

I expect that this setting combination will ONLY copy to my clipboard but when I hit capture it also opens up the image in Snagit :(

What am I doing wrong?

Photo of Rob


  • 3 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Joe Morgan

Joe Morgan

  • 9123 Posts
  • 4805 Reply Likes
For starters,
I'm a Windows user.
But the settings you're using work on Windows. Provided you're hitting the Capture Button on the Large Menu.And not the Smaller One Click button.

If that's the case. SnagIt for MAC may have a bug. Maybe another MAC user will test this and report back.

There's tech support as well.

This is a Free Service............... Submit a ticket

Or call, >>>

 Toll Free: 800.517.3001 (U.S. & Canada Only)

8:00 AM to 7:00 PM EST Monday through Friday

Regards, Joe

Photo of Rob


  • 3 Posts
  • 0 Reply Likes
Yes I am clicking the big red button, OK thanks I will submit a ticket.
Photo of pjonesCET


  • 378 Posts
  • 74 Reply Likes
Mac version not designed that way. Everything must go through editor.
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1537 Posts
  • 389 Reply Likes

This isn't true in all cases. The editor will appear if:

1. you have an effect selected in your settings
2. preview in editor is on
3. the editor is open on your system already

If you have preview in editor off, no effects, and the editor is not already open, it will not show. 

Rob, given that your settings for 1 and 2 look correct, my guess is you're running into situation 3. Make sure you have this setting enabled: this will allow the Snagit capture window to stay active even if the editor is closed. Then you should be able to go directly to clipboard without the editor opening.

Photo of Rob


  • 3 Posts
  • 0 Reply Likes
Thanks I will test this out when I'm back in my office