How do I export lossless video for Adobe Premiere (PC)

  • 1
  • Question
  • Updated 2 months ago
  • (Edited)
I'm using windows 10 pro, adobe premiere pro, camtasia pro, all latest versions.  I'd like to export Camtasia videos and import into adobe premiere in a lossless format.  How can I do this?  

The only links I found on this site describing how to do this are many years old, articles on this site that I searched for using "adobe premiere" for example were written years ago.

I'd like to go from Camtasia (PC) -->Adobe Premiere.  

Thanks for any help!
Photo of marshill88

marshill88

  • 1 Post
  • 0 Reply Likes

Posted 2 months ago

  • 1
Photo of Joe Morgan

Joe Morgan

  • 5638 Posts
  • 2924 Reply Likes
"Lossless Format" is an overrated goal. "In my opinion"

I would  produce to .avi using the TechSmith Screen Codec 2. Its a lossy format but a good one. The file sizes are still quite large.
More than enough video information to to reproduce a clean video in Premiere Pro.



A Lossless video with dimensions of 1920 x 1080  could easily reach or exceed 2 to 4 GB  per minute file size. Even top notch CPU's and GPU's can get bogged down working with files like that. 

Working with the original files is best whenever possible. If your simply trying to work with .trec files in Premiere Pro. The original files unedited,well you can't get any more lossless than that, its as lossless as it gets.
You can extract the contents of a .trec file by placing it in the media bin. And.............. 

Regards,Joe


   
Photo of rg

rg

  • 104 Posts
  • 55 Reply Likes
I just tried the right-click "export" approach with a 1GB *.trec file from within Camtasia v8.6 and the resulting 1GB *.avi file would not open in Win10 Media Player.  Figuring it was an envelope problem, I tried opening in Switch, but even Switch could not recognize the file. Bigasoft converted the file (it took 4 minutes to "convert" and nearly doubled the file size) to a more "universal" *.avi format, but that really defeats the purpose of directly exporting the source file.
(Edited)
Photo of Joe Morgan

Joe Morgan

  • 5638 Posts
  • 2924 Reply Likes
I tested a quick recording using Camtasia 8.6. Extracted it, here it is playing in Windows media player on Windows 10.
You must be missing a codec or something.
Photo of rg

rg

  • 104 Posts
  • 55 Reply Likes
I wonder if there is any way to figure out what is missing.  Got any ideas?
Photo of Dubie

Dubie

  • 961 Posts
  • 741 Reply Likes
You could try downloading and adding the K-lite codec pack to your machine.

That will add support for many formats.
  • AVI, MKV, MP4, FLV, MPEG, MOV, TS, M2TS, WMV, RM, RMVB, OGM, WebM
  • MP3, FLAC, M4A, AAC, OGG, 3GP, AMR, APE, MKA, Opus, Wavpack, Musepack
  • DVD and Blu-ray (after decryption)
  • and many more audio and video formats!
Another option is to use VLC for your media playback.

It plays pretty much anything.

:)
Photo of Joe Morgan

Joe Morgan

  • 5638 Posts
  • 2924 Reply Likes
A reinstall of Camtasia might install the codec.

However, if your extracting the contents of a .trec file.The main reason for doing it? Is usually to edit the video in Premier Pro or some other program.If you can use the extracted video in other programs.I wouldn't worry about it much.

Unless you have a specific reason to watch these Raw files in Media Player? To me, there's not many reasons to watch raw trec files in media player.

However, you can always watch them using the Camtasia player. Just select "Open With" and select CamPlay.exe
It only plays avi's. You'll probably have to navigate to the Camtasia 8 folder first time around under "Choose another app."


Here's the location and .exe


Photo of Luis Stamatis

Luis Stamatis

  • 19 Posts
  • 1 Reply Like
Better use Screen Capture Codec, older but lossless
Photo of rg

rg

  • 99 Posts
  • 51 Reply Likes
As of my version 8.6 I don't see any option for recording except to AVI or TREC.  I don't think there's any option for something older.
Photo of Luis Stamatis

Luis Stamatis

  • 19 Posts
  • 1 Reply Like
Recording:
When you choose "Avi" under "Inputs" tab you click "Video Settings"