How to change Logitech webcam power line frequency to 50 Hz for preventing flickering with Camtasia recorder ?

  • 1
  • Question
  • Updated 2 months ago
How to change Logitech webcam power line frequency for preventing flickering with Camtasia recorder. I am located in India so need frequency 50 Hz instead of default 60 Hz as in Camtasia.

During video recording through my Logitech webcam c922x, I am getting flickering lines. Please provide a solution.
Photo of Rohit Runwal Jain

Rohit Runwal Jain

  • 1 Post
  • 0 Reply Likes

Posted 2 months ago

  • 1
Photo of Samarn Sumrith

Samarn Sumrith

  • 139 Posts
  • 58 Reply Likes
please try to change on Device properties or Format settings in Camtasia Recorder.



Photo of kayakman

kayakman, Champion

  • 7178 Posts
  • 2390 Reply Likes
this screenshot shows a 60 FPS capture frame rate

not seeing this option in Camtasia 2019

what version of Recorder are you using?
Photo of Samarn Sumrith

Samarn Sumrith

  • 139 Posts
  • 58 Reply Likes
I use Camtasia 9. But I enter 60fps manually.
Photo of Joe Morgan

Joe Morgan

  • 7426 Posts
  • 4055 Reply Likes
When I go into device properties..., as Samarn Sumrith has highlighted.

My Logitech C920 software opens. Giving me access to 50Hz PAL setting.



The software I run is not available for a C922x. There is something called Logitech G sync available for a C922x,https://support.logi.com/hc/en-us/articles/360024699934--Downloads-C922-Pro-Stream-Webcam

I don't know if that will help you or not? I can control a lot setting. Brightness,Contrast,etc. White balance is the most useful setting. It lets you capture the color correctly in different lighting conditions.

Either way, Device settings should get you to some form of your webcam settings.

Regards,Joe

(Edited)
Photo of Samarn Sumrith

Samarn Sumrith

  • 139 Posts
  • 58 Reply Likes
I have use Microsoft Lifecam Studio. I can setup for 50Hz or 60Hz.
Photo of Paco Perez Escudero

Paco Perez Escudero

  • 1 Post
  • 0 Reply Likes
I had the same problem I changed in Skype at 50Hz and it works