How to save a color image, and prevent snagit from saving as a black & white image

  • 2
  • Question
  • Updated 2 weeks ago
So, I snag images in color.  I manipulate them in color in the editor.  I then "save as" (and save as JPGs), and the images in the snagit editor are still in color.  Yet, when I open the file on my computer, it is black and white.  And if I try to reopen the files from my computer in the snagit editor, they are now black and white.

How do I make sure snagit saves my color images in color???
Photo of Nick Sheedy

Nick Sheedy

  • 1 Post
  • 0 Reply Likes

Posted 8 months ago

  • 2
Photo of Paul

Paul

  • 1146 Posts
  • 908 Reply Likes
How do they look in Windows Explorer?
Photo of Joe Morgan

Joe Morgan

  • 5677 Posts
  • 2945 Reply Likes
It sounds like you may have the Jpeg "File Format" settings set to "Grayscale"

Save a Jpeg, go into the "Options" tab. Make sure "True Color 24 bit "  is selected.

Regards,Joe

Photo of lynette.cortez

lynette.cortez

  • 1 Post
  • 0 Reply Likes
Thank you, @Joe Morgan!  That fixed the same problem I was having.  However, this started happening about two weeks ago and I did not make this change.  Is that something TechSmith pushed out?  Or perhaps my own corporate security changes incorporated that change?  Strange. But glad I found the solution!
(Edited)
Photo of Joe Morgan

Joe Morgan

  • 5448 Posts
  • 2839 Reply Likes
I don't believe it's anything TechSmith or Security has done.

Some odd glitch occurred. It's kind of like having a warning light come on in your car and have it go out 5 min later.
Except in this case, you know what the problem is. Probably won't happen again. I'm glad you found this question and got it fixed. {:>)
Photo of Ryan Cunningham

Ryan Cunningham

  • 1 Post
  • 0 Reply Likes
Solution
This happened to me at my work and took me a long time to figure out the simple solution, which is as follows:
  1. In the "Save As..." dialog, change the output to another type (e.g. in my case, we use PNGs, so I changed it to JPG)
  2. Do a screenshot and save it locally (this screenshot looked "normal" for me)
  3. Then, I simply changed the output type back to PNG

My system details

  • Dell Latitude E6440 laptop
  • Microsoft Windows 10 Enterprise 2015 LTSB (64-bit)
  • SnagIt Version 2018.2.2 (64 Bit) (Build 2240) - 9/13/2018

Additional details about the problem

In the SnagIt editor, I noticed that upon taking a screenshot the color bit depth of the unsaved image was "normal", that is 32 (View > Details... and then look for "Bit depth").

After saving the image, however, I located the image in Windows File Explorer, right-clicked, selected Properties > Details tab and then looked at "Bit depth". The number was then 1.

Since initially setting things up, I have not touched my settings, but I work in a large corporate environment so there's a good chance a computer update jacked up something.