How to start recording in one hot key?

  • 1
  • Question
  • Updated 5 months ago
Is there a solution where from the one hotkey, I can get it to start recording automatically as well?  It seems odd that I have so many items I can configure, but cannot set it to auto record. Is this just a facepalm, and I'm staring right at the option?

I am trying to record VR from a hotkey.  The VR content can be seen from a window on my desktop. With the VR on my head, I cannot see my desktop (or anything else in the room). I'm using Scroll Lock at present as the hot key to start a preset for Video, with a fixed region. I can find the scroll lock key blind folded, so it works here. It is set to record a fixed/predefined region. 

On pressing scroll lock, it does start SnagIt, but is sitting on the view for me to press record.  I don't not have mouse control at this time. The hotkey is shift F9, and is nearly impossible to find blind folded (VR headset). 



I am using Snagit 2019.1.6 (build 5031), on Windows 10. US Keyboard configuration.

Thank you.
Photo of hpdvs2

hpdvs2

  • 8 Posts
  • 1 Reply Like

Posted 5 months ago

  • 1
Photo of JL1

JL1

  • 351 Posts
  • 160 Reply Likes
At the risk of stating the obvious (and of being wrong, since I don't think I have recorded a video of my screen in the almost 15 years as a SnagIt user), have you tried the options highlighted below (sorry for the poor legibility, I had to use the snipping tool because, somehow, SnagIt wouldn't capture itself even though the Hide Snagit when capturing is unchecked).


 


Photo of hpdvs2

hpdvs2

  • 8 Posts
  • 1 Reply Like
Thank you, that is helpful. I did forget about this option, and for now I will use it, but it is not a good experience for me. I have 5 Monitors + VR running when I start this, and despite it being a powerful machine, it can take up to 4 seconds to bring up the screen recording UI. That means I have to wait about 5 seconds before pressing the hotkey to start recording. If I'm too early with the second hotkey, it won't record a thing, and I won't know until I take the headset off and check the recording. :(
Photo of hpdvs2

hpdvs2

  • 8 Posts
  • 1 Reply Like
Also, the option to "Automatically start video recording" automatically record gets rid of the timer, but does not automatically start the video recording. That does seem like a bug, but its been that behavior for multiple versions.
(Edited)
Photo of Joe Morgan

Joe Morgan

  • 9083 Posts
  • 4787 Reply Likes
I'm running SnagIt 2020.
You have the option to disable the countdown timer.
With auto start as a separate function/selection.


It works with a hot key for me. Starting recordings instantly.
The options are the same with 2018. 
It worked correctly for me as well.

Perhaps the bug is related to your setup.
SnagIt 2018 through 2020 are covered by support.
You may want to open a ticket.

This is a Free Service............... Submit a ticket

       https://support.techsmith.com/hc/en-us/requests/new

Regards,Joe
Photo of hpdvs2

hpdvs2

  • 8 Posts
  • 1 Reply Like
IT WORKS!!!  I was having a brain fart.  :)   Or maybe I didn't, but I went through an update today, and it worked after that.  
Photo of hpdvs2

hpdvs2

  • 8 Posts
  • 1 Reply Like
Specifically the settings to turn off countdown, and turn on the auto start. as Joe Morgan said.