How do I remove audio echo in Camtasia Studio 8?

  • 5
  • Question
  • Updated 2 months ago
  • (Edited)
how do I remove echo audio?

I have several .camrec clips recorded in Camtasia 8 from online video and when I play the files in Camtasia's video player I hear a bad echo.

How can I remove or prevent the audio track from having this echo?
Photo of pauljacques

pauljacques

  • 1 Post
  • 0 Reply Likes
  • really disappointed....

Posted 7 years ago

  • 5
Photo of Fred Grover

Fred Grover, Champion

  • 2445 Posts
  • 385 Reply Likes
Where are you recording the videos from and what are the steps you are taking when setting up for your recordings? Sometimes it can be the video you are recording and not caused by Camtasia Studio 8. Do you hear the echo when you just play the video you are recording? Let us know and if possible upload a sample for us to hear. Thanks for posting.
Photo of Michael Hickey

Michael Hickey

  • 4 Posts
  • 0 Reply Likes
I am on a 30 trial and recording a webinar that will only be up for a few days and I had that echo.  I kept dumping them and trying again while fooling with the audio settings.  Finally, I made the audio settings "Do not record microphone" and "record system audio" and the echo went away.  I don't know if this helps but it stopped when I quit using "Stereo Mix.".  
Photo of kurrykid

kurrykid, Champion

  • 760 Posts
  • 131 Reply Likes
This can happen if you record your system audio and through your microphone at the same time. You can essentially record the same information in both areas causing an echo.

Could this be the case?

HTH
Photo of news

news

  • 6 Posts
  • 0 Reply Likes
I wish like anything you had offered a further solution. I turn off one, and I get no mic recorded for my Google interviews. I turn off the other, and get no audio at all.
Photo of news

news

  • 6 Posts
  • 0 Reply Likes
So what's the solution? I turned off the mic input but predictably recorded no input from my mic. I turned off internal audio and lost everything else. Sigh.

I really wish you had specified your solution rather than just 'well, don't do that.' I desperately need a fix for this.
(Edited)
Photo of Dubie

Dubie

  • 1529 Posts
  • 1263 Reply Likes
See my other post below.

It might be a option that will help with your audio setup.
Photo of Bill Jones

Bill Jones

  • 1 Post
  • 0 Reply Likes
I have several .camrec clips recorded in Camtasia 8 from online video and when I play the files in Camtasia's video player I hear and echo.

How can I remove or prevent the audio track from having this echo?

Ken C,

This reply was created from a merged topic originally titled
how do I remove echo audio?.
Photo of Dan Hörning

Dan Hörning

  • 1 Post
  • 0 Reply Likes
So what do you do to remove this echo? Just completed an amazing interview through Skype and found out I had this error, using the same installation and hardware that I had used for another interview two weeks earlier without a problem
Photo of Fred Grover

Fred Grover, Champion

  • 2445 Posts
  • 385 Reply Likes
Dan can you tell us the settings you are using when you record your Skype Interviews and the steps you used? More information would help if possible. I have used Camtasia Studio 8 for PC in recording a two way Skype Conversation and never had or should I say could not reproduce this problem. Thanks for posting and sorry for the problem you are experiencing right now but we hope to help you get it figured out along with TechSmith Support. Have a great day.
Photo of Allen MacCannell

Allen MacCannell

  • 2 Posts
  • 2 Reply Likes
Guys, this is not the way we would do support. We would never allow a thread to hang like this.

The echo seems to be a normal thing. I am experiencing it now in Version 8.02 and I have not a clue how to fix it. But I'll bet there's an easy fix and that there was simply a misunderstanding caused by navigation issues that product managers will want to fix. Do Camtasia people work with people live who are using the software via screenshare? If you do this, you will see where people don't understand the navigation and where people arrive quickly at problems like this.

Because the customer is always right when they have problems. It's almost always a fault in the navigation if not an actual bug.

Now let's figure this out logically. I believe this has something to do with the fact that there is not logical way for a user to determine what track is playing at any one time. That's because you have the tracks stacked on top of each other. Where's the button or green light that means "This track is what we are not dealing with?"
Photo of Fred Grover

Fred Grover, Champion

  • 2445 Posts
  • 385 Reply Likes
Allen this is not a TechSupport site it is a user to user forum with users trying to help other users. If you want the Support then you would need to fill out a Support Ticket which is for that purpose. Like I said we are not trying to be Support Technicians here just offering suggestions. Thank you for your input as it is appreciated.
Photo of news

news

  • 6 Posts
  • 0 Reply Likes
This. It is an obvious issue, I can find tons of Google queries on it and no simple fixes by Camtasia although it's obviously some tech setting I'm simply missing. For the moment, my past 2 recorded Hangouts interviews are unusable (my own voice deafening, my subjects' way too quiet) and yet mic settings are not the issue. I've tried toggling all audio settings to no avail.
(Edited)
Photo of Allen MacCannell

Allen MacCannell

  • 2 Posts
  • 2 Reply Likes
We wouldn't figure "Oh well, this is on the Internet for everyone to find but the particular customer isn't complaining anymore so he or she must have resolved their issue and everything's cool".

The echo is the first thing I am experiencing the first time I am using Editor.

I did nothing wrong recording. I listened to the playback before clicking "Save and Edit" and everything was fine then.

I am sure this happens to a lot of people and, if they stop complaining, it doesn't necessarily mean they figured things out and still use your software.

This is why it would be really important for Camtasia to make sure the entire Echo Issue is dealt with thoroughly on your forum.
Photo of Fred Grover

Fred Grover, Champion

  • 2445 Posts
  • 385 Reply Likes
Allen I noticed you said you were using Camtasia Studio 8.02. Have you tried upgrading to the latest version of 8.0.4 to see if that helps at all? If not I would try that and then if it is still doing this maybe post a few screenshots or make a short video if possible so we can see and hear what is going on. I can not reproduce this problem myself but that is not to say that it is not happening and I use a different type of audio setup than most care to spend money on.

I am sorry to hear your problem and hope it can be resolved. I do not work for TechSmith but I have been using the software for many years and maybe myself, other users and TechSmith Support can help figure out why you are experinceing this problem.

Can you tell us what OS you are using and what soundcard it might have? For example RealTek or something else and the Mic you are using is it a built in internal mic or a USB, etc. ? Let us know and the more information we have the easier it might be to help figure out the problem(s) you are experiencing here. Thanks for posting and have a great day.
Photo of Curtis

Curtis

  • 7 Posts
  • 3 Reply Likes
I have the same problem, and it's keeping me from producing useable videos. I'm using Camtasia Studio 8.0.4 (Build 1060) and I experience the problem with mp3 audio files that I created and edited on Audacity, exported to mp3 format, and imported to Camtasia in short (5 to 20 sec) segments for each step of an instructional video. The original mp3 audio files do not have an echo. The echo only occurs during playback (and final production) in Studio at the very end of the clips. It doesn't occur with every clip, nor for the same duration when it does happen. It's as if the last fraction of a second up to couple seconds of the audio clip is copy/pasted onto the end of the clip....it's very odd. I can send samples if you care to hear them.

Here's my system info:

Microsoft Windows 7 Home Premium 64-bit SP1
Intel Core i7 3610QM @ 2.30GHz 60 °C
RAM: 12.0GB Dual-Channel DDR3 @ 798MHz (11-11-11-28)
Motherboard: ASUSTeK COMPUTER INC. G75VW (SOCKET 0)
Audio: NVIDIA High Definition Audio

Microsoft IMA ADPCM CODEC Version 4.00.0000
Microsoft CCITT G.711 A-Law and u-Law CODEC Version 4.00.0000
Microsoft GSM 6.10 Audio CODEC Version 4.00.0000
Microsoft ADPCM CODEC Version 4.00.0000
Fraunhofer IIS MPEG Layer-3 Codec (decode only) Version 1.09.0401
Messenger Audio Codec Version 4.00.0000
Microsoft PCM Converter Version 5.00.0000
TechSmith LAME MP3 Codec v0.9.2 - 3.99.5 Version 4.00.0000

Thanks,

.........Curtis.........
Photo of Curtis

Curtis

  • 7 Posts
  • 3 Reply Likes
I found a work-around by simply turning the volume down at the end of each clip. The echo is still there, but you can't hear it in the final mix.
Photo of Joe

Joe

  • 3 Posts
  • 0 Reply Likes
I have the same problem. Using audicty to record the audio which then plays back just fine. I export it as mp3 or wav and then import it into camtasia studio 8.1 (just upgraded). When I play the clip it stutters and echos all the way through and seems to have a big delay. I play with the space bar and when I hit the space bar again to stop it keeps echoing away for a second or two. Let me know if you come up with anything.

Thanks.
Joe.
XP 32
Photo of Joe

Joe

  • 3 Posts
  • 0 Reply Likes
I have been fooling around with this. My video is a screen capture of a drawing, I have to play it at 1000% clip speed to get it to match up in length to the audio. When I switch it back to 100% the audio plays OK. Still not a solution but may help get there. Joe.
Photo of Joe

Joe

  • 3 Posts
  • 0 Reply Likes
OK, I may have discovered something. All the echoing and stuttering and delay only happens in the studio. I produced first the video without audio and that worked fine so then I added the audio back in and although it won't play in studio preview, the exported video plays just fine. Exporting as wmv always seems to strip out the audio but I'm used to that so I just export as AVI. This makes editing somewhat tedious but at least I can get something useful if I slog through it.
Photo of Fred Grover

Fred Grover, Champion

  • 2445 Posts
  • 385 Reply Likes
Would it be possible for anyone to upload a short video of how and what they are doing and having it playback so we can see and hear what you are getting with these results. Let us know as sometimes the other users here might see or hear something we don't and might have another suggestion(s). Also what Operating System do you use Windows XP or 7, etc.? And what type of soundcard and microphones are you using? Thanks and I hope someone can help get this figured out and I would like to try and help but would love to see a short video or even the whole video of the procedures you are taking as I can not make it happen when I do this when importing an mp3 into the timeline and synching it up with my video. Thanks and let us know.
Photo of Curtis

Curtis

  • 7 Posts
  • 3 Reply Likes
Hi, Fred and kurrykid. Here's a demo of the problem with the workaround I mention above: http://www.screencast.com/t/PUVkyQk9Tn

Note that in this example I'm seeing the problem with an mp3 audio clip imported from Audacity, but I have also observed the problem with audio recorded with Camtasia recorder. (And, obviously, the original mp3 clips do not have the "echo" at the end.)

Let me know if you have other questions.
Photo of kurrykid

kurrykid, Champion

  • 760 Posts
  • 131 Reply Likes
Good suggestion Fred...I'd like to see it to!
Photo of Ben Hunt

Ben Hunt

  • 2 Posts
  • 0 Reply Likes
I'm having the same problem on Version 8.1.2 for Windows, but it only manifests on very long recordings.

I'm also recording Skype interviews, playing the other person through my computer speakers, and recording using a good microphone (Blue Snowball). I'm recording both the microphone and system audio, so they're going onto separate audio tracks.

What I'm finding is, at the start of the recording, say the first 30 minutes, I can see that the mic is picking up the speaker sound, but that's OK because they're in sync.

However, as I go through the recording, the audio tracks go gradually out of sync, to the point that, around 45 minutes onward there's a noticeable echo, which gets worse.

In the past, I've gone through manually and muted sections of the mic track when the other person is talking, but that's a big pain.

I know that preventing audio feedback is THE major challenge with video chat systems like Skype / Google Hangouts etc (much more challenging than the video element). It would be GREAT if Camtasia could feature a "Remove Echo" option that would intelligently identify and then remove duplicate patterns. That would be a much better solution than manual editing, which isn't perfect.
Photo of Fred Grover

Fred Grover, Champion

  • 2445 Posts
  • 385 Reply Likes
Ben I cannot think of any software even out of all the audio software programs that I have used that have a one click solution to remove the echo. When you say your mic is picking up the speakers I am assuming that you are listening to the audio through your speakers and not headphones? Correct me if I am wrong. By doing this then yes you may end up with an echo as it is recording your speakers sound(s) which is or might be causing this echo. I would suggest trying to listen to any system sound you record with headphones and not through speakers unless you are not recording any narration with your mic. This is just a suggestion to try.

Have you tried upgrading your Camtasia to the latest version? Also, would you have a sample recording you could upload and share for us to hear the problem? I do know when recording Skype and other chat (Messaging) apps it can cause problems on their end and like I said if you are listening to them using your speakers then have your mic on to talk to them then yes it might pick all of that conversation up especially if they are talking over you when you are talking.

Let us know and thanks for posting and I hope this helps a little. Have a great day.
Photo of news

news

  • 6 Posts
  • 0 Reply Likes
Fred, I appreciate your frequent presence here, but you and others seem to be missing the main issue.

For me, at least, it feels like there is a missing middle ground.

I am an experienced (many years) Camtasia user. But when I try to record Google Hangouts in a shared call/interview, after the fact (not during) -- my own voice is deafening and the interview subject's is tinny and far too low. Their quality is unacceptable while mine feels like it's echoing in my own head.

I have tried every permutation -- turning off my microphone, recording inbound audio only etc., but when I try all those, I get no mic recorded at all. All I want is for my voice levels and those of my interviewees to be the same levels (versus me at some deafening level that nukes their quality).

I have tried everything. It seems obvious to me that my mic is 'doubling' something I'm not seeing in Camtasia, but the settings don't seem to want me to figure it out. At the moment, it is all (me deafening/nuking the interview, and a barely understandable recipient), or nothing (no audio at all). 

I'd love any help you can give.
(Edited)
Photo of Dubie

Dubie

  • 1529 Posts
  • 1263 Reply Likes
Hey News,

Have you ever considered  using a audio mixer?

That would allow you to control the audio inputs and even them out.

If you might be interested in giving one a shot, I recommend Voicemeeter.

https://www.vb-audio.com/Voicemeeter/


I prefer the more advanced Voicemeeter Banana

https://www.vb-audio.com/Voicemeeter/banana.htm




Dubie:)

Photo of Ben Hunt

Ben Hunt

  • 2 Posts
  • 0 Reply Likes
Hi Fred.

Yes, I'm well aware that if I used earphones instead of speakers that would eliminate the problem.

One issue with that is that I prefer not to use them, particularly for 90-minute discussions. However, it seems like that's the only realistic option.

But there's another more serious issue, though. That is that the recordings go gradually out of sync over a long timeline. That's what actually causes the echo, not the fact that the mic is picking up the speaker output.

As I said, near the start of the call, the other person's audio is simply coming in in stereo, and that's not a problem, because the channels are in sync.

As the call progresses, though, one of the tracks seems to record at a different speed. I can even see that when I go to the end of the timeline in Camtasia... One track is literally longer than the other! I think that's a bug in the software, to be honest.
Photo of jwisnieff

jwisnieff

  • 2 Posts
  • 1 Reply Like
I experienced this problem with my very first recording. I called TechSmith and the issue was that I was saving the clips to a network drive (with a longer transition time) than a local drive. When I saved the clips to a local drive the problem stopped. I don't really understand the technical reasons involved. I'm writing this post immediately after this fix. Hopefully it is solved. If it's not-  I'll post here again.
Photo of Dougly Michael

Dougly Michael

  • 3 Posts
  • 0 Reply Likes
I had an echo on one of my first recordings. Basically it sounds like two identical audio tracks have been recorded, but are playing back slightly out of sync. I have not found a way to fix something recorded this way yet. But to prevent it from occuring again, I simply selected "Do Not Record Microphone" and "Record System Audio." My recordings since then have been fine.
Photo of Dougly Michael

Dougly Michael

  • 3 Posts
  • 0 Reply Likes
I found a solution to fixing videos with an audio echo without having to re-record. Simply go into Camtasia editing studio, add your video capture file to the timeline, and "silence" one of the audio tracks. To be more specific in my situation, it appears that the microphone auido was recorded and married to Track #2 that also contained the video. Obviously, I do not want to remove this track because then I wouldn't have an image. I right-clicked this track on the timeline, selected "Edit Audio", and then selected "Silenece." Boom. Fixed. Now, my project contains a video track (with muted microphone audio) and a System audio track. I will not need to re-record. I hope this helps you all. Good luck!
Photo of Fred Grover

Fred Grover, Champion

  • 2445 Posts
  • 385 Reply Likes
Just by chance when you all are recording with the Record Mic and System Audio Checked are you listening back through your computer speakers ? If so, your Mic may be picking up the audio from the speakers. Not sure if that is your case but I know it has happened before. Just a suggestion to check.

If anyone has a video of how they are recording when they get the echo please post it here. Thanks for posting and have a great day/night.
Photo of Dougly Michael

Dougly Michael

  • 3 Posts
  • 0 Reply Likes
Fred, when I first adjusted my settings prior to recording anything, I had unchecked record microphone audio. I had no problems with my first few recordings. But when I closed the program and reopened it later to record a little bit more, it seems my settings had reset. This time around it recorded system audio and microphone audio. During recording, there was no echo. But upon playback, it was quite obvious that there were two audio tracks playing back and out of sync. I was able to fix my video in post, but checking the settings prior to recording is a good way to avoid getting an echo altogether.
(Edited)
Photo of Fred Grover

Fred Grover, Champion

  • 2445 Posts
  • 385 Reply Likes
I agree Dougly so I hope that idea or suggestion helps others who have this issue work things out too. Thanks for posting and have a great day/night.
Photo of Klaus Schulz

Klaus Schulz

  • 1 Post
  • 0 Reply Likes

I have the same problem and no solution for it. All what was said above isn't working (or I have overseen something). However, I record with headset (incl. mic). Recording is perfect. Once I replay, directly after recording - perfect. Save, exit and replay - ECHO. I completely diconnected the heatset with mic - still echo. I deleted the system audio track as suggested in another post - still echo.

I am running out of options, and I have to present a demo by the end of the week.

Any suggestions?


P.S. I just published one of my tests. To my surprise, this was without echo.
(Edited)
Photo of jwisnieff

jwisnieff

  • 2 Posts
  • 1 Reply Like
To re-iterate my solution (posted 3 weeks ago):  I had the echo problem when I saved the file on a network drive. When I moved the file to my local C drive the echo stopped.  
Photo of Matías Velasco Guzman

Matías Velasco Guzman

  • 1 Post
  • 0 Reply Likes
this is it!!
Photo of Cesar Perez

Cesar Perez

  • 2 Posts
  • 0 Reply Likes
I found out what the problem is. Some time during the video recording the video himself got corrupted or "lag" so if you do record voice narration it will record on top of a video who is skipping or lagging you can see if in your timeline...the best thing to do is delete that part of the video....
and is not the microphone or nothing from the abode post i try everything also and i am using headphones not speakers i also tried installing the audio file in another hard drive and i unchecked record microphone audio from the record scream and nothing... check the video playback and look if the time skips.. this help me i hope it help you also 
Photo of Cesar Perez

Cesar Perez

  • 2 Posts
  • 0 Reply Likes
I forgot to add this happened after i did a clip extend or something like that at the end of the video