I cannot get my interactive hotspot to a URL to work on the finished video

  • 1
  • Question
  • Updated 1 year ago
Hi folks, I have added an interactive hotspot to a URL, and tested it on camtasia (v9 for windows).  The test works fine, but when I share the project to a local file as a MP4 with smart player (and it says the hotspot will work in the blurb)... the hotspot doesn't work when I play the finished video.  Any tips?  Thanks!
Photo of will

will

  • 4 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of kayakman

kayakman, Champion

  • 6250 Posts
  • 1834 Reply Likes
are you launching using either the xxx_player.html or xxx.html files, so that video plays in a browser?
Photo of Will Findlay

Will Findlay

  • 21 Posts
  • 8 Reply Likes
yeah, if you try to play this by opening the mp4 file directly, it won't work - it needs to be playing in the smart player.
Photo of will

will

  • 4 Posts
  • 0 Reply Likes
Hi Will, thanks. So there is not way to make a url clickable from the video if it mP4 that I (for example) embed into a LinkedIn post?  Because most of my target audience will either view it on their laptop or smart phone.
Photo of will

will

  • 4 Posts
  • 0 Reply Likes
And Kayakman, I am creating an mp4 and just opening that xxx.mp4.  What I want to do is load the mp4 file onto social media so that the url in the video is clickable.  How is it best to do that?  Many thanks.
Photo of will

will

  • 4 Posts
  • 0 Reply Likes
is it best to share to my youtube channel, and will the url then work?
Photo of kayakman

kayakman, Champion

  • 6250 Posts
  • 1834 Reply Likes
you need to launch using the smart player if you want any interactive content to work [TOC, hotspots, captions, quizzes]; there is no way to avoid this

just playing the MP4 will never work

my suggestion: share to Screencast.com, and put that URL on social media