I can't find tools/preferences in snagit!

  • 1
  • Question
  • Updated 4 years ago
I originally had a problem recording video with snagit - when I play it back, I find that the audio lags the video.  So I posted here, and a person replied that I should do the following:

1.       You will need to set “Microphone Input” to system audio in SnagIt Preferences first.

2.       You will start a screen recording in order to access the options for recording audio on the recording toolbar. “The easiest thing to do is start a recording and hit { Shift + F9 } right away to pause the recording .Then make your changes”. 

.3.       Set microphone recording to on.

4.       Disable system audio recording
The problem is that I don't find "SnagIt Preferences" (there is a tools menu in the editor, but I don't see 'preferences').  Plus, when I start a recording, I get a rectangular bar at the bottom of the screen, and it does have a picture of a microphone, which I can mute/unmute, but I don't know how that ties in with #3 and #4. 
Can anyone enlighten me on this? 
Photo of gideon48

gideon48

  • 9 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Timbre4

Timbre4, Champion

  • 680 Posts
  • 273 Reply Likes

Hello,

I'm not finding that either; SnagIt's video capabilities are very simple by design. I believe turning your mic on and off with the toolbar option is about it. Perhaps the reply was about Camtasia instead of SnagIt; it seems to be more about audio input selection which is a different topic altogether.

Photo of Joe Morgan

Joe Morgan

  • 7248 Posts
  • 3952 Reply Likes
Hello gideon48,

That post you are referring to was left by me. See Image Below, Click to Enlarge.

You actually need to select the audio output for your speakers. It won't be called system audio.
On my computer it is Realtek High Definition Audio.

Regards, Joe

(Edited)
Photo of Timbre4

Timbre4, Champion

  • 680 Posts
  • 273 Reply Likes
I stand corrected. How does changing the input have an effect on the original lag issue reported?
Photo of Joe Morgan

Joe Morgan

  • 7243 Posts
  • 3949 Reply Likes

The problem usually occurs when the audio stream is recorded independent of the video stream. This is what can happen when you record system audio. System audio is the sound you hear coming out of your computer speakers. The audio track becomes out of sync with the video track as you pause and restart a recording. 

The way to avert this is to record the video and audio combined as one recording. Although, you will need sacrifice the ability to record audio with your microphone simultaneously to accomplish this.

See Image Below, Click to Enlarge

1.       You will need to set “Microphone Input” to system audio in SnagIt Preferences first.

2.       You will start a screen recording in order to access the options for recording audio on the recording toolbar. “The easiest thing to do is start a recording and hit { Shift + F9 } right away to pause the recording .Then make your changes”. Why they don’t give you access to those controls before you start a recording has never made any sense to me.

3.       Set microphone recording to on.

4.       Disable system audio recording.

That’s it. You can now record and pause as often as you like.

Regards, Joe


Photo of Timbre4

Timbre4, Champion

  • 680 Posts
  • 273 Reply Likes

Thanks for the detailed explanation, that is an odd workflow to get those audio options changed mid-flight. (I don't use this video area at all)

What I'm still at a loss is understanding how the two audio streams are different timing wise (lag introduction) or how "audio stream is recorded independent of the video stream"? They are happening simultaneously and the microphone is no more tied to the video recording than a line input or system audio is. What's up with that?

Photo of Joe Morgan

Joe Morgan

  • 7248 Posts
  • 3952 Reply Likes

I have tested several screen recording programs. BandiCam, SnagIt, Camtasia, Corel Video Studio and one other program I downloaded as a free trial, I don't remember the name because I didn't buy it.
I've reproduced out of sync system audio using every recorder. It's been resolved in every case by saving the system audio to microphone.

I'm referencing  Camtasia as an example. When you record system audio and a microphone simultaneously you end up with one video track that contains the microphones audio. And  a separate audio track that contains system audio. 

When you record as a microphone in Camtasia the audio track is always saved to the video track.

This is my "Theory". The video and audio stream are tied together when you record using the microphone. So they record based on frame rate. They stay in sync because of this.

System audio is an audio recording that is not governed by frame rate. It is not an actual video. When you edit audio using a program like Adobe Audition you can trim the duration by 1/1000 of a second if you wanted to.

However, you can only trim audio on the timeline by frame rate when you're using video editing software.

I think that's how the disconnect comes into play. System audio is not governed by frame rate so it doesn't follow the same rules.
 
  It comes down to this. The only thing different about recording to microphone is how the related audio track is processed and/or saved.

Why so many screen recorders are afflicted with the same problem is an issue for the programmers to resolve.

The technique works and that's good enough for me.


Regards, Joe
Photo of Timbre4

Timbre4, Champion

  • 680 Posts
  • 273 Reply Likes

Puzzling. If I elect to record as trec, there is only a single A/V file and no other tracks produced during that event. Seems to me that mic, line, system audio would all be on an equal footing in this regard.

Are you saying that 'system audio' inside a trec file is going to have a sync problem but audio in a trec file from a 'microphone' is not?

If there is something in SnagIt programmatically that discriminates what the audio source is and dictates sync behavior, it seems a tad goofy.

Photo of Joe Morgan

Joe Morgan

  • 7248 Posts
  • 3952 Reply Likes

Confusing, aggravating, illogical and a tad bit goofy are all valid adjectives covering this bug.

 Why exactly does this problem exist???

 If I knew the answer to that I'd be willing to pass it along to software programmers so they could fix it. Although, I'd probably want to hold out for monetary compensation. Why give it away?

 I've laid out a workaround that works well for me and I'm just hoping it can benefit others.

 

If you had ever recording using the default setting for capturing "System Audio" in Camtasia.

You would have seen a "System Audio track" on the timeline that is separate from the video file.

 The audio track is called system audio by default. You must have been capturing system audio to the microphone all along.

 That’s probably why you have never worked with the system audio track in the past.

See Images Below



(Edited)