I didn't record screens in the right aspect ratio, I changed canvas size but there's still black bars when exported. Any way to fix this?

  • 1
  • Question
  • Updated 2 years ago
I didn't record screens in the correct aspect ratio, I changed canvas size but it still leaves black bars when exported... any way to fix this?
Photo of christina

christina

  • 2 Posts
  • 0 Reply Likes
  • anxious

Posted 2 years ago

  • 1
Photo of Stephen Wagner

Stephen Wagner, Employee

  • 610 Posts
  • 149 Reply Likes
If you set the canvas size to the size of your recording, you will not get black bars.  There is a "Fit to Visible" option in the Project Settings dialog.  This will resize the canvas to the current content on the screen.  

The one exception is if you are sharing to YouTube.   If the aspect ratio of your recording is not 16:9, then you will see black bars.  There is no great solution to that.   One option is to fill up the extra space with a logo or something.

-Stephen
Photo of christina

christina

  • 2 Posts
  • 0 Reply Likes
Thank you for the quick response Stephen! I am indeed sharing this to YouTube... after thinking I had minimised the problem of the bars as much as possible, it looked completely bonkers when I uploaded it to YT. I think I may have to re-record... thanks again though. 
Photo of Paul Middlin

Paul Middlin, Employee

  • 835 Posts
  • 185 Reply Likes
Another option is to "zoom in" your video (make the scale bigger) to fill up the empty space, and pan around a little as needed. Something will be cut off, but if it's the unimportant part, it'll fill the space without rerecording.