I have Camtasia 2019 but the update error is telling me to "upgrade to 2019." What's up with that?

  • 1
  • Question
  • Updated 10 months ago
I have Camtasia 2019 but the update error is telling me to "upgrade to 2019." What's up with that?  - I started with a Camtasia bundle with Snagit - if that helps.
Photo of kmrussell1

kmrussell1

  • 1 Post
  • 0 Reply Likes

Posted 10 months ago

  • 1
Photo of Paul Middlin

Paul Middlin, Employee

  • 1329 Posts
  • 338 Reply Likes
I'm not sure what update error you're referring to. Would you mind posting a screenshot of it?
Also, is this from when you do a "check for updates"?
Photo of Glenn Hoeppner

Glenn Hoeppner, Employee

  • 1914 Posts
  • 378 Reply Likes
Is it possible that you also have an older version installed? You can have multiple versions installed at once. Take a look in your applications folder for multiple Camtasia and/or Snagit 

-Glenn