I need 3 tracks, but i only have 2 tracks after i used OBS

  • 1
  • Question
  • Updated 3 months ago

Hi guys,

I recorded a video including an audio track with OBS. in total there are 3 tracks. (1 = video, 2 = desktop sound, 3 = microphone sound)

a friend of mine has sony vegas. sony vegas automatically recognizes all 3 tracks. he only needs to open the MP4 file there.

if I try exactly the same thing at camtasia, only one track will come. that's why I had to separate "video and audio". but there is the big disadvantage that i only have 2 tracks at the end. (1 = video, 2 = desktop sound)

how can i add the 3rd track?

and by the way, before I separated it, so where it was a whole track, I only heard "video (silent sound) + desktop sound" and not my microphone sound.

I sent my buddy exactly the same MP4 file so that he can test it. for him it works without a problem

i hope someone can help me. thx for reading!

check the picture, and u know what i mean ;)



Photo of fettsackfreunde .

fettsackfreunde .

  • 3 Posts
  • 1 Reply Like
  • sad

Posted 3 months ago

  • 1
Photo of Joe Morgan

Joe Morgan

  • 8782 Posts
  • 4688 Reply Likes
Camtasia doesn't support it.
It supports 2 audio streams per track. "Stereo"

It cannot extract or utilize multiple audio sources contained within a video. You can't select which audio track you want to use either.
If you want to bring in multiple sources.You'll need to extract the audio in a program like Audacity.
Then import it into Camtasia separately.

Regards,Joe 


(Edited)
Photo of fettsackfreunde .

fettsackfreunde .

  • 3 Posts
  • 1 Reply Like
ah ok, thank you for the information.

its much more work to do it with Audacity :/
you have to keep setting it so that you cannot hear the mouse and keyboard clicks. over and over again, right?
Photo of Joe Morgan

Joe Morgan

  • 8782 Posts
  • 4688 Reply Likes
Well, I just ran a test.
I could hear my microphone but the system audio was silent.
Here is that video in Premiere Pro.
The mic track is highlighted in white. I was coughing intentionally, thats why the audio is peaking off the charts.
The other track is system audio of a video playing.System audio captures mouse clicks."When recording with Camtasia" that is.


  

Here is that same recording in Camtasia.
The mic track is the only one showing.



If I separate the audio from the video, the mic is the only track available.



I don't know it there are setting in OBS that could help? Allowing you to capture 2 audio streams to one track?"Mono setting to each stream would probably be required"
Capturing audio without the mouse clicks?

This is one of those situations where a workaround may be the only option.
Which is unfortunate, but it is what it is.

Regards,Joe
(Edited)
Photo of fettsackfreunde .

fettsackfreunde .

  • 3 Posts
  • 1 Reply Like
I have set in OBS that you have 3 tracks. I wanted the desktop sound and microphone sound to be separate. but unfortunately it doesn't work with camtasia.

you're right i can change it to OBS.

Many thanks for the effort joe!! have a nice weekend.