I just "upgraded" to 2.0 Mac Snagit and it doesn't work!! Help!

  • 7
  • Problem
  • Updated 8 years ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Inactive threads; archiving to prevent necroposing

I have PREVIEW IN EDITOR turned on and do a capture that used to work in 1.x and now in 2.x it doesn't work. The capture seems to find its way into the thumbnails at the bottom of the screen, but it doesn't appear in the main edit window.

Further, there are overlapping graphic controls near the screen size gizmo.

Also, no tools or effects show up in the right panel!

I am toasted! How do I go back to my registered v1.x for the time being while I wait for this build to get fixed?

BTW, I'm on a MBP 10.6.8
Photo of Ree-K

Ree-K

  • 13 Posts
  • 0 Reply Likes

Posted 8 years ago

  • 7
Photo of M Moran

M Moran

  • 15 Posts
  • 0 Reply Likes
Requiring the addition of Chalkboard or Felt marker seems like more work than we should be required to perform. This program was released too early and needs to be fixed/patched with the proper fonts installed up front. I would expect an upgrade real soon.
Photo of Jason Eagleston

Jason Eagleston, Employee

  • 632 Posts
  • 95 Reply Likes
Hi,

Thanks for the response. In this case, we were taking advantage of default system fonts when creating our different Callout styles, and there wasn't a safeguard in place if the system fonts were not enabled or installed. We're planning to add more defensive checks to prevent similar issues from occurring in the future.

We really appreciate all of your help on this topic and your candid feedback, keep it coming!

Thanks,

Jason
Photo of henry

henry

  • 5 Posts
  • 0 Reply Likes
Candid feedback notwithstanding I want to upgrade but can't! Will someone on the Techsmith payroll respond to John Hanson and M Moran (or me) about where to get these fonts? I haven't changed anything in my system yet those fonts are nowhere to be found.

-e
Photo of Jason Eagleston

Jason Eagleston, Employee

  • 632 Posts
  • 95 Reply Likes
Hi Henry,

Here is a quick little video showing how to do a global search in the "Font Book" application to track down if a font is disabled or removed. http://screencast.com/t/HdZGnNCiOj

The key is to select the "All Fonts" collection on the left and then do the search. I apologize if you've already tried this, but I wanted to give it a shot to see if the quickest workaround would be to just re-enable it.

Thanks for your patience on this, we certainly understand your frustration with this bug.

Let me know if those any of those three fonts are still not showing up and we'll make sure we get you up and running.

Thanks,

Jason
Photo of Jason Eagleston

Jason Eagleston, Employee

  • 632 Posts
  • 95 Reply Likes
Also, just to clarify, the "Font Book" application is located in your normal Applications folder.
Photo of roger.hubmann

roger.hubmann

  • 1 Post
  • 0 Reply Likes
Hi all, although I reinstalled SnagIt several times, the apps still behaves strangely:

1) I don't get any tools, effects in the right hand side bar
2) when I take a screenshot it does not show in the edit window
3) the screenshot does appear in the lower list. But I cannot take it to the editing window with a double click

See the screenshot attached.

Anyone has the same problems? Will downgrading to an earlier version help? If yes, where can I get it?

This reply was created from a merged topic originally titled
Problems with latest version SnagIt on Mac..
Photo of Jason Eagleston

Jason Eagleston, Employee

  • 632 Posts
  • 95 Reply Likes
Hi Roger,

I have merged your GetSatisfaction topic with this topic, which describes the same issue you have reported. Please see Carmen's "Official Response" at the top of this thread which outlines the problem.

Sorry for this trouble, let us know if these fonts do not exist on your Mac, in most cases, they have just been disabled and need to be reenabled in Font Book.

Thanks,

Jason
Photo of henry

henry

  • 5 Posts
  • 0 Reply Likes
UPDATE: the fonts that Techsmith support says should be in the Mac OS system have not been included in new installs of the OS for a long time -- according to my company's help desk. If you find them in your system it is probably because you've upgraded OS X and not done a recent fresh install from an Apple system DVD. My fonts have not been "disabled". Jason, thanks for the short video but I did look there; no go.

If this is true, and SnagIt has no backup fonts that it can be prodded to use, we need some way to download these fonts from a third party archive. My tech support says that they don't support us "mucking up" system fonts; we're on our own.
Photo of henry

henry

  • 5 Posts
  • 0 Reply Likes
I should clarify that of the three system fonts that Techsmith says are required in one's system, only Marker Felt and Chalkboard are missing (or no longer included in the Apple distro). Helvetica is there.
Photo of Jason Eagleston

Jason Eagleston, Employee

  • 632 Posts
  • 95 Reply Likes
Hi Henry,

I apologize if there is any inconsistency with the reported system fonts included with OS X, this is the documentation we were referencing when listing which fonts are included by default: http://support.apple.com/kb/HT5098 (Lion), http://support.apple.com/kb/HT5154 (Snow Leopard).

For licensing reasons, TechSmith is unable to redistribute Apple fonts. If you would like to contact me to test a possible fix for this issue, please email me at j.eagleston@techsmith.com.

Thanks to everyone for participating in this conversation, we greatly appreciate it.

Jason
Photo of henry

henry

  • 5 Posts
  • 0 Reply Likes
Jason,

I responded to your private email and had a few questions of my own. Thanks for being so proactive!
Photo of Joe Ragey

Joe Ragey

  • 4 Posts
  • 0 Reply Likes
Hello Jason: I have all 3 fonts installed and active in FONTBOOK. Problem persists. See screenshot of SNAGIT attached. NOTE: Using Mac's PREVIEW app, I made a composite image with screen shots from my FONTBOOK to show you the 3 fonts. Is there anything else I can try or an extension issue with known software, that I can run to see what else might be in conflict with SNAGIT's upgrade version?

Thanks
Joe
Photo of Jason Eagleston

Jason Eagleston, Employee

  • 632 Posts
  • 95 Reply Likes
Hi Joe,

Sorry for the delay in my response. Just as a quick check, if you had to reenable those fonts in the Font Book, you would need to restart Snagit for the problem to cease (apologies if you've already done this).

Beyond that, we are unaware of any other causes for this trouble. Let me know if that still doesn't help out and if not, we will want you to open a support ticket with our technical support staff here: http://techsmith.custhelp.com/app/ask. Please include this thread in your request. And we will make sure this gets squared away.

Thanks and again, I apologize for the delay in getting back to you.

Jason

This conversation is no longer open for comments or replies.