Infinite snagit screenshots copied from system tools driving me crazy

  • 1
  • Problem
  • Updated 7 months ago
Wow. Talk about an amazing feature with one fatal flaw.

Snagit allows you to auto-copy a screenshot created from a non-Snagit program into the Snagit library. It only works with Microsoft Snip&Sketch so far.

This is perfect because Snagit isn't pen-friendly, but Microsoft's snipping program is perfect for writing/annotating.

But every time I make one minor edit on Snip&Sketch a copy is created in the Snagit Library.

If I take a screenshot and then write on it... Snagit will end up copying as many as 60 DUPLICATES. Imagine doing this for 10 images...

Any minor change I make in snip&sketch will create a new duplicate in Snagit.

Please tell me if there is a solution to this?
Photo of lloydmc2

lloydmc2

  • 4 Posts
  • 0 Reply Likes
  • frustrated

Posted 7 months ago

  • 1
Photo of Rick Stone

Rick Stone

  • 5807 Posts
  • 2764 Reply Likes
Hi there

From the SnagIt, capture screen, if you click File > Capture Preferences... > Capture tab, is the option "Open screenshots copied from system tools" enabled? If so, try disabling and see if that helps?



Cheers... Rick :)
(Edited)
Photo of lloydmc2

lloydmc2

  • 4 Posts
  • 0 Reply Likes
Thanks... I've already done that.

But is there anyway to keep that feature on while not getting infinite images duplicating during editing/annotating?
Photo of Paul

Paul

  • 1644 Posts
  • 1226 Reply Likes
Coming at it from the other direction, is it possible that Windows is autosaving after every edit, and that that is causing SnagIt to react?
Photo of Dubie

Dubie

  • 1487 Posts
  • 1213 Reply Likes
Open Snip & Sketch and click on the three dots and then Settings.




In the Settings Turn Off  "Auto copy to Clipboard"



With it on you are updating the clipboard when you annotate which in turn updates Snagit.

Dubie:)
(Edited)
Photo of Joe Morgan

Joe Morgan

  • 7397 Posts
  • 4041 Reply Likes
Ah, dueling keyboards. Looks like you hit enter first {:>)
Photo of Joe Morgan

Joe Morgan

  • 7397 Posts
  • 4041 Reply Likes
Paul nailed it lloydmc2,

I haven't been using Snip and Sketch or the SnagIt Open screenshots copied from system tools feature .

But I played around with it after reading Paul's post. There is a setting in Snip and Sketch that updates the Clip Board as you annotate.

I captured Pauls post. Started drawing, and it was filling up SnagIt in a hurry.

I disabled the feature and it quit happening.

Regards,Joe
Photo of lloydmc2

lloydmc2

  • 4 Posts
  • 0 Reply Likes
BINGO!

Thanks guys...

SO I did exactly as you guys said... changed settings in snip/sketch tool and it worked! No more infinite copying...

The new problem? Snagit doesnt auto copy the work I do in snip/sketch.
The new solution? Luckily, snip/sketch has a "copy to clipboard" button right on top. Press that and Snagit auto copies into the snagit library.

Crisis averted!

Now...

any idea why snip/sketch "prt scn button" doesn't work inside certain programs? It seems to work while most programs are open, but disables itself when others are actively being used. I use a little-known program called ThinkorSwim for stock charting and need to take screen caps.
I'm thinking maybe I can use Autohotkey software to forcibly map snip/sketch to prt scn so that prt scn always works.

Thanks again for your insights. Helped a bunch.
Photo of Joe Morgan

Joe Morgan

  • 7397 Posts
  • 4041 Reply Likes
ThinkorSwim might have hijacked the printscreen button?
Photo of Dubie

Dubie

  • 1487 Posts
  • 1213 Reply Likes
@lloydmc2

In case you didn't know you can use the key combo Shift+win+S to activate Snip & Sketch

and then if you just click once it will capture your main monitor full screen or you can also click and drag to capture just a region of any screen/monitor.


Dubie:)
Photo of lloydmc2

lloydmc2

  • 4 Posts
  • 0 Reply Likes
It must be ThinkorSwim... 

Shift+win+S works on thinkorswim... so I used Autohotkey to successfully remap Shift+win+S into PRINTSCREEN... yet when I press printscreen it still doesn't work -- even though the Shift+win+S combo is being activated.

Why are you doing this to me god?! Why!