Is Snagit 3.3.7 supported for Mojave?

  • 1
  • Question
  • Updated 3 months ago
Snagit magnifying cursor on delay capture
Photo of ren.chaturvedi

ren.chaturvedi

  • 2 Posts
  • 0 Reply Likes

Posted 3 months ago

  • 1
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1012 Posts
  • 249 Reply Likes
Hi,

Unfortunately not. Snagit 4 and later are supported, although 4 will not be supported once macOS 10.15 comes out. for full support you'd need either Snagit 2018 or 2019.
Photo of ren.chaturvedi

ren.chaturvedi

  • 2 Posts
  • 0 Reply Likes
Thanks for the quick reply, Luke!