Is v3.3.7 compatible with Sierra?

  • 1
  • Question
  • Updated 2 years ago
It is working fine w/3.3.3 but my system wants to upgrade to 3.3.7 but I don't want to if it will break. I do not yet have the option to upgrade to v4
Photo of marykay

marykay

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 713 Posts
  • 175 Reply Likes
Snagit 3 is not supported on macOS Sierra. If 3.3.3 is working, I would stick with that until you're able to upgrade to 4.
(You can turn off the autoupdates in Snagit preferences to make sure it doesn't accidentally happen)
Photo of pjonesCET

pjonesCET

  • 359 Posts
  • 65 Reply Likes
Upgrading to 4 doesn't guarantee anything. I have 4.0.5 and This morning I hit a stray key not knowing which and it crashed, the very first crash I have ever had with SnagIt. SnagIt has been the most reliable application i have ever used.  I just updated to Sierra Night before last took 9 hours to download and install and 95 Mbps Comcast cable connection.

I suggest the People at Techsmith better get going. Oh and don't believe that 35 minutes to download and use nonsense floating around on the internet.