Issue trying to produce & share to YouTube

  • 6
  • Problem
  • Updated 10 months ago
Camtasia 7 issue: I'm trying to upload a video direct to YouTube. I'm doing the steps correctly but it keeps telling me that my YouTube login credentials are incorrect. I've done this many time before and my login credentials have not changed. I'm able to login to my YouTube account separately with the same username and password I'm entering in Camtasia. In the past, I've been able to do this seamlessly with no problem. Now I can't. Any advice? Is there a bug?
Photo of Mary Reynolds

Mary Reynolds

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 6 years ago

  • 6
Photo of Brian Bennett

Brian Bennett

  • 82 Posts
  • 6 Reply Likes
Hi Mary,
If you have Google's 2-step verification (or have enabled it recently), you need to use an application specific password from your Google account.

To get one, log into YouTube, click on your user image at the top right, and then click on "Settings." This will take you to your Google Account page. Next, click on Security on the left and see if 2-step verification is "On." If it is, continue reading. If not, would you mind uploading a screenshot of any error message you're getting? It will help us track the problem down.

If 2-step verification is on, click on "Review permissions" next to the Connected applications and sites heading. It will ask you to verify your password and the take you to a page with a list of services you've authorized to connect to your account. Scroll to the bottom where it says "Generate application specific password." Enter a name like Camtasia (it doesn't matter what you call it) and then click on "Generate Password."

Once you've gotten it, go back to Camtasia and paste that password into your YouTube credentials from the Produce and Share screen. It should take care of the problem.
Photo of WebTechGlobal

WebTechGlobal

  • 3 Posts
  • 0 Reply Likes
I don't think this applies right now because the 2-Step takes us to the main account. The application specific passwords seems to be associated with the primary account username/email address. 

However I have not tried to logout of all accounts including the primary - then login to my sub account. Then attempt an application password. 
Photo of nightcore tv

nightcore tv

  • 2 Posts
  • 0 Reply Likes

Photo of nightcore tv

nightcore tv

  • 2 Posts
  • 0 Reply Likes
Làm ơn giúp tôi

Photo of Joe Morgan

Joe Morgan

  • 7392 Posts
  • 4038 Reply Likes
Bạn đã đăng nhập vào tài khoản email của mình trên máy tính mà bạn đang cố tải lên chưa? Nếu là tôi, tôi sẽ tải nó bằng tay và bỏ qua quá trình này hoàn toàn.
Tôi đang sử dụng Google dịch Tôi hy vọng bạn hiểu điều này.
Trân trọng, Joe


Photo of Cordero Spencer

Cordero Spencer

  • 8 Posts
  • 0 Reply Likes
I'm getting that message. I upload a video fine earlier today and after i got back from lunch it won't let me.
Photo of John Buell

John Buell

  • 1 Post
  • 0 Reply Likes
This is happening to me. I validated that 2-step authentication is off.
Photo of pumpkin

pumpkin

  • 23 Posts
  • 0 Reply Likes
YouTube now requires us to log in with the gmail associated with our channel, rather than the user name like we did previously. Can you try that?
Photo of WebTechGlobal

WebTechGlobal

  • 3 Posts
  • 0 Reply Likes
That will only sign us into the primary account and publish videos to the primary YouTube channel. 

I logged into my primary then tried to publish to a sub channel and experience the same problem as explained by the OP.

I do have a working login for a sub account which I use regularly so I know all the screens and steps. Yet it's a struggle to make it happen with more sub accounts. 
(Edited)
Photo of pumpkin

pumpkin

  • 23 Posts
  • 0 Reply Likes
Hey, I wanted to post a follow-up to this thread. YouTube must roll out these changes in phases because we encountered the issue Brian describes above only this week. His instructions were a little different than what I actually saw in our acct but basically I had to get the YouTube generated page name for third party uploads--this is the new user name to use in Camtasia. Note: Our old login still works for our YouTube account when accessed from the browser.
Photo of ggirl02306

ggirl02306

  • 2 Posts
  • 0 Reply Likes
how did you find the YouTube generated page name for third party uploads?  I have tried every name under the sun and can't figure out how to get Camtasia to recognize my YouTube account.
Photo of pumpkin

pumpkin

  • 23 Posts
  • 0 Reply Likes
Sorry for the slow reply. I had to dig back through YouTube to locate that setting. This worked for me:

1. Log into your YouTube channel.
2. Click your channel icon at top right corner and select YouTube settings from the dropdown options.
3.On the left should be Account Settings and you should default to the Overview page.
4. Under Account Information, in the Name section click the Advanced link under your channel name.
The Advanced page appears, Under Account Information, you should see the email address you need: Something like yourchannelname @ pages.plusgoogle.com ***This is your new username to enter in Camtasia***

I think it recognizes your old password just fine. We're still using our old one and I don't see where I entered that anywhere in YouTube.

HTH!!
Photo of ggirl02306

ggirl02306

  • 2 Posts
  • 0 Reply Likes
Thanks for checking on this!  I tried the email listed on the advanced account page but no luck.  Camtasia keeps showing an error message that the YT account doesn't exist, which it clearly does b/c I can sign into YT!  I'll keep poking around and see if I can get anything to work as it is a pain to download and then upload to YT.
Photo of BlazegamerUK

BlazegamerUK

  • 1 Post
  • 0 Reply Likes
I've been finding the exact thing I even tried my own email but that wont work and I tried saving then uploading but it says you have to do it from Camtasia
I also can't find this two step verification thing
(Edited)
Photo of jason

jason

  • 2 Posts
  • 0 Reply Likes
Has anyone had any luck with this recently? I still can't get it to work. It gives me the same error as others above
Photo of KarenK

KarenK

  • 2 Posts
  • 1 Reply Like
I was able to resolve this issue.



It is a setting in the users google account that is preventing the log on.  Here is how you fix this.

1.  Go to:

https://www.google.com/settings/security

Log on with your google account and password

             youraccount@gmail.com  and your password

Then under Account Permissions

Access for less secure apps needs to be set to: enabled

2.  If it is set to disabled, click Settings  then select Enable.

Click the Done button.

Now you will be able to use your account on Camtasia Relay and Camtasia Studio to publish to YouTube.  :=)




Karen
(Edited)
Photo of Lauren Bryant

Lauren Bryant

  • 1 Post
  • 0 Reply Likes
This fixed it for me except it was in a different place. Use the link, SIGN IN & SECURITY, scroll to the bottom and "Allow less secure apps" slide to "ON"
Photo of Matthew McDermott

Matthew McDermott

  • 29 Posts
  • 5 Reply Likes
Rather than lower the security on my Google Account, I have two step enabled and just generated an App Password like Brian initially indicated and it worked. 
Photo of Spencer Clough

Spencer Clough

  • 1 Post
  • 1 Reply Like
bs tech smith, fix this
Photo of Brittany Jones

Brittany Jones

  • 2 Posts
  • 0 Reply Likes
When I try to Produce and Share a video to YouTube, every channel I try uploading my project to, says that my google account is not connected with a YouTube account. I know I am using a google account that has a YouTube account because before today, Camtasia worked without this problem.
Photo of Lauren Valentino Bryant

Lauren Valentino Bryant

  • 1 Post
  • 0 Reply Likes
Did you try changing your security settings as seen in KarenK's answer? It fixed it for me!
Photo of Brittany Jones

Brittany Jones

  • 2 Posts
  • 0 Reply Likes
Yes. I tried changing my security settings as directed, but the issue was not resolved.
Photo of asitstandsrp

asitstandsrp

  • 4 Posts
  • 0 Reply Likes
Nothing here works, nothing at all. I've tried my user name, email, the pages.plusgoogle.com thing, I tried my password, the one time generated password, all mixed and matched and NOTHING logs me in.
This is driving me crazy as I can't find a SINGLE tutorial on how to render a video for manual upload to youtube. All I see is USE THE BUILT IN PRESET. Well I CAN'T. 
Photo of Joe Morgan

Joe Morgan

  • 7392 Posts
  • 4038 Reply Likes
Hi asitstandsrp,

This is a technique that has served me well.

 I never use the upload directly function because I prefer to watch my video and check for errors before committing to a upload. Uploads can take a very long time, I also have DSL. See Image Below, Click to Enlarge.

Regards, Joe

Photo of Ed Kennett

Ed Kennett

  • 1 Post
  • 0 Reply Likes
KarenK,  Thankyou so much for your post. You are a star  and saved me hours of drama and problems. Many thanks
Photo of Mona Soliman

Mona Soliman

  • 5 Posts
  • 0 Reply Likes
just re- name it and save . i face this before 
(Edited)