lame_dshow.ax failed to register

  • 1
  • Problem
  • Updated 2 years ago
I just spent an evening troubleshooting (This file may not besupported.)  Then re-installing Camtasia 8.6 - Error 1904. lame_dshow.ax failed to register. HRESULT -2147024770

The Solution was: unregister a Directshow filter that hooked all Directshow APIs. Then re-installing Camtasia 8.6 worked and lame_dshow.ax registered without error.

The Directshow filter I was using was one I complied from the [DirectShow Filter Graph Spy] project. But I think a lot of problems installing additional Codec support filters would fail the same way. Also (obviously since it happened prior to this..) "any" This file may not be supported. error messages that suddenly appear for .mp3 and .mp4 and other media files (especially while working with previously working .camrec files and projects) would tend to suggest a new Directshow filter was installed (possibly associated with another multimedia program) and/or then removed and "broke" the dshow filter chain.

I had a rare moment of "longer term memory" than normal and could accurately recall everything I did and exactly how to back it out.. but I bet a lot of people would not be that lucky.

It would be [Super] helpful if Techsmith could run a quick test to verify the Directshow Filter chain is sane and unbroken either before it trys to install a new dshow filter, or anytime it fails to register a dshow filter and alert the user to the problem.. even if they don't understand, techsupport would get a better idea of the problem and how to help faster.

The "generic" Error 1904 could mean almost anything, and the HRESULT -2147024770 is practically "meaningless".. there is nothing specific or helpful about those messages.

I did manually try to regsvr32 lame_dshow.ax a copy of the dshow filter and it threw up a very similar error message that it couldn't register it. Ironically an older lame_dshow.ax file from the Camtasia 7.1.1 [would] register when the same file that came with Camtasia 8.6 [would not] this inconsistent behavior through me off the rabbit trail until I ran out of ideas and just de-registered the older dshow filter and gave it a shot.
Photo of John Willis

John Willis

  • 20 Posts
  • 1 Reply Like

Posted 2 years ago

  • 1

Be the first to post a reply!