Login does not work for me

  • 1
  • Problem
  • Updated 3 months ago
When I click Login on either Camtasia or SnagIt and login using my TechSmith account (which separately is fine and has all my keys) I get the error: Whoops

Sorry, something unexpected happened.
Start fresh from TechSmith Account.

If that doesn't work, please let us know on our support site.



I know the account is fine because I'm able to login just fine otherwise. This is only an issue when using the Apps to to sign-in. I'm currently using Windows 10 and Edge Chromium as my system default on one system and Windows 10 and Standard Chrome on another. 
Photo of revpixel

revpixel

  • 2 Posts
  • 0 Reply Likes

Posted 3 months ago

  • 1
Photo of Fred Grover

Fred Grover, Champion

  • 2444 Posts
  • 383 Reply Likes
This is strange. Unless maybe they were doing some kind of maintenance to their website or something.

I have tried logging in from the website, Camtasia 2019, and SnagIt and had no problem with getting signed in. I am using Windows 10 Home and Firefox and Google Chrome Browsers. Not sure what might be causing this issue for you as you were able to log in to the Community Forum and if that is the same password you use for your apps I would think this should not be happening.

Is it possible that you typed an incorrect password in ? I have done that before or forgot it and had to do the change password option.

I would suggest contacting TechSmith Support which is free if you cannot get this to work correctly. I just wanted to add my input to let you know that I was not having an issue in logging in and that would tell me it is not on the TechSmith Website end of things.

Let us know what you find out and post back here please. Sorry that you are having this issue. Thanks for posting and have a great day/night.

Regards,

Fred
Photo of revpixel

revpixel

  • 2 Posts
  • 0 Reply Likes
This has been an issue for a long time for me tho. I'll open a ticket.