Milky faded video

  • 1
  • Question
  • Updated 1 month ago
Why are my videos in Camtasia so Milkey with faded colors?

If I open the video in Microsoft's default video player OR VCL media player, the video is crisp and full of color. (see video below the bad one)

If I change the Hardware Accelerator option in Preferences, to Microsoft's driver I can get a little better, but not all the way. Why can't I use my Nvidia card....I don't want to use Microsoft's default one. I purchased an upgraded card for better graphics




Photo of holmesshanea

holmesshanea

  • 9 Posts
  • 5 Reply Likes

Posted 1 month ago

  • 1
Photo of Joe Morgan

Joe Morgan

  • 6651 Posts
  • 3658 Reply Likes
Its a bug that's been around since Camtasia 2018 was released.
Tech support has recently/finally been able to reproduce the error on one of there computers.
There working on a fix.

Regards,Joe
Photo of holmesshanea

holmesshanea

  • 9 Posts
  • 5 Reply Likes
Well, that is NOT good! How can I produce quality video ?   WTH!
Photo of Kevin Mojek

Kevin Mojek, Employee

  • 581 Posts
  • 119 Reply Likes
Currently we're able to reproduce the problem with one specific model of nVidia graphics card. Which graphics card do you have?
Photo of holmesshanea

holmesshanea

  • 9 Posts
  • 5 Reply Likes
GeForce GTX 1050 Ti
Driver Version 388.13
Photo of holmesshanea

holmesshanea

  • 9 Posts
  • 5 Reply Likes
Just upgraded to 
Driver Version 430.39
but it makes no difference
Photo of Joe Morgan

Joe Morgan

  • 6649 Posts
  • 3657 Reply Likes
This is related to lots of cards and lots of posts. I've responded to a lot of them. Heres  just 3 of so many others.

https://feedback.techsmith.com/techsmith/topics/camtasia-eandomly-modify-video-colors

https://feedback.techsmith.com/techsmith/topics/camtasia-2018-0-the-colors-of-the-videos-are-incorre...

https://feedback.techsmith.com/techsmith/topics/milky-film-faded-colors

This support article has been around for a very longtime. At least 10 months according to the first post I reference above. This isn't some one off glitch and it shouldn't be reported  as such.

 https://support.techsmith.com/hc/en-us/articles/360005120411-Camtasia-Windows-Video-Is-Washed-out-on-Canvas

Photo of raybettis

raybettis

  • 4 Posts
  • 3 Reply Likes
I also have this exact same issue with my 1080ti and Camtasia. Finally found this thread as it was driving me nuts.  I am now very - very disappointed.

Looks fine in the Microsoft player. So, I have switched to the Microsoft Basic Render Driver as the software only was absolutely horrible and choppy. 

I sure hope they fix it soon as I have done the upgrade to 2019 and the problem is still present.  Oddly, the 30day trial version did not do this but when I paid for the full version expecting an even better experience this is what I got.
Photo of Joe Morgan

Joe Morgan

  • 6651 Posts
  • 3658 Reply Likes
Just for your information. This was posted in another thread a couple of weeks ago. It's relevant to this bug.

Official Response
Hey Folks,

For the record, editing at 24 / 25 FPS are on the backlog--I will work hard to get it done as soon as possible, but cannot guarantee a timeline (I want them too). We are not planning to support drop-frame editing frame rates (only useful if you are producing for old school NTSC TV broadcast). In the future we may consider adding frame rates higher than 60 FPS if there is significant demand and adequate performance.

The move to 60 FPS editing in Camtasia is not the cause of the rendering bugs Joe is describing / showing. Over the last two years a major rewrite of the underlying decoding and rendering engine used by Camtasia has been underway. There's a dedicated team working on that engine. The goal is to tap into the huge advances that GPU technology has made over the last 15 years, move onto a modern AV stack provide by the OS and create a performant cross-platform rendering engine for Camtasia. A cross platform rendering engine will allow us to create user facing features more quickly and consistently. The changes in how the engine decodes video moves Camtasia to a much newer low-level technology stack provided by the OS. We are slowly rolling out pieces of this new engine over several years. Phase one saw us adding this new decoding stack and additional GPU accelerated rendering in Camtasia 2018 on Windows.

Joe is running into a bug based on specific hardware and video sources that we have not been able to duplicate internally until recently. We now have a machine where we can duplicate this and the rendering team assures me they are working on a fix. Turns out specific hardware GPU / decoding stack / source footage bugs are gnarly to diagnose and fix. We are working on it. My apologies. You can still fallback to software rendering mode in 2018 using app preferences which should behave exactly as Camtasia 9 does, and you should be able to edit at 60 FPS, but with no GPU acceleration. 
Hope this helps everyone understand where we are at.

Brooks
Camtasia Technical Product Manager
Mobile Technical Product Manager
TechSmith

So this is all well and good, progress seems to be afoot.

Photo of holmesshanea

holmesshanea

  • 9 Posts
  • 5 Reply Likes
Here is the official response that I received last evening:

Aaron Y. (TechSmith Support)

May 1, 3:20 PM EDT

Hello,

I am really sorry to hear you are running into this issue! This, unfortunately, is a known issue at this time and we are actively working on getting it fixed. In the meantime, the best solution is to switch to Software only mode or run the files through Handbrake first:

- Open Camtasia 19
- Click on Edit>Preferences at the top of Camtasia 19
- Click on the Advanced tab
- Under the Hardware Acceleration section, choose "Use the software-only mode" from the drop-down menu
- Restart Camtasia and see what you get 

If that doesn't do anything, then I'd try running the files through Handbrake to create a new MP4 file:

Download link for Handbrake: https://handbrake.fr/

Video on what settings to choose in Handbrake: https://tsc.techsmithrelay.com/ad5Q

I am really sorry about all of this! This is certainly not ideal or how we want anyone using the software. 

Please let me know if you have any questions.

Kind Regards,
Aaron

Technical Support Specialist
Photo of luis

luis

  • 3 Posts
  • 0 Reply Likes
Thanks for sharing this worked for me switching to "Use the software-only mode" .

Best regards,
Luis