Missing Markers in Quiz properties

  • 3
  • Problem
  • Updated 2 years ago
Camtasia 9.1.1 
When I create a quiz and select to display feedback, there is an option to jump to Marker. Even though I have Markers on the Timeline they are not listed/selectable in the Quiz properties see image below. It works a treat on the Mac.

Has anyone else experienced anything similar?
TIA, Jayne
Photo of Jayne Davids

Jayne Davids

  • 198 Posts
  • 174 Reply Likes

Posted 2 years ago

  • 3
Photo of Rick Stone

Rick Stone

  • 5775 Posts
  • 2756 Reply Likes
That would certainly appear to be a bug to me! I tested on my own setup and I see the same behavior.

All I can think of to suggest as a workaround is to carefully note the time at each marker, then use the Jump To Time action instead.

Cheers... Rick :)
Photo of Jayne Davids

Jayne Davids

  • 198 Posts
  • 174 Reply Likes
Thanks for taking the time to check and reply Rick. I agree, adding the time is a workaround. I guess  I was interested to see if anyone experienced the same and had reported it. I'll advise Tech Support.
Cheers,
Jayne
Photo of math4cc

math4cc

  • 2 Posts
  • 0 Reply Likes
Jayne, has this been resolved?  I have the same challenge.
Photo of Jayne Davids

Jayne Davids

  • 198 Posts
  • 174 Reply Likes
Hi, it’s been reported as a bug but I’ve not been advised of when it will be resolved. You can use the ‘jump to time’ as a workaround.
Photo of math4cc

math4cc

  • 2 Posts
  • 0 Reply Likes
Thank you Jayne...I am having a challenge with the time jump as well.  The inputs for minutes must be less than 30.  I need to jump to the 35th minute and the software will not accept anything over 29 even though my video is 52 minutes long.  I was hoping to use the marker as a work around for the time limitation.
Photo of kayakman

kayakman, Champion

  • 7170 Posts
  • 2383 Reply Likes
the go-to-time hotspot time controls accept minutes, seconds, frames; they work OK for all minute values
Photo of Nicola

Nicola

  • 5 Posts
  • 0 Reply Likes

I am having the same problem with quizzes. 'Jump to marker' dropdown list is empty. 'Jump to time' will only allow a value of 00:59:29 max even though my video is 3 minutes.

Hotspots work ok.

Photo of patou.favard1

patou.favard1

  • 2 Posts
  • 0 Reply Likes
i have the same problem. I deflect with 'jump of time" and it does not work
i use camatasia 9
thank's
Photo of kayakman

kayakman, Champion

  • 7170 Posts
  • 2383 Reply Likes
I just made a short test; it works for me

but you need to upload the production to a web site or to screencast.com; the go-to-time function will not work on videos played on the local PC

here is my test project ...

https://www.screencast.com/t/gjTpMNKQ

select the "wrong" answer to test
(Edited)
Photo of kayakman

kayakman, Champion

  • 7170 Posts
  • 2383 Reply Likes
HEADS UP

Go-To-Time In-Quiz Navigation Behaves Like Go-To-Time hotspots

Go-To-Time interactive items can be corrupted by subsequent timeline insert or cut edits

see this thread for details ...

https://feedback.techsmith.com/techsmith/topics/editing-a-project-with-last-minute-cuts-or-time-inse...
Photo of kayakman

kayakman, Champion

  • 7170 Posts
  • 2383 Reply Likes
UPDATE

I've fooled around some more with go-to-time in quiz feedback; it seems that the behavior will work when played off a local PC; not sure why my earlier test indicated otherwise

furthermore ... since the pick marker dropdown is broke, use go-to-time instead; you'll get the same results since the markers just denote a time value anyway

place your markers anyway [easier to navigate timeline], then make note of their time hacks

better test video ...

Quiz Go To Time Right Wrong Test
http://www.screencast.com/t/xskbYK9rvw
(Edited)
Photo of Jayne Davids

Jayne Davids

  • 198 Posts
  • 174 Reply Likes
Thanks for all your help in testing this & finding workaround Kayakman
Photo of kayakman

kayakman, Champion

  • 7170 Posts
  • 2383 Reply Likes
you're welcome, Jayne

I just hope TechSmith gets it fixed ASAP

but I can't see how this got past QA before CS9 was released?  they never tested?
(Edited)
Photo of martin

martin

  • 6 Posts
  • 2 Reply Likes
Hi Kayakman, I watched the test video. it seems to work for you.
the problem is still present in the time selector.
The select marker shows an empty selection box.

using Windows 10 / version 9.1.1 build 2546.
I'm curious to your workaround / setup to get by this issue.

grt Martin

Photo of kayakman

kayakman, Champion

  • 6985 Posts
  • 2246 Reply Likes
what specific problem in the time selector are you referring to?

and yes, the marker dropdown is still broke; it's a known bug
Photo of martin

martin

  • 6 Posts
  • 2 Reply Likes
the fact that I can't enter anything than a 0 in the minutes box ( see the message pls enter between 0 and 0 .....to me this is a 'special design feature' on boundary validation ;-)

the first post is about 3 months old... any word on fixing this in the nearby future?
(Edited)
Photo of kayakman

kayakman, Champion

  • 6985 Posts
  • 2246 Reply Likes
OK, thanks for the additional info; got it now

I just tested; had the same problem; minute box will only accept 0; looks like another bug

I'll report that to tech support

have not heard back when the marker dropdown selector bug will get fixed

I do a lot of quiz-based projects, but have not used feedback in those projects; sorry I missed the minute box thing

and, I have no workaround for it [yet?]
Photo of martin

martin

  • 6 Posts
  • 2 Reply Likes
Thank's for the followup. Will see what Techsmith team will come-up with. I will tinker with the hotspot options to see if this will provide a form of check=> jump => repeat or go forward.

grt Martin
Photo of kayakman

kayakman, Champion

  • 6985 Posts
  • 2246 Reply Likes
I think I have a workaround; the bug is in the editor UI controls

if you edit the tscproj file you can hand-enter the correct jump-to-time value

I just tried a test project where a question was left at 0-0-0 but where I wanted 60 seconds; in the tscproj the value was 0; so I entered 60000 [miliseconds = 1 minute]; re-opened the project, and the quiz UI displayed the 1 in the minute box; produced and the wrong answer kicked me back to the 60 second [1 min] point
(Edited)
Photo of martin

martin

  • 6 Posts
  • 2 Reply Likes
That's a workaround that I will try (this thought  came to mind, but I din't locate the correct entry / file) :-)

Will try this tomorrow and will let you know if this is a viable workaround (for the time being).

 
Photo of kayakman

kayakman, Champion

  • 6985 Posts
  • 2246 Reply Likes
OK

I've reported to tech support already

I've also continued to fool around with setting feedback options; there seems to be some other bugs here, where time values entered [for seconds] are being retained in the tscproj after a feedback spec is changed from correct to incorrect; I haven't fully reverse engineered it yet?

but the workaround does seem to work reliably
Photo of kayakman

kayakman, Champion

  • 6985 Posts
  • 2246 Reply Likes
How To Workaround For Quiz Go-To-Time Bug
http://www.screencast.com/t/aKeZfXOJ
Photo of martin

martin

  • 6 Posts
  • 2 Reply Likes
I think that I got it working :-)

Using the Markers
fb_correct_action=\"fb_JumpToMarker\"  then set the Marker ID and Time stamp of the marker and the jumptime (to the same value).
fb_correct_jumptime_ms=\"3510\" fb_correct_url=\"\" fb_correct_marker=\"492DF7F7-A278-4B91-88EB-64A6BBC44A11\" fb_correct_marker_time=\"3510\"

Same setting for the incorrect answer
fb_wrong=\"\" fb_wrong_action=\"fb_JumpToMarker\" fb_wrong_jumptime_ms=\"2580\" fb_wrong_url=\"\" fb_wrong_marker=\"C99285F3-56AC-4001-B307-A4FBEB61F233\" fb_wrong_marker_time=\"2580\"

This seems to do the trick.

workflow used:
open Camtasia and Add markers (2 x)
add quiz.
select Jump to marker for good and wrong answer (this will create entries in the tscproj file.
save the project and exit Camtasia.
Edit Project file in Notepad++
Use marker ID and Timestamp and copy to Quiz Marker settings.
Use timestamp and copy to jumptime settings
save file.
Reload project in Camtasia and render files.
Note: don't select the Quiz / properties this will overwrite the adjustments just made ( and garble the timestamps! again)

Above resulted in video with quiz jumping back when incorrectly answered and forward to next section.

grt Martin
(Edited)
Photo of martin

martin

  • 6 Posts
  • 2 Reply Likes
One more observation on the timing.

The timing shows 'ms', however in the GUI timeline it will count from 0 to 29 and then roll over to the next second (ia 1 'tick' is 1/30 sec and not exactly a millisecond ) .

For example 01:14:07 (min:sec:ms2) would result in:
1 min = 60 sec + 14 sec = 74 sec * 30 + 07 = 2227 (time stamp)

or timestamp 3529

total seconds = quotient(3529;30) = 117 (30 for the 1/30 per timeline 'tick')
minutes =  quotient(total seconds = 117;60) = 1
seconds = MOD(total seconds = 117;60) = 57
ms2 = MOD(timestamp = 3529;30) =  19

gives a timeline time of 01:57:29.

(note: MOD and Quotient can be used in Excel)
grt Martin
Photo of kayakman

kayakman, Champion

  • 6985 Posts
  • 2246 Reply Likes
thanks for your contributions here; glad we now have a way to make it work as needed

I suspect that it may also be possible to edit the config files, post production, to achieve the same outcome; I'll give that a test later today
Photo of kayakman

kayakman, Champion

  • 6985 Posts
  • 2246 Reply Likes
OK; I've confirmed that you can also edit the config files, post-production, to fix this issue

How To Edit Config Files To Fix Quiz Go To Time Bug
http://www.screencast.com/t/VyupxJpQw
(Edited)
Photo of cvos

cvos

  • 2 Posts
  • 4 Reply Likes
This huge bug is rather old now, more than three months. We are not looking for a workaround where I work - but a patch to fix it. No words from Techsmith about this?
Photo of kayakman

kayakman, Champion

  • 7170 Posts
  • 2383 Reply Likes
not that I know of

TechSmith generally does not announce when bug fixes will be released; but bugs that do get addressed are usually included in a "next" release
Photo of kayakman

kayakman, Champion

  • 7170 Posts
  • 2383 Reply Likes
Update ...

tech support confirms that they are aware of the bugs in the quiz UI re missing markers in dropdown, and the issue with the minutes text box control

they have indicated that these bugs will be addressed in the next maintenance release; but there is no scheduled release date to pass along
(Edited)
Photo of cvos

cvos

  • 2 Posts
  • 4 Reply Likes
I wrote to support and got the same answer yesterday. Fast support, thats nice - but thanks for your update.
Photo of David D

David D, Technical Product Manager - Camtasia

  • 139 Posts
  • 174 Reply Likes
Just a quick update on this issue. We do have a fix for it and it will go out in our next maintenance release.
Photo of Jayne Davids

Jayne Davids

  • 198 Posts
  • 174 Reply Likes
That's great news David, thanks for letting the community know.
Jayne
Photo of mibelib

mibelib

  • 1 Post
  • 0 Reply Likes
Tnx David. When is next maintenance due??
Photo of kayakman

kayakman, Champion

  • 7170 Posts
  • 2383 Reply Likes
it is already released, CS 9.1.2.; now available for download