Mouse pointer is wrong size

  • 1
  • Problem
  • Updated 1 year ago
I run Camtasia on a high DPI machine and for some reason that mouse pointer that gets recorded is 2x the normal size.  In Camtasia 8 I fixed this by doing a cursor effect that changed the size by 50%.  

How do I do this in Camtasia 9?  It looks like cursor effects in C9 allow you to make the mouse pointer *bigger* but not smaller. 

Any suggestions?

-Ben
Photo of Benjamin Day

Benjamin Day

  • 33 Posts
  • 12 Reply Likes

Posted 1 year ago

  • 1
Photo of Dubie

Dubie

  • 964 Posts
  • 743 Reply Likes
I know of no way to make the mouse size smaller than the recorded size in Camtasia 9.
As you state, larger but not smaller.

Has your mouse been customized to be larger on your system or are you using any accessibility settings ?

Maybe try using a smaller mouse on your system or turn off any accessibility  setting temporarily when doing a recording and see if that is better.

That is the best I can suggest shy of contacting support and see if they might have a solution.


Get Free Service Tech Support by:

Opening a support ticket at:
https://support.techsmith.com/hc/en-us


Or you can call:

Toll Free:
800-517-3001 (U.S. & Canada Only)

Monday through Friday
8:00 AM to 7:00 PM EST


Chat with Support:
https://support.techsmith.com/hc/en-us/

Monday-Friday
6:00 AM to 9:00 PM ET

Saturday
12:00 PM to 4:00 PM ET.
(Edited)
Photo of Benjamin Day

Benjamin Day

  • 33 Posts
  • 12 Reply Likes
Hi Dubie --

My mouse pointer settings in Windows 10 haven't been customized -- I'm using the defaults.  I believe that this is an issue with how Camtasia handles systems with high DPI screens.  

I think I'll eventually have to contact tech support about this.  Thanks for the suggestion.

-Ben
Photo of Benjamin Day

Benjamin Day

  • 33 Posts
  • 12 Reply Likes
I found a solution.  It's not a particularly elegant solution but it's a solution.  I guessed that the error message in the Camtasia 9 user interface that prevents you from putting a value in for cursor size that's less than 100% was just an arbitrary value.  So if you set the value in the UI and then open the tscproj file directly in notepad, you can change the value from 100% to 50% and it works fine.  It renders perfectly. 

@TechSmith Camtasia Team, all you have to do is to change that validation rule in the code!  Other than that, it's already implemented!

-Ben 
Photo of Dubie

Dubie

  • 964 Posts
  • 743 Reply Likes
This is good to know.

Thanks :)
Photo of Benjamin Day

Benjamin Day

  • 33 Posts
  • 12 Reply Likes
FYI, here's the fix.  Open the Camtasia 9 project file (*.tscproj) in Notepad or some other text file editor (don't use something like Microsoft Word).  Do a find and replace in the file.

Find
"cursorScale" : 1.0
and replace it with
"cursorScale" : 0.5
Then save the file.  From this point, you can open it back in Camtasia 9 and it's perfectly happy and will render the videos exactly how you want.