New SNAGIT 2018 version: problem with the video capture

  • 5
  • Problem
  • Updated 3 months ago
Before i have SNAGIT 13
I bought the new SNAGIT 2018 version: the video capture of the screen area does not work.
The sound of the screen is recorded, the webcam also but not the screen.
In SNAGIT Editor, I have an "INITIALIZING"
Thank you in advance for your help
Photo of stievenardp

stievenardp

  • 3 Posts
  • 1 Reply Like

Posted 2 years ago

  • 5
Photo of Robert R.

Robert R., Online Community Admin

  • 1563 Posts
  • 469 Reply Likes
Hi there;

We have seen quite a bit of success with Snagit 2018's video capture functionality; have you tried the steps listed in this article that covers troubleshooting video issue? If so and it is still not working, please open a support ticket so an agent can look into this for you.

-Robert
Photo of chet

chet

  • 1 Post
  • 1 Reply Like
Same issue -- Windows 10 on a new computer with everything up to date, new install of Snagit 2018.  Video recorder appears to work, but the video is just a static "Initializing" image (the first frame of what should be a longer video, I suppose).

Ran the registry updater to use software encoding, did not help.  
Photo of stievenardp

stievenardp

  • 3 Posts
  • 1 Reply Like
me too :(
Photo of julie

julie

  • 1 Post
  • 0 Reply Likes
me, too - unfortunately, none of the suggestions here have helped
Photo of j.alley

j.alley

  • 1 Post
  • 0 Reply Likes
same thing for me - Snagit 2018 broke my recording of audio AND video - only now records VIDEO - whats up?
Photo of 3TSolutions.ca

3TSolutions.ca

  • 1 Post
  • 0 Reply Likes
Windows 10, snagit 2018.2.1
Program was operating fine for about a week, and then today it stopped working.A Windows update recently occurred, and I also updated my sound drivers
Re-installing makes no difference.
I performed a system restore to prior to the update and also the driver update. Did not fix the problem, and my audio sounded terrible.
I undid my restore session, the windows update repeated.
Back to square one. My audio was working though.

I decided to uninstall my audio drivers, and then deleted the sound card from device manager. I also re-installed my nvidia(or ati) drivers performing a clean install.
After performing both remedies, I re-installed Snagit and it is operating fine.
The odd thing is, the sound card driver I had re-installed apparently was the already on my computer (I did not notice I was up to date) currently I am using the Windows driver, but will be installing the driver from the manufacturer (creative labs) to gain some functionality back.
Hope this helps.
(Edited)
Photo of Greg A.

Greg A.

  • 1 Post
  • 2 Reply Likes
Hi, I have the same issue. I upgraded to Snagit 2018. The screenshots work fine but not video capture.

Nothing here is applicable to this issue described though and I have a super powerful computer and should not have to compromise below any default settings and definitely do NOT want to use software mode only. I have two onboard high end graphics cards and have like 64 GB RAM etc.

System info:
https://www.screencast.com/t/290NJkLGMeL
https://www.screencast.com/t/4s9OwCrOnh (graphics card #1)
and
https://www.screencast.com/t/ibhICG38t2gm (graphics card #2)


Here is my original issue for reference:But, after upgrading to 2018, I get this on VIDEOS after they process: 
https://www.screencast.com/t/CrIpKyhulo7B


I have all requirements and more for Snagit 2018 here https://support.techsmith.com/hc/en-us/articles/203731518-Snagit-Windows-Troubleshooting-Video-Capture and have .NET 4.7.1 too.

Please let me know thoughts on this so I can try it some solutions?

Surely, others are having the same issue as us as well?

:)

Greg
(Edited)
Photo of stievenardp

stievenardp

  • 3 Posts
  • 1 Reply Like
It still does not work for me. I have to use version 13 for now
Photo of andrew4375

andrew4375

  • 2 Posts
  • 10 Reply Likes
Greg. I know what the problem is.....see below for my fix
Photo of mscbrande

mscbrande

  • 2 Posts
  • 0 Reply Likes
Hi Robert, I uninstalled my SnagIt 2011 and bought/installed SnagIt 2018.  None of my video captures work.  My application crashed / hung every time.  I looked over numerous kb or equivalent.  When is this going to be fixed?  I am using Windows 7
Photo of Fred Grover

Fred Grover, Champion

  • 2425 Posts
  • 376 Reply Likes
I am using SnagIt 2018 on a Windows 10 Laptop and I have not having this issue. I also have used it on Windows 7 but had this issue so it could be something with Windows or another setting that causes this issue.

I found this article from Support for Windows 7. I did what it said to do with the instructions and it now works on Windows 7 for me. Try this and see if it helps or not and if not then please contact the TechSmith Support and see if they can help you with the issue.

https://support.techsmith.com/hc/en-us/articles/115002732932-Snagit-Windows-Crash-or-hang-when-stopping-video-in-Snagit-2018-on-Windows-7

Hope this helps and thanks for posting and let us know what you find out. Have a great day/night.
Photo of mscbrande

mscbrande

  • 2 Posts
  • 0 Reply Likes
I already looked at that article.  I didn't understand or see a reason why I have to make this software only.  Why does snagit 11 work?
All I wanted to do is reduce size of snagit videos.  Now  i have a mess
Photo of Dubie

Dubie

  • 1306 Posts
  • 1051 Reply Likes
Thats what you got out of those articles? Use software mode?

That's not the important one of the options.

First Snagit 11 and Snagit 2018 are two completely different designs.

2018 is a complete rework and isn't going to be like Snagit 11.

I'm running Windows 7 ultimate and have no problems with the video recording.

A few questions...

1.  Does  your system meet the minimum requirements?

Snagit 2018
  • Microsoft Windows 10 (1703, 1607, and 1511), Windows 8.1, Windows 7 SP1 (32-bit and 64-bit), Windows Server 2012 R2, Windows Server 2016
  • .NET 4.6 or later
  • 2.4 GHz single core processor (dual core i5 required for video capture)
  • 1 GB of RAM (4 GB required for video capture)
  • 500 MB of hard-disk space for program installation
  • Video and Panoramic capture on Windows N requires the Media Feature Pack for Windows N
  • We recommend the 64-nit Snagit installation when using multiple monitors or a 4K display

2.  Do you have service pack 1 installed?
Install service pack 1
Download service pack 1

3.  Is your .net framework 4.6 or higher?
Latest version .net 4.7 download

4.  Did you download and run the file recommended in the article?
It's just a registry fix.
UseAlternateHWEncoder.zip

  1. Close Snagit so it is not running at all. Make sure it is closed by checking the notification area (by the Windows clock).
  2. Download and save this zip file.
  3. Unpack the file by double clicking it.
  4. Double click the REG file inside and click OK to the prompts.
  5. Launch Snagit and try recording another video.


Download a fresh copy and uninstall.reinstall Snagit 2018
Latest version 2018

If all is up to date and still no go than the route to follow is support.

Contact Free Tech Support...

Open a ticket, Call them or Chat
https://support.techsmith.com/hc/en-us

:)
Photo of Leave Comments

Leave Comments

  • 5 Posts
  • 1 Reply Like
Wow. That is a whole lot of stuff to check to run version 2018. I am on win 7 with a good computer, but I am going to downgrade. I need my easy fast video capture back. Very disappointed.
Photo of ben.sacherich

ben.sacherich

  • 16 Posts
  • 8 Reply Likes
Thanks @Fred_Grover.  The link you provided (https://support.techsmith.com/hc/en-us/articles/115002732932-Snagit-Windows-Crash-or-hang-when-stopping-video-in-Snagit-2018-on-Windows-7) fixed my issue.  I downloaded the .reg file, ran it, and restarted Snagit.  I'm not able to record video and the Processing works like it used to in v13. 

No reinstall was necessary.

(Update 12/21/2017)   I've made a 5-6 short videos the past few days.  A few of the times the video capture would crash during the "Initialize" phase, right before recording.  I'm not sure if this is related to this same issue or it is a new unrelated issue.  YMMV
(Edited)
Photo of andrew4375

andrew4375

  • 2 Posts
  • 10 Reply Likes
Ok Everyone I had the same Problem as Greg but on my laptops only. My desktop didn't have this problem. I tried the registry fix dropped the video quality and still had the issue and then I decided to try this and it fixed the problem. I am not a computer wizard so I may be syntactically incorrect about some of the things I say. It looks like it a graphics processor control problem. The laptops I have are running medium to high end NVIDIA Quadros. one laptop has a  K5100M and the other a M2200. When you have a laptop with an added graphics card the laptop has 2 graphics processors the one from NVIDIA and the Integrated graphics processor. Through the NVIDIA control panel you can actually assign a graphics processor to a specific program. The trick was assigning the Integrated graphics processor to the Snagit2018 program. To do this follow these steps....

1. right click a blank area on your desktop and select "NVIDIA Control Panel" from the contextual menu
2. Select "Manage 3D Settings" (under 3D Setting) from the tree on the left. You will see 2 Tabs "Global Settings" and "Program Settings" 
3. Select the "Program Settings" Tab and there will be a drop down list ("1. Select a program to customize") allowing you to select a specific program. If you do not see SnagIt click the "Add" button beside the drop down list. The program should be listed in the corresponding window if not browse for it.
4. then you can assign the graphics processor to the program ("2. Select the preferred graphics processor for this program") Select "Integrated Graphics"  
5. Select the "Apply" button and close all windows, reboot the computer (not necessary to reboot if you shut down Snagit completely from the system tray on the desktop) and re-start SnagIt.

I am not sure about other graphics cards but I have been around long enough to know that the concept will be the same. 
in a nut shell force the program to run from the on-board graphics not the installed graphics card.

Once again the issue with Snagit only happened on my Laptops. SnagIt ran fine on my desktop which has a NVIDIA Quadro P4000 but I do not have an option to select the integrated graphics processor on my desktop. Not sure what science is behind that but I hope this solves some peoples issues.
Photo of Robert R.

Robert R., Online Community Admin

  • 1551 Posts
  • 463 Reply Likes
H Andrew4375 and thanks for stopping by and taking the time to post the steps you have taken to alleviate the issue.

I'll pass this information along and do some internal testing.

Thanks again!

-Robert
Photo of arloemerson

arloemerson

  • 1 Post
  • 0 Reply Likes
thanks andrew4375, your fix works! for others, restart not required, just make sure you really kill your snagit proc first.

win10 version 1709 OS Build 16299.248
nvidia version 382.05 GeForce GTX 1070
Photo of Tim

Tim

  • 2 Posts
  • 0 Reply Likes
brilliant @andrew4375 - works a charm for me too. Although I don't have NVIDIA but integrated Intel. Your hot tip was 'maybe it's a video driver setting in regards to 3d'...aye... it is
Photo of 4evermaat

4evermaat

  • 100 Posts
  • 26 Reply Likes
thanks for this tip.  But Techsmith needs to do a better job of self-diagnosing problems.  If you contact their support they will want you to grab dump file, run dependency walker, run process monitor, and try about 10-12 other things before apparently accepting that a bug actually exists.

Instead they should have a bug reporter that grabs all of the diagnostic info that is needed and allow user to run the tool.

TS has poor bug reporting/debugging tools and asks the user (who is often not so technically inclined) to do too much.
(Edited)
Photo of ateunen

ateunen

  • 1 Post
  • 0 Reply Likes
This fix worked beatifully, thanks!
Photo of wjgentry

wjgentry

  • 1 Post
  • 0 Reply Likes
This fixed my issue as well!!!! Thank you
Photo of sjdnever

sjdnever

  • 2 Posts
  • 1 Reply Like
THANK YOU SO MUCH for posting this. I was so frustrated, because nothing else I'd tried was working, and I was on the verge of rolling back to an earlier version . . . really appreciate you taking the time to post the help. 
Photo of cameron.rees

cameron.rees

  • 1 Post
  • 0 Reply Likes
This fix works, poor software design, the video capture works when the HP laptop was on the docking station, laptop mode showed initializing (sic) and no video. Pissed off after recording 5 minutes to try and debug design software.
(Edited)
Photo of Manna8

Manna8

  • 1 Post
  • 0 Reply Likes
Didn't work for me, I got an error - Nvidia 3D settings are not compatible with integrated graphics.
Photo of scott

scott

  • 1 Post
  • 0 Reply Likes
Worked for me. I'm using the onboard graphics from the motherboard, but was having the same issue. The instructions above were close enough to enable me to figure out how to configure the settings. Thanks for posting.
(Edited)
Photo of FX_Dave29

FX_Dave29

  • 1 Post
  • 0 Reply Likes
THANK-YOU so much for this. Spent hours trying to sort this!! Snagit, poor on you for not putting this out!!!!!!
Photo of ben.sacherich

ben.sacherich

  • 16 Posts
  • 8 Reply Likes
I have a Dell Precision laptop.  I tried many of these suggestions and could not get the video capture to work when using my Logitech USB headset.  It was crashing right after the 3.2.1..countdown.  

Yesterday I upgraded from version 2018.0.1 to 2018.0.2 using the "Check for Updates" option on the help menu.  My video capture is working now.

On thing I'd like to note in case this is a side effect.  After rebooting, my output to Google Drive plugin was missing.  I had to download the plugin from the website and shut down Snagit before it would install properly. 
Photo of ben.sacherich

ben.sacherich

  • 16 Posts
  • 8 Reply Likes
Update:  My video capture still crashes if I don't select the audio device from the main Snagit screen, before clicking the round Capture button and selecting a region.   If I try to change the audio device to my Logitech headset after selecting a region, it will crash after the 3.2.1 countdown.   
Photo of cp

cp

  • 3 Posts
  • 0 Reply Likes
Still not working (Thinkstation P500 with Nvidia Quadro K2200). After I draw a region for video capture, the area stays grey saying "Initializing". Forever. After exiting with ESC, Snagit is unusable and I have to kill it via task manager. Updater says 2018.1.0 (64-bit) (Build 775) is the latest version.
Photo of cp

cp

  • 3 Posts
  • 0 Reply Likes
Update: Although I turned of audio recording (microphone and system sounds) in SnagIt before I click the record button, SnagIt crashes on the Initializing part. When I deactivate my DSP audio card (Sonic Core Pulsar II) in the device manager, video capturing would work. There seems to be a bug in SnagIt in combination with audio drivers.
Photo of cp

cp

  • 3 Posts
  • 0 Reply Likes
That's what worked for me (I have an additional sound card which has conflicts with SnagIt):
Step 7 of https://support.techsmith.com/hc/en-us/articles/211117907-Snagit-Windows-Troubleshooting-Audio
Photo of brdog

brdog

  • 1 Post
  • 0 Reply Likes
I went through all of the standard tips for over 2 months in the past. Try to disable your monitor display spanning if you have multiple monitors. I have 4. See here https://www.screencast.com/t/iV5VglUQ setting to max 3d worked for me. However, I desire to use spanning with Snag it but the new version does not seem to like spanning. Techsmith, also, what do you think? Spanning is definitely a issue (100%) on this "Initializing" hang in the software.
Photo of jamespitts

jamespitts

  • 1 Post
  • 0 Reply Likes
Though what worked for you didn't work for mine, I did something similar where I switched the advanced 3D settings for hardware accelerated 3D applications that use Direct3D or OpenGL to let the 3D application decide. Closed down Snagit, re-opened and voila!https://www.screencast.com/t/xIys9y3Pfj
Note: I also have Snagit pointed to use the Integrated graphics instead of my NVIDIA GTX1080 Ti. I guess these new video cards bring too many ponies to the show, literally.
Photo of dominic-lavoie

dominic-lavoie

  • 19 Posts
  • 2 Reply Likes
I have successfully recorded videos with version 2019.1.0 but it only works if i have a USB microphone plugged in even if i don't use it. Can also record with onboard mic as long as USB mic is plugged in. Can also record with no microphone as long as the USB microphone is plugged in.

Talk about a major design flaw!!!
Photo of dominic-lavoie

dominic-lavoie

  • 19 Posts
  • 2 Reply Likes
Finally found the problem with the help of Techsmith. It's the Alienware Sound Center that was preventing Snagit from initializing the audio feed. SO i just have to exit the program whenever i want to record videos.

https://support.techsmith.com/hc/en-us/articles/211117907-Snagit-Windows-Troubleshoot-Audio
Photo of Rick Stone

Rick Stone

  • 5204 Posts
  • 2459 Reply Likes
Appreciate the post. It will likely help others facing similar issues.
Photo of dominic-lavoie

dominic-lavoie

  • 19 Posts
  • 2 Reply Likes
Making the world better one little problem at a time ;)
Photo of dominic-lavoie

dominic-lavoie

  • 19 Posts
  • 2 Reply Likes
Procedure that works for me is :

1- Exit alienware soundcenter (probably applys to all third party sound centers)
2- Restart snagit (Exit and start)
Photo of Alec Brown

Alec Brown

  • 7 Posts
  • 1 Reply Like
Hi, 
Wondering if you can share a little more detail on how you got this working and does this apply to the current version 2019.11 build 2860 of Snagit or just 2018?

I too have an Alienware but I don't see a match on the SoundCenter, it seems like that is integrated with the Alienware Command Center(AWCC)?  I have tried turning off all of the audio features within AWCC which does not help.  The AWCC application restarts itself if I end the task.  I found and stopped the "AWCCService" then was able to kill AWCC without it restarting but Snagit still won't record video and spits out that same error about audio.



Error on launch for VIDEO capture


I read all of these issues and workarounds and can't help but think it's time to find an alternative product.

Photo of dominic-lavoie

dominic-lavoie

  • 19 Posts
  • 2 Reply Likes


To verify if you have an issue with alienware software, you could uninstall it to be sure.T his fix works for for both 2018 and 2019 version but i went back to 2018 because the 2019 editor was freezing my laptop!

 I also agree that snagit is becoming more and more troublesome and this probably won'T change until there is a product able to really compete with it, because as of now, I have tried 3 times in the last 3 years to find an acceptable replacement and didn't succeed.
Photo of Alec Brown

Alec Brown

  • 7 Posts
  • 1 Reply Like
Thank you much, I appreciate the graphic to help.  My setup isn't quite like that.  I've gone through the pains of disabling any/everything I could think of..  I've spent hours on this which seems ridiculous...

Maybe support will surprise me and be helpful..  
Photo of dominic-lavoie

dominic-lavoie

  • 19 Posts
  • 2 Reply Likes
If i was you i would try uninstalling all the Alienware software. maybe you don't even really need any of it.
Photo of Alec Brown

Alec Brown

  • 7 Posts
  • 1 Reply Like
Perhaps - I have a ticket in with Alienware as well and TechSmith support so far only offers the disable/uninstall for the Alienware audio.  So far no luck but will keep working on it and share if any luck.

The comment from support regarding the audio dependency:
..."in order for Snagit to be able to mute and unmute the audio while you are recording, the audio needs to be able to be initialized.  This is why it is required, otherwise users would not be able to mute and unmute while the recording is taking place. "
Photo of dominic-lavoie

dominic-lavoie

  • 19 Posts
  • 2 Reply Likes
The comment from support is just avoiding the issue. If the user doesn't select audio recording when configuring the recording session, it is because the user won't be using audio! And if the user was able to start recording without audio and then unmute audio during the recording, what would be the purpose of the audio options to begin with!? Either the suppprt tech who wrote this doesn't know what he is talking about or he is trying to make it look like all of this is unavoidable!
Photo of Alec Brown

Alec Brown

  • 7 Posts
  • 1 Reply Like
I give up - I'm done with Snagit.  I've been a paid user since the 90's when I was in consulting and used it to help make shiny documentation for clients.

I've found these alternatives:
Video = Cyberlink Screen Recorder.  Use coupon SR20OFF and the Honey web app got me another $3 off.
Screen Captures = Greenshot (free!)

Hopefully Snagit gets their act together - I am not happy to part ways but my time and frustration deserve better. The app while fine for screen captures has become bloated and slow.  The interface is a mess compared to previous versions and support is not helpful.