New version of snagit is laging on a 64bit windows 10.

  • 3
  • Question
  • Updated 3 years ago
This new version of snagit is laging on a 64bit windows 10. I have used older version of snagit and never had an issue. The laptop I have is new with 8GB of RAM and hardly under any kind of load. So I am not sure the source of lag.
Photo of nick.augustine

nick.augustine

  • 1 Post
  • 0 Reply Likes

Posted 3 years ago

  • 3
Photo of Divebug

Divebug

  • 2 Posts
  • 0 Reply Likes
I'm having a similar issue. While taking a series of region captures, the cross hairs to target the capture is very difficult to control - very laggy/choppy performance. I'm capturing to a Word doc. Had no such issue in previous versions. Win 10 Pro 64bit/Snagit 13.0.2
(Edited)
Photo of jepsondesign

jepsondesign

  • 3 Posts
  • 0 Reply Likes
I am not able to install 13 on Win 10 Pro 64bit 

error 1603 ?  can't figure out how to fix it. Repair instructions don't work for me. ?
Photo of Joe Morgan

Joe Morgan

  • 7262 Posts
  • 3966 Reply Likes

jepsondesign
I don't know what error 1603 is but tech support will know.

This is a Free Service. Submit a ticket at,

https://support.techsmith.com/hc/en-us/requests/new


Or call, >>> 1.517.381.2300

 Toll Free: 800.517.3001 (U.S. & Canada Only)

8:00 AM to 7:00 PM EST Monday through Friday

Regards, Joe

(Edited)
Photo of jepsondesign

jepsondesign

  • 3 Posts
  • 0 Reply Likes
2 months later and still can not install 13 on windows 10 pro x64
Photo of Daniel Barnett

Daniel Barnett

  • 2 Posts
  • 0 Reply Likes
Same ... and I'm even on a spec'd out machine - i7-6820HK, 32Gb DDR4, PCIe3 SSD and 4k screen capture with as few as ~3 floating layers becomes laggy all over.  *especially* when using the scroll bar to scroll up/down view of an image.  

Any beta's in the works we can get our hands on?