None of the behaviors in Camtasia 9 work like the thumbnail

  • 1
  • Problem
  • Updated 7 months ago

Behaviors are a very cool idea but I can't get any to work like they show. I exited and started Camtasia again but that had no impact.

For example, the Scale behavior thumbnail shows the letters displaying individually from left to right and large to small. My text comes in all at once then shrinks out. I have tried various combinations of settings and it still does not change. 

There is nothing in the Help that explains what the options actually do. "Choose the desired motion effects" is not sufficient to help me. No matter what I do, I cannot get the behavior to "behave" like the thumbnail.  

If the action does not apply to each letter, why do you show it that way?

Animating separate letters and animating all the words are very different effects.

Photo of patti.schulz

patti.schulz

  • 34 Posts
  • 13 Reply Likes
  • very disappointed and frustrated

Posted 2 years ago

  • 1
Photo of Kelly Mullins

Kelly Mullins, TechSmith Employee & Helper

  • 2732 Posts
  • 563 Reply Likes
Hi Patti,
I'm sorry you are having trouble!

I think I might know what is happening but please correct me if my thoughts are not right.

If you want the Behavior to act EXACTLY like the view in the icon, you need to add a TEXT ONLY callout to the video. The Behavior is applied to whatever you put it on. So, if you put it on a callout with text, it applies to the motion and behavior of the callout as a whole. Not as individual letters.

Please see this demo as a comparison. I used the same exact Sliding Behavior on each object, you can see how different they perform.
Overall, I think you might be using a graphic callout, and you need to use the Plain Text Callout to get the look you want.

http://screencast.com/t/0hfWyk2bSDQ

Also, there is another setting to be aware of that controls the overall aspect of the Plain Text Behavior actions. You can find that here and it tells the
Behavior to treat the plain text callout on a per-letter basis or as one object - like the image callouts behave.
From there, you can choose further how you want the letters to behave.



Thank you for asking this question. I'm sure others will find this helpful.

(And, if this was not the issue, please let me know!)

Kelly
User Assistance
TechSmith
(Edited)
Photo of patti.schulz

patti.schulz

  • 34 Posts
  • 13 Reply Likes

This is the issue and your explanation makes sense. You should add that you find the plain text under the Basic grouping.

Thanks.

Photo of Kelly Mullins

Kelly Mullins, TechSmith Employee & Helper

  • 2732 Posts
  • 563 Reply Likes
Hi,
I'm glad this was resolved for you!

For others coming to this page, I thought I would post an image of where to find the plain text options.
Under Annotations tab > Callouts subtab, there are several themes of callouts to choose from in the Style dropdown menu.

In each theme, there are two plain text options as seen below.



Thanks again, Patti for raising this topic.

Kelly
Photo of Kristen F

Kristen F

  • 45 Posts
  • 19 Reply Likes
The only problem with this solution is that this forces me to have a drop shadow on my text. I do not want drop shadow on my text, and the only way to remove it is to use the Legacy text option. However, the Legacy text does not work with the behaviors either. It animates all at once rather than letter-by-letter, as Patti describes at the beginning of this thread.
  1. Is there a way to remove shadow from Camtasia 9 text only?
  2. Is there a way to get behaviors to work on Legacy text as shown in the Behavior thumbnails?
Photo of Joe Morgan

Joe Morgan

  • 5629 Posts
  • 2920 Reply Likes
Yes you can, and it's simple.

Open Visual Properties with the text selected.



Click the "X" to the right of the Drop Shadow Window. Done!

Regards,Joe

Photo of Kristen F

Kristen F

  • 45 Posts
  • 19 Reply Likes

Awesome! Thanks Joe, that worked. I see now why I wasn't finding it. The Drop Shadow property was almost hidden in my menu. Once I scrolled down I was able to find it. I'm not really a fan of the low-contrast, hidden-scrollbar style of this interface for this reason. But that's a whole other topic. :)

Photo of Kyle Ortman

Kyle Ortman

  • 58 Posts
  • 7 Reply Likes
How do I get behaviors to do nothing during?
I can't seem to find a "Do nothing" option in the dropdown.
Photo of Kristen F

Kristen F

  • 45 Posts
  • 19 Reply Likes

Here you go! Under behaviors, click "During", then scroll to "None."

Photo of Kyle Ortman

Kyle Ortman

  • 58 Posts
  • 7 Reply Likes

Jeeze what am I blind?!?!?

I guess I was just expecting the none option to be at the top. I am litterly doing the facepalm right now. Doght!

(Edited)
Photo of Kristen F

Kristen F

  • 45 Posts
  • 19 Reply Likes
I had the same problem when I first looked for it! I was expecting it to be at the top. When your eyes are skipping around looking for what's expected, sometimes you overlook what's right in front of you. I had a facepalm moment with that as well. XD
Photo of Soph Marx

Soph Marx

  • 31 Posts
  • 17 Reply Likes
Also, what does it mean when you select the red bar in the behavior on the text and it turns yellow? It doesn't seem like you can make it move on the track, shorten it, or anything. Are we supposed to use the  In, During, and Out to do that?

I, too was searching forever for "do nothing" on the Out, because I wanted the text to stay there, not slide away. Do nothing seems a bit more intuitive. 

Also, with the "speed", why is it in a percentage? Seems a bit odd. I'm not sure what to do with that.  And what do you mean by offset? Is there anywhere in the help that defines each option and what you can do with it? The terminology is not intuitive. For example, what is "ease both" ? Both of what?

If we didn't want to use the presents because they are way too comprehensive and confusing, how do we just slide in the text for each bullet item and leave it there?

Photo of luca.mengoli

luca.mengoli

  • 1 Post
  • 0 Reply Likes
Hi guys, this thread has been really useful. I also want to apply the behaviors to the text only and not to the slide however by using plain text I cannot change the color of the background; by default it comes in black and I would like to turn into pink for example. Do you know if that's possible and if yes how?
That would be awesome! 
cheers
Luca 
Photo of Joe Morgan

Joe Morgan

  • 5629 Posts
  • 2920 Reply Likes
Standard text callouts don't have a background.

Chose a rectangular callout with a background instead. Change it's color to whatever you like.

Regards,Joe
(Edited)
Photo of boyd.su

boyd.su

  • 10 Posts
  • 5 Reply Likes
I would add that, if you are wanting to retain the behavior on the text (as discussed in replies above) you could do a text only object with the desired behavior, and place a basic shape of any color behind it, as a separate object.  The shape can fade in, or just appear, or whatever you want it to do, and the text can dance in front of it however you'd like.

Great conversation here!
Will