Pasting image into Word for Mac no longer works

  • 1
  • Problem
  • Updated 7 months ago
Anyone else had this issue and found a fix?

I've been pasting images from Snagit (Mac) into Word for Mac 2011 for years and then today all I get is a blank placeholder. I've double-checked and it's only an issue with pasting the image as I can use the insert photo function from the menu - but that's the long way round.

This is one of those quick and simple things I do all the time, so I'm really hoping it's simple to fix.
Photo of martin

martin

  • 4 Posts
  • 1 Reply Like

Posted 7 months ago

  • 1
Photo of Rick Stone

Rick Stone

  • 4498 Posts
  • 2007 Reply Likes
Makes me wonder if it's related to what the thread below discusses.

https://feedback.techsmith.com/techsmith/topics/screenshots-faded-in-mac
Photo of martin

martin

  • 4 Posts
  • 1 Reply Like
Thanks for the link, Rick. I will check that out and report back. Much appreciated.
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 711 Posts
  • 175 Reply Likes
Hi,

Do you know if this happened as the result of a Snagit update, or a MS Word update?
Photo of martin

martin

  • 4 Posts
  • 1 Reply Like
Hi Luke. Hard to know for sure. It's only started happening within the last week or so and I can't say if an update triggered it.

That said, I'm now starting to think it's a Mac or Word issue rather than a SnagIt one.

I've just opened up some older Word docs that have images pasted in from SnagIt, which were visible at the time I created the docs, but now all I see is a blank space placeholder.

I'm using Word for Mac 2011 version 14.4.7 and SnagIt 2018.
Photo of martin

martin

  • 4 Posts
  • 1 Reply Like
SOLVED! After finding a forum post elsewhere, I checked in my Word preferences and somehow I had a check against Image placeholders. I unchecked this and everything is back to normal. It's baffling as I'm the only person using my Mac and I have no recollection of checking that feature.

Anyway, I'm going to shuffle away quietly now... ;-)