Pausing causes audio out of sync

  • 1
  • Problem
  • Updated 4 years ago
Snagit 12.4.1 on Windows 7. Pausing the video capture causes the audio to get out of sync a bit each time. The bits accumulate, so after several pauses the audio is noticeably out of sync and the result looks/sounds like a parody of Kung Pow. I see lots of old posts on this problem, but no solution. Any solution for this? 
Photo of Kenny Moore

Kenny Moore

  • 2 Posts
  • 2 Reply Likes

Posted 4 years ago

  • 1
Photo of Timbre4

Timbre4, Champion

  • 680 Posts
  • 273 Reply Likes

Hello,

This may have to do with the way SnagIt does video these days. It used to product an AVI output that few people then knew what to do with, so in recent years it has become an MP4 ("instantly sharable") output instead. If the pauses are absolutely necessary, you may need to do something else. (somebody else comes in behind me and tells you how to fix this? keep fingers crossed)

Depending on your projects / budget consider Camtasia Studio 8 as it gives you full editing with transitions, effects, multiple track timeline, etc.

Photo of Joe Morgan

Joe Morgan

  • 7252 Posts
  • 3959 Reply Likes

Kenny,

If you are attempting to record a video playing that contains audio. Or any form of media that is using system audio for playback  you will encounter this problem.

It Looks/sounds like a parody of Kung Pow.

 That's a hilarious and accurate description of the issue. However, this can be averted. This a Workaround.

The problem occurs when the audio stream is recorded independent of the video stream. The audio track becomes out of sync with the video track as you pause and restart a recording. So when you save the recording the syncing problem is part of the recording process and comes along for the ride.

The way to avert this is to record the video and audio combined as one recording. Although, you will need sacrifice the ability to record audio with your microphone simultaneously to accomplish this.

See Image Below, Click to Enlarge

1.       You will need to set “Microphone Input” to system audio in SnagIt Preferences first.

2.       You will start a screen recording in order to access the options for recording audio on the recording toolbar. “The easiest thing to do is start a recording and hit { Shift + F9 } right away to pause the recording .Then make your changes”. Why they don’t give you access to those controls before you start a recording has never made any sense to me.

3.       Set microphone recording to on.

4.       Disable system audio recording.

That’s it. You can now record and pause as often as you like.

 

I’ve been aware of this syncing problem for several years now. I’ve just never connected the dots until now.

Timber, the same thing would happen with Camtasia Studio. I ran today's tests using Camtasia, SnagIt, Bandicam and Corel Video Studio. The results were all the same.

I will probably post this as an Idea or something along that line tomorrow so others can be aware of this. I’ve seen the audio out of sync complaints posted several times in the past. I’ve never seen a solution posted for it either. So it was worth the effort. {: >)

Regards, Joe

(Edited)
Photo of Timbre4

Timbre4, Champion

  • 680 Posts
  • 273 Reply Likes

I didn't think he was using SnagIt like a VCR/DVR for existing videos, I thought he was pausing his own original narration captures. This would remain a problem regardless of platform.

Timber = trees

Timbre = music

Photo of Kenny Moore

Kenny Moore

  • 2 Posts
  • 2 Reply Likes
Thank you Timbre and Joe.

Joe - I am currently making some PC tutorials and recording my own narration, but I will definitely keep your suggestion in my toolbox for later use. 

Timbre - Thank you for confirming that this is a known issue, not something I am doing wrong. My imperfect workaround is to do the whole video in one take then edit out all the many oops parts. Kind of a pain, but for the price and features Snagit is still an awesome tool. I do not do enough video work to justify an upgrade to Camtasia today - maybe someday. 
Photo of Joe Morgan

Joe Morgan

  • 7226 Posts
  • 3930 Reply Likes

Kenny,

I don’t believe there is a problem with the SnagIt screen recorder.

I think you should try setting your microphones recording levels to 44,100 Hz at 16 bits.

Why do I say this? This is the holy Grail for audio recording when you’re working with TechSmith products.

I have never detected any issues with my microphone recordings getting out of sync with the video track. I also pause frequently when recording a video and I use narration. I always use the same audio settings for my microphone as posted above.

I assumed that you were recording a video playing and you were probably seeing the lip movement of a character that was out of sync with the audio track. This is typical of what happens when you record video with system audio. A very Kung Pow effect.

 Camtasia is my screen recorder of choice but I thought I should put SnagIt through its paces.I'm just one of those people that enjoys trying to resolve issues.

So I started recording my desktop with SnagIt while I was straightening up my computer room and watching some television.Over the course of an hour I recorded a video that wound up being 48 minutes in duration. I also paused and restarted the recording 75 times. I kept track of the pauses and marked it down to ensure that I did just that.

So once I restarted the recording for the final time I had a folder open on my desktop.

Then I placed my cursor over some images in the folder. When I left clicked on an image I would count. I continued to do that until I selected 10 images as I counted to10. At that point I save the video and I played it back in the SnagIt editor.The mouse clicks and my counting were in sync with the video.

 This doesn’t indicate that there’s a problem with SnagIt to me.

 I suggest you try those settings and see how it works for you. I hope this helps you out and let me know if this resolves the issue for you.

Good luck, Joe

I didn't mean to misspell your name Timbre.I've always thought that your name was Timber so sorry about that.

(Edited)
Photo of Timbre4

Timbre4, Champion

  • 680 Posts
  • 273 Reply Likes
No worries - it's just different.
Photo of Here's Johnny

Here's Johnny

  • 28 Posts
  • 14 Reply Likes

Thanks a million Joe! I changed my microphone settings and it solved the problem.

cheers John