Playhead won't snap to markers in CS 9?

  • 1
  • Question
  • Updated 2 years ago
Wondering if anyone else is seeing this?

When I make a timeline selection, the playhead no longer seems to "snap" to a marker like in CS 8.

I've set the View - Timeline Snapping - Markers...

Am I missing something?

Thanks,
- Lon
Photo of Lon Naylor

Lon Naylor

  • 84 Posts
  • 52 Reply Likes

Posted 2 years ago

  • 1
Photo of kayakman

kayakman, Champion

  • 6250 Posts
  • 1834 Reply Likes
that is the behavior I see

my technique when wanting to make a selection up to a marker is to use shift-ctl-[ or ] keys
Photo of Joe Morgan

Joe Morgan

  • 5681 Posts
  • 2949 Reply Likes
I can confirm this. It happens anytime I have a marker highlighted and/or selected.

Un-selecting the marker restores snapping.

I'm going to  report this bug right now.

Regards,Joe
(Edited)
Photo of Tim Frost

Tim Frost

  • 75 Posts
  • 54 Reply Likes
Lon,

You are not missing anything...TechSmith is missing something.  That something is a RIGOROUS, pre-release beta test of Camtasia 9 in which they should have seen all of these egregious errors in Camtasia 9.

I have already ceased using Camtasia 9 and reverted back to Camtasia 8.6...perhaps you should to the same thing.

Tim
Photo of ExpertNovice

ExpertNovice

  • 352 Posts
  • 105 Reply Likes
That really needs to be fixed!  Our work-around is to set the timeline to maximum detail to try and avoid gaps or overlaps then reset the timeline.
Photo of Dubie

Dubie

  • 962 Posts
  • 742 Reply Likes
It only works for me if I  have the option above Timeline Snapping
"Enable Playhead Snapping " also checked

This posts also confirms this
https://feedback.techsmith.com/techsmith/topics/camtasia-9-playhead-snapping-not-enabled-by-default
(Edited)
Photo of Lon Naylor

Lon Naylor

  • 84 Posts
  • 52 Reply Likes
Thanks Dubie. If you notice in my screen shot, I do have that enabled. My problem is snapping from marker to marker (something I do a lot).

If I make a selection TO a marker, it snaps. Starting by snapping to a marker (or double-clicking it) and then going to another marker doesn't snap the second marker. 
(Edited)
Photo of Dubie

Dubie

  • 962 Posts
  • 742 Reply Likes
Oh, ok I got it. Thought you meant it wouldn't snap to any marker. Hopefully they shoot out an update before long to fix some of these quirks and maybe add a few much needed/used features back in.
(Edited)
Photo of Aaron Y

Aaron Y, Employee

  • 75 Posts
  • 6 Reply Likes
Hey Everyone,

As noted, making sure "Enable Playhead Snapping" is checked will help. However, if the Marker is selected in the timeline, then we do not "snap" to that marker. This behavior is different than in Camtasia Studio 8. If the Marker is not selected, then we can "snap" to it.

I have gone ahead and added this to our feedback so the proper team will take a look.

Please let me know if you have any questions!

Kind Regards,
Aaron
Technical Support Specialist
Photo of Hannah Tolstoy

Hannah Tolstoy

  • 3 Posts
  • 0 Reply Likes
I cannot for the life of me figure out how to get snapping to work AT ALL. I have ALL FOUR of the snapping checked. But when I clip any segment or do ANYTHING to make a gap, it never snaps, ever. So I have all these gaps to deal with... It's driving me crrraaazzyyy.

Can anybody tell me what I am missing, so that I can start using this needed function? (I'm not super familiar, so please tell me the exact path of where to go in the menus to make the changes needed, I don't really know where things are).

THANK YOU very much in advance!

USING: CAMTASIA STUDIO 8

Hannah
Photo of Lon Naylor

Lon Naylor

  • 84 Posts
  • 52 Reply Likes
I think you want "Auto-stitching".

Tools...Options...Program tab...Enable Auto-stitching checkbox.

- Lon
Photo of Hannah Tolstoy

Hannah Tolstoy

  • 3 Posts
  • 0 Reply Likes
Thanks for responding Lon..But I just checked ant auto-stiching was already clicked...


So it wasn't that :-(


Am I missing anything else?
(Edited)
Photo of kayakman

kayakman, Champion

  • 6250 Posts
  • 1834 Reply Likes
Hanna, are you trying to cut content and have the gap automatically close?

if so, use ctl-X [cut]

does that work?
(Edited)
Photo of Video Engineer

Video Engineer

  • 72 Posts
  • 16 Reply Likes
in CS9....there is an easy fix   "view" menu and turn on "ENABLE PLAYHEAD SNAPPING"

when i contacted support and asked them to change this to default 

We actually have it turned off by default due to user demand/beta feedback; having it enabled by default gave users with intricate projects the sense that Camtasia was stuttering / performing poorly (because the playhead was not smooth while moving it on the timeline). Is there anything else I can assist you with today?

looks like they are decreasing the functionality for a changed "perception" of smoothness
Photo of Lon Naylor

Lon Naylor

  • 84 Posts
  • 52 Reply Likes
I have a video in my Camtasia 9 Survival Guide series on this.