PNG image looks odd after editing in SnagIt

  • 3
  • Praise
  • Updated 1 month ago
So a SnagIt update was released today. I was happy to see it and gleefully installed it.

Later, I was attempting to create an image and part of that involved trying to coax one of the new images in WebP format into SnagIt. When that little process failed, I thought: No problem, I'll just find an on-line converter and sure enough, the great and mighty googler didn't disappoint.

Uploaded and converted to PNG and BOOM, I'm in business!

Here's where the misplaced blame comes into play.

In the SnagIt editor, things looked all hunkey dunkey. Same for the thumbnail. But when I went to pop the image into the other application, it looked absolutely dreadful. My first instinct was to say Hmmmmm, I just upgraded SnagIt. So there must be a bug!

Then I thought: Perhaps it will behave differently if instead of doing the click and drag from the recents tray, I instead save the file to the hard drive. But nope.

So I'm nearly to the point where I'm about to report to TechSmith as a bug that was introduced with the new SnagIt upgrade. But I pondered the situation. And it hit me that the image began life as a WebP and was converted to PNG. So I looked in SnagIt at the Save As options for PNG format. And sure enough, the image was configured for 256 colors and not True Color + Transparency.

Once I made that little change, BINGO!

So this post is just to illustrate that SnagIt was receiving unjust blame. It was my own actions that caused the issue, but because I had just updated SnagIt, I was too eager to point the finger there.

Hopefully somewhere down the line this helps somebody avoid the mistake.

Cheers... Rick :)
Photo of Rick Stone

Rick Stone

  • 4830 Posts
  • 2176 Reply Likes

Posted 1 month ago

  • 3
Photo of Timbre4

Timbre4, Champion

  • 659 Posts
  • 261 Reply Likes

Thanks for going the extra mile to confirm what really happened!