Prevent snapping on canvas by holding CTRL does not work

  • 1
  • Problem
  • Updated 2 months ago
  • (Edited)
It works when I move clips on the timeline but it does not work when I drag / reposition clips on the canvas. Is this a bug or is it not supposed to work?

As a workaround I use "Enable Canvas Snapping" but the shortcut (Ctrl + ;) does not work here (German keyboard layout - maybe this is the problem?). So it's annoying to open the menu every time you want to reposition a clip precisely.



(I'm working with Camtasia 9.)
Photo of lukas

lukas

  • 23 Posts
  • 4 Reply Likes

Posted 2 months ago

  • 1
Photo of lukas

lukas

  • 23 Posts
  • 4 Reply Likes
Nobody?
Photo of Dubie

Dubie

  • 1199 Posts
  • 941 Reply Likes
CTRL + ; works for me on a US keyboard. Both Camtasia 9 and 2018.

Just to cover some bases as I do not know your knowledge level using Camtasia.

On the Timeline holding down the CTRL key and dragging with the mouse will temporally disable the snapping.

On the Canvas you have to toggle the snapping on or off.  CTRL + ; toggles it On/Off
There is no Hold and drag to temporally disable the snapping.

If you already know that is how it works but it's not working for you then...

Maybe it may be the difference of the keyboard as you mention. Maybe there is a different key combo
fo CTRL + ;  ??

It may just be not working in your copy.  Bug ??

Unless some one else that is using a German keyboard comes a long and may know something than your quickest solution may be to contact support directly.

 Techsmith Free support

Open a support ticket here:
https://support.techsmith.com/hc/en-us

Or

Phone:
    +1.517.381.2300
Toll Free:
    800.517.3001 (U.S. & Canada Only)
Hours:
    8:00 AM to 7:00 PM EST Monday through Friday

Chat:
   6:00 AM to 9:00 PM EST Monday thru Friday


Dubie

TechSmith Resources         
Support      Tutorials     Version Downloads _________________________________________________________

Photo of lukas

lukas

  • 23 Posts
  • 4 Reply Likes
Hi Dubie,

thanks for your posting!

On the Timeline holding down the CTRL key and dragging with the mouse will temporally disable the snapping.
Yes. As I mention on my posting this works perfectly.

On the Canvas you have to toggle the snapping on or off.  CTRL + ; toggles it On/Off
There is no Hold and drag to temporally disable the snapping.
Okay. Thanks for the clarification. I already spent a lot of time writing with the support. The support told me that Canvas snapping by holding CTRL should work and if it doesn't work for me I should change some/delete registry values and install different graphic card drivers. :-|

But back to the hold-and-drag-functionality:
There is no Hold and drag to temporally disable the snapping.
Why not?!? I would think of it to be very obvious that if holding CTRL temporarily disables snapping on the timeline, it should do the same for the canvas. That's just consistent and people would expect it like that. So what is there against adding this functionality to Camtasia with the next update? If you often reposition elements on the canvas it's really tedious to always switch it off and on again.

...if at least the shortcut for the menu entry would work :-)
Maybe it may be the difference of the keyboard as you mention. Maybe there is a different key combo
fo CTRL + ;  ??
Indeed that could be the problem. But the shortcuts must work with every keyboard layout. I'm using many programs (Studio One, Adobe Creative Suite, Visual Studio etc.) and none of them has problems with recognizing my ";" key as a shortcut. So if that's the problem, it's a bug that should be fixed.

I apologize for my clumsy English.

Lukas
Photo of Dubie

Dubie

  • 1199 Posts
  • 941 Reply Likes
Your English is good, No need to apologize.

I too wish we could just hold CTRL to temp disable the canvas snapping but I have only ever been able to turn it on/off with CTRL + ;  keystrokes.

It would be nice if Techsmith would Change this behavior.

Dubie
TechSmith Resources         
Support      Tutorials     Version Downloads _________________________________________________________