Problem syncing recorded PowerPoint slide show with audio files

  • 1
  • Question
  • Updated 3 years ago
Hi there - total newbie here - using Camtasia version 9.
I have a PowerPoint presentation with embedded animations and videos. I've recorded audio for each slide and brought these files into Camtasia. I then recorded my slideshow (ie timing of slide transitions) using the Camtasia add in while listening to recorded sound files to ensure I got the timing of transitions correct. 
Problem is when I bring in the resulting .trec file into Camtasia, the timings are off - with the slides taking much longer to transition than I'd recorded, and as a result they don't sync with the audio files. Any insights on what I can do or why this is happening? Any assistance gratefully received :)
Photo of jasmine


  • 2 Posts
  • 1 Reply Like

Posted 3 years ago

  • 1
Photo of Jayne Davids

Jayne Davids

  • 218 Posts
  • 199 Reply Likes
Hi Jasmine,

Have you tried producing the video? Sometimes the PC resources can make your Camtasia project seem out of sync but when you produce it, you my find it's OK.

If it's still out of sync then you could use the editing capabilities to manually sync. E.g. The clip speed feature might help. Right click the clip and add clip speed - adjust as required.

Other editing features that might help are: trim, cut, split.

An alternative workflow would be to record the slideshow first, then add voice narration after. The slideshow will play on the canvas whilst you record the voice narration.

I hope this helps,

Photo of George G

George G

  • 1 Post
  • 0 Reply Likes
This could also be a result of the software using a variable framerate.  I use SnagIt 14 and I believe the way it captures is identical to Camtasia.

I recorded like 5 videos with a mix of desktop screen capture and a separate video camera for software demos.  The problem I had after the fact was the audio on my TechSmith file was COMPLETELY off from the action.  My audio synced between the SnagIt file and the video file I shot, but the desktop capture was out of sync with the audio embedded with it. It took me about 19 hours to resync the footage looking for points when my presenters typed something or clicked a mouse. It was horrible.

A variable framerate like that is used to save file space while still having really nice looking captures, which this software can provide. I just don't understand why its a feature to have the audio completely out of sync from its video. As long as there is motion on the screen, it should be recording. As soon as you stop moving the mouse or changing slides, it stops recording. I thought talking into a webcam would keep the recording going, but mine still screwed up. Seems like yours did as well.  You should be able to go through a powerpoint, talk the entire time and have it just in sync with your actions. Anymore legwork is an absurd waste of time.

What I did to make it a *a little better* was find a JavaScript block of code that was nothing more than a clock with seconds shown. I put that into a webpage and made it my sidebar window so something on the screen was moving 100% of the time I was recording.  You can crop the clock out after you're done within Camtasia so all you see is your PowerPoint. Just make sure you're recording then entire desktop, not just the program window.  I still didn't have that standard 29.97 frames per second as most video, but at least the video wasn't 20 seconds off from its audio.

Also, make sure you're recording at the highest quality.... I think it should technically help keep it at that standard framerate, although there is no way to disable variable frame rate recording feature.
Photo of Robert R.

Robert R., Online Community Admin

  • 1635 Posts
  • 525 Reply Likes
Hi there!

There could be a number of causes for this particular issue and as such the best place to receive some assistance on it would be with our Support Team. Can you please open a support ticket so an agent can look into this for you?

Photo of jasmine


  • 2 Posts
  • 1 Reply Like
Hi all - thank you so much for the detailed, thoughtful replies - I am honored to have joined such a helpful community.  As Jayne predicted, I found that once the video was produced, the gap seemed to disappear.  I also found my audio wasn't quite at the right points so manually moved them to improve it.  The video I've done is far from perfect but it's definately better than it was and will do for what I need. Thank you all again for the help :)
Photo of Jayne Davids

Jayne Davids

  • 216 Posts
  • 197 Reply Likes
You're welcome. Glad I could help.