Problem with new Snagit 2019

  • 2
  • Problem
  • Updated 6 months ago
  • (Edited)
My new Snagit 2019 has issues with the stamp application.
When I try to use the stamps, it always uses the last one used, and so, I have to click the new one again. Usually, it will do the same thing of continuing to use the last stamp used and having to click a second time to get the new stamp. Sometimes, it will go back to the last two or three stamps used, and of course, I have to click again on the new stamp to get it to work.

In other words, the stamp application doesn't work consistently when you click on an icon or image to stamp, it doesn't respond right away to the image clicked. Its very annoying to have to go back and forth instead of clicking on the image you want to actually use.

UPDATE: 
I have a folder with my custom stamps, I only have four, and they are made in PNG which I imported to a folder that I can access on my desktop.  It is usually one of these stamps that keeps reappearing. If I go to say business section of stamps and click on my work, I get one of my custom stamps that have been imported.  This repetition of a stamp is always from one of my four custom stamps. Why?  They are PNG, and properly imported! 

Photo of Tony Coty

Tony Coty

  • 83 Posts
  • 12 Reply Likes

Posted 8 months ago

  • 2
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1088 Posts
  • 262 Reply Likes
Hi,

Sorry about this! We haven't seen anything off with stamps, do you think you could make a quick video of what you're seeing?
Photo of Tony Coty

Tony Coty

  • 83 Posts
  • 12 Reply Likes
I have tried last year to make a video, and had all sorts of problems with it. So, I just gave up with videos. I was unable to stop the video even though I know there is a button to do so, it disappeared. It's been a while since I tried, but it was a pain to do a simple video. 

(Edited)
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1088 Posts
  • 262 Reply Likes
If you do a region video instead of a fullscreen, the stop button will be much easier to find. If you're not up for making a video, the other thing you can do is get in touch with our Tech Support team and they'll be able to take a look at what you're seeing.
Photo of Tony Coty

Tony Coty

  • 83 Posts
  • 12 Reply Likes
Ok Luke, I figured out how to do the video. Here it is. Notice that every time I go to click on a stamp, in any category, it starts with another stamp from the original one I started. 

Damn, now it wont let me upload the video to this forum. I don't have Youtube of other ways to load this video. I can send by email.
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1088 Posts
  • 262 Reply Likes
cool, you can send it to me at l.griffioen@techsmith.com
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1088 Posts
  • 262 Reply Likes
Thanks for the video, I see what you mean now. I'll bring this issue up with the development team.
Photo of Tony Coty

Tony Coty

  • 83 Posts
  • 12 Reply Likes
Thanks Luke for taking time to read and follow up on this problem. If you figure it out or developers do, please let me know if its my problem or a corrected update is needed.
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1088 Posts
  • 262 Reply Likes
So I was looking at this some more and it looks like 2018 and 2019 are behaving the same. If you switch categories nothing is selected, so it draws the last stamp you had. If you select something first, it should draw the stamp you have selected.
That said, we should probably automatically select something when you switch categories to avoid this confusion.
Photo of Tony Coty

Tony Coty

  • 83 Posts
  • 12 Reply Likes
speaking of confusion, I don't understand your solution!
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1088 Posts
  • 262 Reply Likes
Here's a quick video of what I'm referring to (includes audio). https://www.screencast.com/t/BQo8wd7yzok
Photo of Tony Coty

Tony Coty

  • 83 Posts
  • 12 Reply Likes
Luke, thanks for taking time to help with a  video, but the problem is not category, its every time you select within a category.

Example:

1. Select item number 1
2. Click on canvas, number 1 appears.
3. Click on another item, no. 2, and once again no. 1 appears.
4. click it again, THEN select no. 2, and only then it shows no 2.
5. Click on a third item, no. 3, and click on canvas and once again no. 1 appears.

This goes on and one within the same category! Even if your version shows that it has to be clicked more than once, that makes no sens, why should these stamps not work when you click on them? Why should they be clicked multiple times to work correctly. I'm afraid there is a problem with this feature!  Let me know if you want another video showing what I'm trying to explain here.
Photo of Paul

Paul

  • 1625 Posts
  • 1200 Reply Likes
I have the same issue but it's not limited to stamps.  I use the favourites section A LOT.  I find that the first click on any item often does not "take" and  I have to go back and a second click is required.  I thought it was trigger finger, but now I'm not so sure
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1088 Posts
  • 262 Reply Likes
Thanks I see what you're saying. I'm not able to get that to happen though, I would open a ticket with our Tech Support team, so they can help figure out why it's behaving like that for you.
Photo of Paul

Paul

  • 1625 Posts
  • 1200 Reply Likes
Thanks Luke, I will raise a ticket.  I thought it was the general sluggishness, and SnagIt not having time to recognise the mouse click

Just as an indicator of how flaky SnagIt has become, I have used it since 2002.  In the first 15+ years I raised zero tickets because it just worked.  In the last 11 months, roughly since the new UI was launched I have raised 20, soon to become 21  

15 years with none.  11 months with 21 - nearly 1 ticket every 2 weeks

That speaks volumes about how much the product has been degraded by a vanity makeover.  So sad.  So sad.
Photo of Tony Coty

Tony Coty

  • 83 Posts
  • 12 Reply Likes
I hear you Paul! I started with SnagIt 8, windows version, and was quite happy with it, and quite adapt with it. When SnagIt10 came to the scene, I stopped using snagit. Started again when I changed from Windows to Mac in 2016, and have been thoroughly disappointed in the as you say, "degrading" of the product. I've complained on Facebook and to support, and have asked them to stop upgrading and making the user interface a constant new learning curve, but I highly doubt they listen, I'm but a mere customer, what do I know?!

Another comparison I've brought to the attention of the support staff has been that I've used Photoshop for many many years, and although they have upgraded and added features, the basic tool set has remained the same, no new learning curve. Photoshop is complex enough that it doesn't need more learning curves with basic tool operation. I have suggested to SnagIt staff to consider following Photoshop's successful concept of keeping things as they are even when upgrading, but again, who am I but a mere customer giving feedback!
(Edited)
Photo of Tony Coty

Tony Coty

  • 83 Posts
  • 12 Reply Likes
Luke, thanks for suggesting that I go to support, I don't want to have to go through all this explanation all over again. Too much of a bureaucratic hassle. I thought talking to you was like talking to support, I guess I'm wrong. Thanks for your time1 
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1088 Posts
  • 262 Reply Likes
If you call support, they can set up a screenshare so they can actually see what's going on while talking in real time. Given the nature of this problem, I think this would help get to the root of it.
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1088 Posts
  • 262 Reply Likes
Hi Tony,

We had one user internally run into this and we learned a few things from it:

1. When you're running into this, you can still drag a stamp from the sidebar onto the canvas and get the one you're expecting
2. You can right click a stamp and add to the favorites tool and use it from there instead

After doing step 2, the entire stamp tool started working properly again. This is a little unfortunate because it makes it tricky for us to nail down the root cause, but if that works for you as well, then great!

Let us know if either of these workarounds help
Photo of Tony Coty

Tony Coty

  • 83 Posts
  • 12 Reply Likes
I tried what you suggested, and this is what I got (see attached video)!!

Ok, tried to upload my video, and your form wont accept it. Please let me know how to send it to you so you can see for yourself that this "fix" doesn't work!
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1084 Posts
  • 262 Reply Likes
If you have a link you can post it here, otherwise you can send me the file at l.griffioen@techsmith.com
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1084 Posts
  • 262 Reply Likes
Thanks, I got your video. It's definitely behaving strange. So for the 2nd item I suggested, what I did was add some stamps to favorites and then use them from the Favorites tool. After that, the stamp tool started to work again.
Photo of Tony Coty

Tony Coty

  • 83 Posts
  • 12 Reply Likes
Yup, this time it worked by using the favorites stamps. Went back to regular, not favorite stamps, and it worked. Thanks Luke1