Problems with System Audio Recording on macOS Mojave

  • 1
  • Problem
  • Updated 3 months ago
After the last update to the system audio recording, all recordings are getting audio lagged. It was not like this. Please go back to the old plugin. I have several recordings to make and with this problem, the working time has doubled.
Photo of Helber Marques Lacerda

Helber Marques Lacerda

  • 1 Post
  • 0 Reply Likes

Posted 6 months ago

  • 1
Photo of Paul Middlin

Paul Middlin, Employee

  • 932 Posts
  • 218 Reply Likes
Hi Helber,
We've been getting some reports of this problem for certain users or certain machines. It is not everyone, however, so we are investigating it to reproduce the problem and solve it.

We can't just go back to the old plugin, because Apple has changed the way that audio works in their most recent hardware they are shipping. As such, the old plugin was completely broken, and irreparable. That's why the new approach.

It sounds like your machine was working with the old plugin just fine, which means you can go back to it for now if you like. We would, however, appreciate it if you contacted Tech Support so we could have a closer look, and maybe at some point ask your help in testing fixes for this issue. If you are willing, please make your support request ATTN: Aaron Y.

https://support.techsmith.com
Photo of Jeroen Burgers

Jeroen Burgers

  • 1 Post
  • 0 Reply Likes
Having similar issue with 10.14.5 / Snagit 2019. When I try to install the Audio Component, after authorising it immediately responds with 'Install Failed, Please try again'. Quite annoying, as I absolutely need ability to record system audio.