Prolem with copy/paste images from Snagit for Mac to Outlook 2011 for Mac

  • 6
  • Question
  • Updated 1 year ago
  • Answered
How can I copy/paste images from Snagit for Mac to Outlook 2011 for Mac?

I've just switch from PC to Mac. I've also started to use Snagit for Mac. I am able to take screenshots on Snagit for Mac. The problem is when I click on "Copy All" in Snagit, then try to paste the image into Outlook for Mac. Instead of the image showing in the email, I get a link to the image location in my hard drive. Is this is a Snagit issue or a Outlook for Mac bug/setting?

Thanks!
Photo of LX Internet

LX Internet

  • 2 Posts
  • 1 Reply Like

Posted 5 years ago

  • 6
Photo of Jason Eagleston

Jason Eagleston, Employee

  • 553 Posts
  • 66 Reply Likes
Hi,

If Outlook is set as your default email client, you can use the "Email" button in the lower right-hand corner of the Snagit Editor, which should give you exactly what you're looking for.

http://screencast.com/t/P2icWyA5202
Photo of LX Internet

LX Internet

  • 2 Posts
  • 1 Reply Like
Yes, I can do that, but then the image is attached to the email. I would like to be able to paste multiple images in the email, and write comments between the screenshots. In Snagit and Outlook for Windows, it's easy, I can simply copy in Snagit and paste it into Outlook. The problem is Outlook for Mac. If I copy the image in Snagit for Mac, then paste it into Outlook for Mac, I only paste a text line with the location of the image, I can't paste the image itself. I don't know if this is a Snagit or Outlook 2001 for Mac issue. Can you please look into it?

I have found a temporary solution, it requires one extra step. I drag the image from Snagit to the Mac desktop, then I drag into the Outlook message, in this case the screenshot is embedded into the email, and I can insert multiple images. Anyway, it works, but it requires one extra step. I think it would be better if Snagit for Windows and Mac worked the same way, but the issue might be with Outlook not Snagit.

Thanks.
Photo of Jason Eagleston

Jason Eagleston, Employee

  • 553 Posts
  • 66 Reply Likes
Sorry for this inconvenience, another possible workaround is to create a new email in Outlook and drag the image thumbnail directly from the Snagit tray (the area at the bottom of the Snagit Editor) into the body of the new email message. This will embed the image in your email.

I realize this isn't the exact behavior you're looking for, so I apologize for the inconsistency between platforms, but hopefully this will make your workflow a bit easier :)

Thanks,

Jason
Photo of Carson Miller

Carson Miller

  • 3 Posts
  • 2 Reply Likes
This is a hugely annoying bug. This is something people do every day with screenshots - send them via email and discuss.

I'd like to see this fixed ASAP. It makes no sense that I have to go to another program to paste, then cut/paste again into Outlook. Makes no sense - it seems the "clipboard" would be the clipboard?
Photo of Jason Eagleston

Jason Eagleston, Employee

  • 553 Posts
  • 66 Reply Likes
Hi Carson,

An additional workaround that is more in line with your Snagit Windows workflow is to right-click the capture in the tray down at the bottom of the Snagit Editor window and choose the "copy" menu option. When you switch to an Outlook message, you can paste right in the body of the email.

Here is a quick screenshot of the menu in the tray area: http://screencast.com/t/aT7XS9pJd

I hope this helps, thank you very much for taking the time to provide feedback, we really appreciate it.

Jason
Photo of Carson Miller

Carson Miller

  • 3 Posts
  • 2 Reply Likes
Hi Jason,

Thanks for the reply. This is a good workaround. That said, can you help me understand the clipboard functionality? I can't understand why it would be inconsistent based on what application you try to paste into. I doesn't seem to make much sense that using the SnagIt "copy all" (i.e. - the clipboard icon) would sometimes paste a link and sometimes paste the actual copied image.

Also, I many times prefer to set SnagIt to automatically copy the image and not to show the editor at all. Unfortunately, this takes on the same behavior as the copy all icon - so it isn't an option.

Any info you have would be great.

Thanks,
Carson
Photo of Jason Eagleston

Jason Eagleston, Employee

  • 553 Posts
  • 66 Reply Likes
Hey Carson,

I'm glad this helped out :)

When an application copies content, it tells the system clipboard what kind of content it is (e.g. file, image, text, etc.). In this case, when you choose the "Clipboard" output to copy your capture, we are putting the file information (the file path) on the clipboard.

Now, this is only the first half of the process, the second half is when you are pasting. The application you are pasting to accepts and processes only certain types of information. In Outlook's case, they accept files as attachments or the raw image data, so when you paste into the body of an email, Outlook only sees the path to the file, which pastes in as text.

In the case where you right-click on the capture in the tray in Snagit, we are copying the raw image data, so when you paste into the Outlook message, Outlook accepts the image data, and the capture is embedded in your message.

I completely agree that this is very confusing. The main reason for having the different types of copying is many other applications expect the file path information, namely Finder.app. So someone that wants to copy a file and paste it to a Finder window would not be able to do so if we only put the raw image data on the clipboard.

I hope this explanation makes sense, unfortunately, to try and be compatible with both Apple applications and 3rd party applications, this confusion exists.

Thank you again for taking the time to provide feedback, feel free to post back with any other questions, or if my explanation above is unclear.

Jason
Photo of Carson Miller

Carson Miller

  • 3 Posts
  • 2 Reply Likes
Jason,

Much appreciated. I guess my remaining confusion is that when I use the "copy all" icon in SnagIt, I can then go to other MS Office apps (Excel, Word, etc) and I get the actual image pasted - not the link. Just seems strange.

That said, I'll use the workaround you defined for now.

Do you have plans to make this update anytime soon?
Photo of Jason Eagleston

Jason Eagleston, Employee

  • 553 Posts
  • 66 Reply Likes
I should have clarified this point, when you choose the "Copy All" output, we are actually putting both the file path information and the raw image data on the clipboard. The destination application dictates the paste type they prefer. So, in the case of Outlook, they seem to prefer to take the file information, whereas Word takes the image data. And likewise, Finder takes the file information. This produces the behavior where different applications have different results, and we're aiming to make Snagit as flexible as possible.

Keep the feedback coming and have a wonderful weekend :)

Jason
Photo of My Urban Child

My Urban Child

  • 1 Post
  • 1 Reply Like
Thank you for posting the 'right click - copy' option (and graphic) - I mistakenly thought that copy to clipboard was doing the same thing and when I could not include the graphics in my emails, it was extremely frustrating. I had tried to copy the saved image on the desktop, embedding it through the Outlook program itself, and nothing would work. Now, they paste right into the body of the email quickly and easily! Problem Solved!
Photo of Jack Fruh

Jack Fruh, Champion

  • 293 Posts
  • 46 Reply Likes
Snag it Mac "Copy All" output doesn't work properly.
Documented here:
http://www.screencast.com/t/dnb7A7creKT

This reply was created from a merged topic originally titled
Snag it Mac "Copy All" output doesn't work properly..
Photo of Jack Fruh

Jack Fruh, Champion

  • 293 Posts
  • 46 Reply Likes
It makes no sense to copy the file path - If a user wants to export the file as a file, then they would use "File->Save As" for everything else, Choosing "Copy All" should copy the data, the same as if we hit Control-C.

Please get this fixed (Come out with an extra output if needed, but get this resolved please!)
Photo of smakusdod

smakusdod

  • 3 Posts
  • 1 Reply Like
Can we make an action that is 'COPY IMAGE' instead 'COPY ALL'?
Photo of Gio

Gio

  • 2 Posts
  • 1 Reply Like
Is there a fix for this yet?
It is the single most important feature for me on my windows machine, and I find it very frustrating that it doesn't operate the same in the Mac OS.
Photo of Jeff Pek

Jeff Pek

  • 1 Post
  • 0 Reply Likes
Would really like to see a fix/better workaround. Not sure what's changed, but I don't even see a Copy action on the right-click menu for the thumbnail. So I seem to be completely out of luck.
Photo of Gio

Gio

  • 2 Posts
  • 1 Reply Like
Please Please fix this.
I do not understand why this is still an issue after being brought to you attention 2 years ago.
Photo of Nils Magne Løvrak

Nils Magne Løvrak

  • 1 Post
  • 0 Reply Likes
I also have the same problem. trying to use the send email button, an this alarme hits me:
The operation couldn’t be completed. (Cocoa error -2741.)

Photo of dma2112

dma2112

  • 3 Posts
  • 0 Reply Likes
I agree, was hoping version 3.02 which I just installed would fix this but it has not.  If I look into my clipboard manager, I see the image.  Outlook however just pastes the file path.  Can we get an option to not capture the file path so outlook can receive the image paste?  I don't like having to click and drag into an email.
Photo of M&Mteam

M&Mteam

  • 1 Post
  • 0 Reply Likes
WORKAROUND
Hello fellow frustrated user of Snagit on Mac

there seems to be a workaround.  If you go to Snagit > Preferences > Advanced > uncheck the box
"Automatically save my new captures to".  This prevents you from saving screenshots locally but now the benefit is that Outlook will get to paste screenshots when you paste it.

hope Techsmith will fix this problem

on version 1.0.4
Photo of John Thompson

John Thompson

  • 4 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled copy all - copy to clipboard.

I expect the "Copy All - Copy to Clipboard" icon on SnagIt for Mac, to essentially perform a "Select All" and then a "Copy" to copy the entire contents of whatever I'm editing, to the clipboard so that I may copy/paste the image into a document or email.   However, mine appears to only copy a localhost URL when I paste it into a document or email.  To get the desired functionality on the Mac that works as described (and how it works in windows), I have to manually go to Edit > Select All, then Edit > Copy; to get the desired functionality.  

Is this a bug, something that I can reconfigure, or am I perhaps doing something incorrectly?
Photo of John Thompson

John Thompson

  • 4 Posts
  • 0 Reply Likes
I am almost always trying to paste / embed the image into an email message (not attach it as a file), and the result has always been a URL for the local filesystem.
Photo of Paul Middlin

Paul Middlin, Employee

  • 306 Posts
  • 22 Reply Likes
Would you mind pasting into something other than outlook, as an experiment? Just trying to narrow down the bug.
Photo of John Thompson

John Thompson

  • 4 Posts
  • 0 Reply Likes
@Paul, pasting into Outlook 2011 for Mac (HTML Format; not text), it's just the URL.  However, pasting into Word or PowerPoint 2011, it is the graphic that's pasted in; with all elements.   
Photo of Paul Middlin

Paul Middlin, Employee

  • 306 Posts
  • 22 Reply Likes
Thank you, that's very helpful. It sounds like this is the same bug as described here by others and not something new. That means the workarounds could work for you for now. 
I'll discuss this again with the team. The issue is complicated for reasons I won't bore you with, but as Jason Eagleston mentioned above, it stemmed from trying to support dragging images right to your desktop in addition to being able to copy them. We need to address this.
Photo of Jack Fruh

Jack Fruh, Champion

  • 290 Posts
  • 46 Reply Likes
To add to this, If I choose Edit-> copy it works in outlook every time, 
If I choose the copy button on the bottom. this is when pasting into outlook pastes a link.
I think the fix is to make the share to clipboard button actually just fire off a command-C,  and if you want drag and drop, create a 'drag zone' in the UI somewhere, like they've done in programs like skitch. 

This conversation is no longer open for comments or replies.