Prolems with Playhead Jumping to Beginning and Clips Jumping to New Track in Camtasia 3

  • 1
  • Problem
  • Updated 11 months ago
Hi! First let me say that overall, I really enjoy Camtasia 3. However, I seem to have a problem when I click and hold the playhead, it jumps to the beginning making it difficult to position exactly where I want it. Additionally if I click and hold a clip, the clip tends to jump to another track.

Has anyone else had this problem? Is Techsmith working on a fix? 

Thanks,

Joey
Photo of Joey

Joey

  • 14 Posts
  • 2 Reply Likes

Posted 2 years ago

  • 1
Photo of benji

benji

  • 1 Post
  • 2 Reply Likes
I've found playhead-jumping issues in general... I wasn't sure if I should piggyback on here or create a new topic.

I've been using Camtasia 3 on Mac and love all of the new changes, interface, everything.  The one problem is the playhead issue.  Generally when I use any video editor, I click in the timeline to move the playhead where I want to start and press the spacebar to begin playing.  Frequently though, when I press the spacebar to play, the playhead jumps from where I manually positioned it to elsewhere earlier in the timeline and begins playing.  It could be user error, but I never ran into this issue with Camtasia 2 for Mac, Camtasia 8 for PC, or any other video editing software like FCPX.
(Edited)
Photo of davemillman

davemillman

  • 461 Posts
  • 141 Reply Likes
I have seen this unexpected cursor behavior. Twice I've tried to reproduce it to document it as a bug, but failed. Could it have to do with our fingers dangling on the trackpad? Just a thought.
Photo of Joey

Joey

  • 14 Posts
  • 2 Reply Likes
I wondered about that, but I use Kensington Trackball, So I don't suspect it to be fingers dangling on it. However, it does seem to happen when you hold the Left-Click for more than a moment.
(Edited)
Photo of Joey

Joey

  • 14 Posts
  • 2 Reply Likes
Yeah, at some point I'm going to do a screen grab of it so I can show Techsmith what is happening. What I don't know is, if it's confined to just the Mac version or if it's happening with both the Mac and Windows versions. It'll be interesting to find out.
Photo of Joey

Joey

  • 14 Posts
  • 2 Reply Likes
Okay. On the way.
Photo of davemillman

davemillman

  • 459 Posts
  • 138 Reply Likes
Joey's video shows what I've experienced, but I cannot reproduce the behavior on-demand like he did. My playhead occasionally jumps to the start of the timeline, just as shown in the video.
Photo of Gary Samuels

Gary Samuels

  • 1 Post
  • 0 Reply Likes
Any progress on this issue. It's so bad from me I almost can't get any work done.
Photo of Robert R.

Robert R., Online Community Admin

  • 1465 Posts
  • 414 Reply Likes
Hi Gary;

This is a topic that is best addressed by technical support; can you please open a Support Ticket so an agent can assist you?

-Robert
Photo of Francis Mella

Francis Mella

  • 15 Posts
  • 0 Reply Likes
I am having the same problem.  I find the exact spot where I want to edit the clip and then when I hover and grab the end of the clip the playhead moves to the start of the clip.   This is a bad situation!!  Get it fixed.
(Edited)
Photo of jeff

jeff

  • 1 Post
  • 0 Reply Likes
I am having the same problem. I created a screen recording using Camtasia 3 on MacBook Pro (2015). The cursor most often jumped when I was selecting a range to clip or edit (using the red and green markers). There was nothing special added to this recording. It was very simple - not even annotations - just screen video and microphone audio.