Properties Window Keeps Disappearing, Drives Me Nuts!!!

  • 1
  • Question
  • Updated 8 months ago
I have heard other people with this problem, but wonder is their a fix for it? Every time I load a new video, do something, render, etc. about 50% of the time the Properties window on the right side losses all its properties, I click on a track, unclick, click show properties, and nothing -- forces me to kill the application, reload -- slows me down and pisses me off.  This BUG is a HUGE problem this really hurts productivity -- this should be a 4 alarm emergency and I can't believe this hasn't been fixed in the latest version 9.x.x -- Anyway, have any tricks or tactics to get the properties back other than killing camtasia and restarting it?
Photo of ceo

ceo

  • 8 Posts
  • 2 Reply Likes
  • PISSED OFF

Posted 8 months ago

  • 1
Photo of Dave O'Rourke

Dave O'Rourke, Senior Software Engineer

  • 1417 Posts
  • 373 Reply Likes
The properties panel shows the properties for the selected item on the timeline.  Tracks do not have properties that show up in the properties panel, so if you're clicking on a track (and not on a media), then it's expected that nothing would show up in the properties panel.

If you're clicking on media and the properties panel is open but not showing properties for the selected item, then that would not be expected.  The only way that would happen is if one or more threads is hung (or stuck) and this is interfering with the correct operation of the properties panel.  If you believe you're hitting this situation, please get in touch with TechSupport at https://support.techsmith.com and they can help troubleshoot further.  If it looks like a bug in the software, it will be escalated so we can fix it.