Record from a Scheduled Task (Windows)

  • 1
  • Question
  • Updated 5 months ago
Hello All.
Windows 10 Pro
Camtasia Studio 9 (2018)

Following this link here.
https://support.techsmith.com/hc/en-us/articles/203728768-Camtasia-Windows-Schedule-a-recording-to-a...

I created the task.
I have the recorder opened.
And during the test, it does not start recording.
When it is scheduled to STOP, it asks to save the file, 
Even though I have it set to save automatically.
And it is trying to save a dead file, as there is nothing to save, as the recorder never started.
(cannot save the file anyway, as there is nothing in the file.)

Any idea's on getting this to work?
Thanks.
Wayne

Photo of wayne

wayne

  • 112 Posts
  • 30 Reply Likes

Posted 5 months ago

  • 1
Photo of Dubie

Dubie

  • 1285 Posts
  • 1035 Reply Likes
It sounds that you possibly don't have something set right.

The process works fine for me. Except I forgot to change my audio input and it didn't record any sound :(
But that's on me.

First... did you save the record and stop files as a .bat ? Not XXX.bat.txt

With Camtasia Recorder open, if you double click the "record.bat" file does Camtasia start recording?

If not check  the .bat code is right  and/or in the recorder Tools Options under the Program tab check that "Record screen after stating capture"
is Checked. If it isn't the recorder won't start recording without manual input to start recording.



Also while there make sure "Hide Preview" is checked and set to "Save"

As far as asking to save, check that the under the General tab that you are recording to .trec and Fix file name or Automatic file name is used.



Other than those few things to check over Go through the article again and confirm that the .bat files  code is correct and everything else is set correctly.

Let us know if you make it happen

:)

Photo of wayne

wayne

  • 112 Posts
  • 30 Reply Likes
Double-clicking the record.bat file, flashing a dos prompt, and then nothing happens after that.
So, I checked the file, and it was missing the opening double Quote "
So, I added that and double-clicked the file, and it started the recorder.

Now, running the task schedule does not [start] the recorder.
However, it does [Stop] the recorder.

Just not certain what is going on with it?
I have checked all my settings, and everything is correct.
Just not starting, but is stopping.

record.bat
"C:\Program Files\TechSmith\Camtasia 2018\CamRecorder.exe" /record
Stop.bat
"C:\Program Files\TechSmith\Camtasia 2018\CamRecorder.exe" /stop
(Edited)