Recording component not working in snagit 2019

  • 1
  • Problem
  • Updated 1 year ago
I bought shagit 2019 this morning from app store then a frustrating issue occurs. the recording component seem not correctly installed in myh mac hence snagit will repeatly asking me to download this from your website. My mac version is 10.14.5 ( the most recent one)  anyone can help ?  
Photo of quan.long

quan.long

  • 5 Posts
  • 1 Reply Like

Posted 1 year ago

  • 1
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1541 Posts
  • 391 Reply Likes
Hi,

Sorry about this, It's possible you're getting our old audio component which we don't use anymore. can you post the link that you're getting the component from?
Photo of quan.long

quan.long

  • 5 Posts
  • 1 Reply Like
Btw. the link I am getting from is by click the install recording component in the preference snagit 2019 .. I am not sure why I download the lated version but the corresponding plugin is outated..please verify if this is a bug or simply provide me a new component link . Thx a lot 
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1541 Posts
  • 391 Reply Likes
Thanks, that does appear to be the old link. The updated one is here https://www.techsmith.com/audio-capture-component.html

Sorry about this, I'll take a look into why the link is still the old one.
Photo of quan.long

quan.long

  • 5 Posts
  • 1 Reply Like
Hi Griffioen,
Thanks a lot it fix my issue. This is the reason why I stick to snagit . great stuff and great support . 
best
Photo of rumplesteel

rumplesteel

  • 22 Posts
  • 1 Reply Like
Usually when Apple upgrades sometimes the programs need an upgrade too, and they don't upgrade fast enough.
Photo of quan.long

quan.long

  • 5 Posts
  • 1 Reply Like
Well this time not the case cause My company also purchased snagit and it works totally fine .. when it comes to my personal purchase . it fails.