Removing the full screen option while playing html file

  • 1
  • Question
  • Updated 1 year ago
I'm producing MP4 Smart Player with ToC and sharing the html file within our company LMS. For the security reasons, I'd like to disable the Full Screen option in the url controller. I tried to uncheck the "Produce with controller" option under Controller tab, but it still appears when playing the html file.

I'm using Camtasia 9.

Any ideas? 
Photo of ces

ces

  • 5 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Dubie

Dubie

  • 1428 Posts
  • 1146 Reply Likes
First I'm a little confused by that you said

" I tried to uncheck the "Produce with controller" option under Controller tab, but it still appears when playing the html file

If you produce/render without the controls you should only get a single .mp4 file. No html file or any  other files. So not sure what html file you are trying.

When you produce with the controls you should get a folder with multiple files and the .mp4 video



Anyway to remove the Full Screen option you have to hack/modify one of the scripts that was produced.
There is no options to modify the player controls when you produce your project in Camtasia.

It's easy to do and straight forward. But you do this at your own risk. I imply no guarantees because you are editing a file that is out of my control.

FIRST... Before doing any changes  "MAKE A BACKUP COPY OF THE FILE" . That way if you do make a mistake you can just bring the backup back in and be back to square one.

1. Open the Scripts folder.

2. In a text editor of your choice ( you can use notepad but something like notepad++ or similar with syntax highlighting makes it easier) open the  "techsmith-smart-player.min.js"   file.




3. Do a search in the file for

<div class="fullscreen-wrapper"></div>\r\n

This is the area in the file you should be

Click image to enlarge:



4. Delete that line of code,  and Save (not Save As) .

Reopen the yourvideo.html file in a browser and the Full Screen option button should be gone.

:)

(Edited)
Photo of ces

ces

  • 5 Posts
  • 0 Reply Likes
Works as magic, thank you so much! About the confusion I commented below to Rick, it was my mistake. Thanks again Dubie!