Rendering on Nvidia GeForce GTX 960M

  • 1
  • Problem
  • Updated 4 months ago
I am thinking of buying Camtasia 2018 but the rendering performance on my laptop (even for small videos) is very poor. I tried everything to activate Hardware rendering:
In Nvidia Control Center I opted to start Camtasia with the Nvidia GPU:



In Camtasia itself I activated it:



But in the taskmanager it looks like my Core i7 is rendering it. A bit GPU load can also be observed:



Driver:






Photo of screener

screener

  • 12 Posts
  • 1 Reply Like
  • frustrated

Posted 5 months ago

  • 1
Photo of michael

michael

  • 2 Posts
  • 0 Reply Likes
Hi,
I would suggest finding the 'Power Options' in Windows, and setting the 'Processor Power Management' to 100%.  Laptops never have this set to 100% for battery use.   This might be your only free option.

My next suggestion is to get an SSD if you have a mechanical hard drive.  

If you can afford another computer, the low-end gaming computers work great.  I paid $700 for a new low-end MSI gaming laptop that renders quickly. 

I also cobbled together a used Pentium i5 server with 8GB RAM, a low-end SSD and a new $49 2GB graphics card from Amazon that renders fast too.  eBay and Craigslist ...

Best,

Michael
Photo of screener

screener

  • 12 Posts
  • 1 Reply Like
This was not my question. I already have a SSD.
Photo of Ed Covney

Ed Covney

  • 339 Posts
  • 223 Reply Likes
Michael - I think any laptop with a GTX 960M is likely as least as much as you suggest, i5, 8G

Screener - Is your windows up-to-date? Can you disable the Intel 4600 graphics card and re-try? (This may be the fix! )
How many physical disk drives do you have and are they SSDs? How much RAM do you have/available?

As to a possible bottleneck, this is easier if you can connect a 2nd monitor: Check your CPU, Disk, Memory and all apps running. Note - the memory, disk and CPU resource monitors are available in the TaskMan's "Performance" tab, very bottom. You can open multiple instances, adjust to your liking and save them to " .ResmonCfg " files. All told the 4 instances of Task Manager will use an additional 2 or 3% of your computing power, which because you have an nVidia GTX 960M , should NOT be a problem. HTH.



Photo of screener

screener

  • 12 Posts
  • 1 Reply Like
I have an ssd and also perfmon tells the same: CPU is the bottleneck.
For me it simply looks like that the geforce is not used.
Photo of michael

michael

  • 2 Posts
  • 0 Reply Likes
I agree with Ed - the GTX is fast enough ...  Also try installing the GTX software from the manufacturer to see if you can configure the second card ...

Michael
Photo of screener

screener

  • 12 Posts
  • 1 Reply Like
What do you mean by configure a second card? I already started camtasia with the gtx.
Photo of Joe Morgan

Joe Morgan

  • 7069 Posts
  • 3847 Reply Likes
I don't know what he's talking about? You can only utilize either the discrete Graphics card/cards. Or the integrated graphics.
If you had multiple Nvidia GTX cards they could work together.
Integrated and Discrete cards are Incompatible/cannot mesh and work together.  

As far as the suggestion to disabling the integrated card goes.
I highly suggest.......... DON'T DO IT! If your GTX dies your monitor will go black and there will be no way to see your screen after the fact.

Why? Because you killed the backup graphics card when you disabled it.
Took away it's capacity to come back online automatically if you remove the defective card from the system.
You could cost yourself a lot of problems.Good luck fixing that issue without a monitor.     
(Edited)
Photo of Ed Covney

Ed Covney

  • 328 Posts
  • 214 Reply Likes
Joe -  What???
Disabling one card does nothing permanent, if the nVidia goes bad, the BIOS will only see the 4600 and load it into the HAL (Hardware Abstraction Layer) whether it was previously disabled or not. The fact that both are listed tells me the BIOS needs a reset. If sceener knows how, turning it off in the BIOS is best.

Screener -
DISABLE THE 4600, preferably in BIOS if you know how. That should have been done at the factory before it entered the market.
Note: IBM standardized the HAL in 1980 and there's only room for addressing ONE graphics card
Here's a good write-up:  https://www.quora.com/If-you-have-2-graphics-cards-and-1-computer-how-can-you-use-them-at-the-same-t...
If you think there's a CPU bottleneck, that's easy to test.  Run the CPU resource monitor and watch it when using Camtasia.
Photo of Joe Morgan

Joe Morgan

  • 7069 Posts
  • 3847 Reply Likes
I see what you're saying. My integrated graphics card doesn't even show up in device manager.
Photo of screener

screener

  • 12 Posts
  • 1 Reply Like
I just tested Movavi editor it works like a charm and in task manager I can see that the GPU and not the CPU is used.
I will not disable my intel card because most of the time I use the integrated graphic card for my office work. Camtasia is set to use the geforce (in nvidia menu and in the camtasia options). If a video cutting tool is not able to render on a GPU then I will use another tool.
Photo of Clint Hoagland

Clint Hoagland, Employee

  • 56 Posts
  • 20 Reply Likes
Hi screener! 

Camtasia 2018 is definitely supposed to be using your video card in this scenario and from the posts in here I'm not sure why it isn't. Your best bet is to open a ticket at https://support.techsmith.com and our support staff can help you figure this out (or at worst escalate it to the development team that something we think should be working turns out not to be working). 

Thank you,
Clint Hoagland
Software Test Lead, Camtasia
TechSmith Corporation
Photo of screener

screener

  • 12 Posts
  • 1 Reply Like
Ticket is opened
Request #585677